Jump to content
modifiedcontent

Front-end editing 'No changes to save' error

Recommended Posts

Has anyone else seen front-end editing not working on certain pages? When I try to make an edit and click Save, I get a javascript pop-up with 'No changes to save'. Anyone have any idea what causes this? Javascript conflict maybe?

Share this post


Link to post
Share on other sites

I still haven't found a solution for this. Any suggestions what could cause it or how to troubleshoot it? Has anyone else seen this issue?

It works fine in some pages, but not in others. 

Share this post


Link to post
Share on other sites

I've had this issue on some occasions, though for me it's been more like "sometimes it works, sometimes it doesn't", rather than not working for some pages at all. Never could really debug what it was all about since these have been very random occurrences, but your guess about some sort of JavaScript conflict seems reasonable.

I've not had a proper look "under the hood" but I believe that front-end editing works by essentially duplicating your content behind the scenes, so the issue could also have something to do with the structure of the pages in question. Do they differ somehow from the pages where this works as expected?

When this happens, do you see any JS errors in the dev tools console? Do you have any particular JS libraries etc. loaded — jQuery and the likes? Also, which editing option are you using and which version of ProcessWire do you have installed?

Sorry for the load of questions — I'm really not sure what could cause this, but perhaps we can at least narrow it down a bit 🙂

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...