Jump to content
Spiria

FieldTypeCache and 3.0.152

Recommended Posts

I have switched to 3.0.152 and get this error when trying to edit any templates using a FieldTypeCache:

ProcessWire: ProcessPageEdit: Method FieldtypeCache::getFieldsTemplate does not exist or is not callable in this context

which returns not content at all.

1626243726_CleanShot2020-03-07at14_54_11.thumb.png.993af94f61bfbccec0668b36a23902a1.png

I have cleared all my caches, refreshed the modules, but to no avail. Switching back to the previous version (3.0.139) corrects the problem. 

 

Share this post


Link to post
Share on other sites

I can confirm this — looks like caching file or image fields in FieldtypeCache doesn't work as expected. Judging from the code changes this has likely been broken since 3.0.142.

@Spiria, would you mind opening an issue for this at https://github.com/processwire/processwire-issues?

Share this post


Link to post
Share on other sites
On 3/8/2020 at 3:22 AM, teppo said:

I can confirm this — looks like caching file or image fields in FieldtypeCache doesn't work as expected. Judging from the code changes this has likely been broken since 3.0.142.

@Spiria, would you mind opening an issue for this at https://github.com/processwire/processwire-issues?

Related Issue was opened

https://github.com/processwire/processwire-issues/issues/1113

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...