Jump to content

Cannot migrate from local to live

Recommended Posts

Hi, I have already tried in different ways and many times to migrate but I always have issues at the end.

Here's what I have done so far:


case 1:

1. Install PW on live server (all normal)

2. Import local DB into live DB

3. Front page site seems to work but I cannot login into admin page

case 2 (I'm currently on this stage):

1. Copied all files from local to live server

2. Import local DB into live empty DB

3. Front page works, but any other page and admin page are 404


In both cases:

- I have changed config.php info accordingly to live server (DB name, DB user and pwd, userauthsalt code)

- Uncommented RewriteBase / and RewriteBase /pw/ lines on .htaccess

- applied owner and group permissions to www-data for PW location

- applied permissions to folders and files accordingly

- applied a2enmod rewrite to apache2 on live server and restarted service


I have read some posts (Ryan's too) about migration and it seems to me that I'm doing it fine, don't know what it fails-

I'm on VMWare machine, Ubuntu Server 18.04, php 7.2, phpMyAdmin 5.0.1

Hope you can help me, thanks in advance

Share this post

Link to post
Share on other sites
11 minutes ago, alanxptm said:

I have changed config.php info accordingly to live server (DB name, DB user and pwd, userauthsalt code)

The userauthsalt has to be the same as on the dev environment if you copy the DB over!

If only the home page works, it's most likely a rewrite issue. If you installed in the root directory, RewriteBase is not needed. Otherwise, set it to the subdirectory your PW installation resides in.

Share this post

Link to post
Share on other sites

The issue is solved and it had nothing to do with ProcessWire.

Don't know why apache keeps reseting his <Directory /var/www/> conditions, just need to keep watching on rebooting.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By AML
      Small recruitment site (7 pages plus jobs) built bespoke in Processwire last year by an agency.
      The site is now underperforming. As a non-developer I am unable to have changes made without having to pay, which was not the original plan.
      The solution is to rebuilt most of the site in WorldPress (all set up), so I can manage and maintain it myself to improve on some sections and better SEO.
      To keep costs down (for obvious current reasons) I would like to learn the process and hand over some sections that need developing.
      I am looking for someone UK based who has experience of PW, WP and ideally recruitment agency experience (e.g. expiry of jobs, category pages etc.).
      Time - over the next 6 weeks.
      Pay - hourly rate or per project.
      If you are interested, please get in touch so I can let you have details.
      Thank you.
    • By rushy
      Hi. I've been using Processwire for a few years now and installed it on a few different shared hosting servers without issues, but I'm now running into an issue on a Fasthosts shared server that I've not seen before. The installation goes ok and I have a working default site profile but I am unable to complete any uploads of images. It just hangs at the progress spinner during the upload. I thought it might be a priviledge issue so have temporarily set the dir / file privs. as 777 / 666 just to test that but it made no difference. I have no errors in the wire log. In server error log I have:
      set_time_limit() has been disabled for security reasons in ....htdocs/wire/core/ImageSizerEngine.php on line 1035 and i note in the assets/file dir. where the image is being stored the date on the file being created has a year of 1970 and 0 length. If I leave the page this file disappears and nothing has been stored. 
      Does anyone know how I can enable set_time_limit if this is likely to be the problem? 
      Many thanks! Paul
    • By Robin S
      After forgetting the class name of the wonderful AdminPageFieldEditLinks module for what feels like the 100th time I decided I needed to give my failing memory a helping hand...
      Autocomplete Module Class Name
      Provides class name autocomplete suggestions for the "Add Module From Directory" and "Add Module From URL" fields at Modules > New.
      Requires ProcessWire >= v3.0.16.

      Install the Autocomplete Module Class Name module.
      Add Module From Directory
      Choose the type of autocomplete suggestions list: "Module class names from directory" or "Custom list of module class names". The latter could be useful if you regularly install some modules and would prefer a shorter list of autocomplete suggestions. The list of class names in the modules directory is generated when the Autocomplete Module Class Name module is installed. It doesn't update automatically (because the retrieval of the class names is quite slow), but you can use the button underneath when you want to retrieve an updated list of class names from the directory. Add Module From URL
      If you want to see autocomplete suggestions for the "Add Module From URL" field then enter them in the following format:
      [autocomplete suggestion] > [module ZIP url]
      Example: RepeaterImages > https://github.com/Toutouwai/RepeaterImages/archive/master.zip Awesomplete options
      The "fuzzy search" option uses custom filter and item functions for Awesomplete so that the characters you type just have to exist in the autocomplete suggestion item and occur after preceding matches but do not need to be contiguous. Uncheck this option if you prefer the standard Awesomplete matching. Custom settings for Awesomplete can be entered in the "Awesomplete options" field if needed. See the Awesomplete documentation for more information.  
    • By gregg
      While trying to install 3.0.123, i encountered the following error: 
           Parse error: syntax error, unexpected '[' in /home/naucom5/public_html/wire/core/FunctionsAPI.php on line 469
      In cPanel, i extracted the zip file to 'public_html', which created the directory 'processwire-master', and then moved the files from 'processwire-master' to 'public_html' (which previously had 1 unrelated directory).
      Installation went well choosing Uikit profile, including connecting to database. Compatibility check ok (mod_rewrite error cleared after recheck), successful database connection, config.php saved, unchecked a few cleanup items, then the error message.
      Any suggestions appreciated. 
    • By franciccio-ITALIANO
      Hi, I must change server provider.
      I don't want rewtrite all page and articles, what must I do?
      I download a database copy on my pc, and now?

  • Create New...