Jump to content
Peter Knight

WebP - server support

Recommended Posts

Is anyone here using WEBP as their output image format and what is your server / environment setup?

 I know there's support for it in PW lately and decided to investigate.

Found it quite difficult to do this on a practical level. IE My current VPS is Cent OS 6 and Plesk and unless I'm wrong, WEBP is not supported by either.

Which host and setup are you on that allows you to run WebP?

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

I'm using it on on multiple Linux servers with Apache configuration. Haven't done any other special updates to make it work, for what I understand if PHP has GD/imagemagick enabled it should all work.

Where I have not being able to configure it is on mixed nginx+apache configurations (like on Runcloud) because static assets are delivered by nginx rather than apache, so I just haven't had time to figure out how that would work. (using the htaccess configuration for delivering webp)

What issues have you encountered? I'm not sure I understand why CentOS/Plesk wouldn't support it. 

Share this post


Link to post
Share on other sites
19 hours ago, elabx said:

What issues have you encountered? I'm not sure I understand why CentOS/Plesk wouldn't support it. 

Just a general lack of support out of the box as @jacmaes mentioned. 

 

Share this post


Link to post
Share on other sites
2 hours ago, Peter Knight said:

Just a general lack of support out of the box as @jacmaes mentioned. 

Oh!! Unexpected! 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By eutervogel
      Hi, 
      what I'm doing is this:
       
      <picture> <source srcset="<?php echo $page->section_three->main_img->first()->size(396,710)->webp->url; ?>" type="image/webp"> <img class="p_absoulte pp_block" src="<?php echo $page->section_three->main_img->first()->size(396,710)->url; ?>" alt=""> </picture> and for some reason it sometimes becomes this:
      <picture> <source srcset="/site/assets/files/1057/sektion3_bild-1.396x710.png" type="image/webp"> <img class="p_absoulte pp_block" src="/site/assets/files/1057/sektion3_bild-1.396x710.png" alt=""> </picture> It seems to be related to ->size(). When I don't use ->size() the webp Url is correct.
      I'm using the image-field inside a Fieldset(Page). Could that be a problem too?
      I just increased the output size by 2px and voila the webp url comes up. 
      I deleted all variations (webp variation is present in correct size) changed it back to the original size and again: a png url.

      I also tried to rename the image and load it up agian. 
      ...same behavoir.
      Thanks in advance guys
       
    • By klikrzys
      Hello processwire world!
      Im having a little problem with getting my image in WEBP format.
      $image = $pages->get('/')->images->first();             echo $image->webp()->url();
    • By jacmaes
      One of PW 3.010's major novelty was the introduction of Horst's new image resizing engine that uses ImageMagick. Now I understand that ImageMagick can convert images to Webp, the image format that Google says can reduce image size up to 34% compared to JPEG.
      Mozilla is apparently adding support to Firefox, and even the Safari team is playing with it, so it looks like Webp is soon going to be available in most major browsers. If Horst's module can be extended to add Webp conversion, that would be a great addition to PW's already very powerful image manipulation arsenal. 
      I'm currently using the free ImageEngine Lite to serve Webp images to supporting browsers, and the results are impressive. I routinely get images that are between 25 and 60% smaller compared to JPEG, with the same visual quality. I would love to eliminate the need to rely on a third-party service though. 
    • By clsource
      Hello,
      Processwire its present in Cpanel's Softaculous
      https://www.softaculous.com/apps/cms/ProcessWire
      But It's not present in Plesk APS.
      I think it's a good idea to create such aps and sent it to plesk for including them in their
      aps system.
      here is some info that I found.
      http://download1.parallels.com/Plesk/Doc/en-US/online/plesk-aps-overview/index.htm?fileName=69262.htm
      http://doc.apsstandard.org/2.1/start/
      http://kb.sp.parallels.com/en/115664
      anyone has any experience creating aps packages?

    • By Peter Knight
      Hi all
      Does anyone here create their PW sites on Plesk (12) on Linux on a VPS? I have a general web dev question for you.
      When you've created a web space and installed PW, does the Plesk Preview link ever work for you?
      I'm really interested in this as I'm new to VPS and Plesk and seem to be having issues with PW sites prior to the DNS propagation.
      My hosting company is telling me this a Plesk "feature" while someone else blamed PW.
      For example, have a look at my own site which does have the DNS kicked in.

      Clicking Preview brings up my site but none of the CSS loads and the paths are clearly broken.

      I've tried numerous combinations of changing the rewrite base  and yet nothing works.
×
×
  • Create New...