Jump to content

Language Translation files no longer read/writeable after deployment on server


overoon
 Share

Recommended Posts

hi,

i tried finding something about the topic, but didnt manage to. i currently face (and already faced a couple of times) the issue of being unable to edit language files through the backend after i deployed the site to it's final hosting destination. i usually tended to just go through the process of manually re-inputting the phrases, but this site has a lot of translatables.

i work on a 2019 xampp environment (windows) for local development and the servers that i deploy to range from shared environments to dedicated servers, so i really cant pinpoint the issue on a specific server/php/sql. in this latest deployment, i also tried setting the chmod for the site/assets/1061/ files to 666 and dir to 777, which sadly didnt do anything either.

when i enter the backend and switch to languages i get a perfect list of all language files

image.thumb.png.6ac7af1ebfef0fcbef56814620feda50.png

but once i hit edit ("bearbeiten") this is what i get:

image.thumb.png.808cf719b2c38c587a312b3a98d6fbc1.png

 

the problem is: those files are there, and they do work (in the frontend) -- if i manually download the file, edit it and reupload it, it also does exactly what it should.

 

does anyone have a thought on this? my dev the site doesnt sit at the root, but it also doesnt in this specific deployment. absolute urls/roots have never been a problem in processwire before though.

could it have something to do with the / and \ -- and if so, how would i find those?

 

thanks and regards

 

Link to comment
Share on other sites

58 minutes ago, overoon said:

could it have something to do with the / and \ -- and if so, how would i find those?

 

I guess so. \ comes from your Windows install... Try to clear compiled files under modules (bottom of page). 

  • Like 1
Link to comment
Share on other sites

thanks for the tip, but the error is still there 😕

i now found the (only) occurence of these strings is in the .phrase-index.txt in assets/files/1061

even when find+replace \ to / i still get

image.png.0f72b2c24924e3f7d892d6a722c59145.png

also doing the replace + clearing the compiled files after doesnt change anything. from analyzing the file this also only really helps the live index, so perhaps not the right place to look at anyhow

any further suggestions? when i click on the file in the greenbar it opens right away, also the http url is correct. just this thing below has the \ /

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...