Jump to content

Recommended Posts

Hi there,

My form is not getting submitted, it is showing:

Unable to verify successful email delivery of this form submission.

Attaching for your reference as well: 

Screenshot_20191105-172804__01.thumb.jpg.5daa336b75626f275b0e79ded6074fe6.jpg

In the Backend, it is showing Connection timed out with smtp.gmail.com

Pl guide me how to resolve that

  • Confused 1

Share this post


Link to post
Share on other sites
2 minutes ago, Mithlesh said:

Hi @3fingers, can you help me for the same?

Please consider contextualize a bit more your situation, post some code. Are you using gmail as a service to send your email? Have you allowed then "unsafe" apps to use their smtp for that?
Lot of things to consider.

Share this post


Link to post
Share on other sites

@3fingers

Yeah, we are using gmail(smtp.gmail.com) and processwire is showing the below:

Screenshot_20191107-205139.thumb.jpg.76d20f5c5090831130a162b2b99efcee.jpg

I have checked Test settings function, it's showing SMTP settings appear to work properly.

Also, attaching the code's doc for your reference(module code) named: WireMailSmtp.module

WireMailSmtp.module

Edited by Mithlesh
Forgot to attach the code

Share this post


Link to post
Share on other sites

Your last screenshot says it's working.

So... what's the (new) issue now?

 

P.S.: there is no need for ASAP.

  • Like 2

Share this post


Link to post
Share on other sites
6 minutes ago, wbmnfktr said:

Your last screenshot says it's working.

So... what's the (new) issue now?

 

P.S.: there is no need for ASAP.

Okay 🙂

So, module settings is showing fine but when someone is trying to fill the form on the website(www.writerrelocations.com), it is like:

Unable to verify successful email delivery of this form submission

Share this post


Link to post
Share on other sites

Hi @Mithlesh,

Obviously It is nothing wrong with the WiresMailSmtp. There is some error about the submission of the form.

Please provide code about how your form constructed and the code about how you manage the form submit. Then we can give you some useful hints.

Gideon

  • Like 1

Share this post


Link to post
Share on other sites

If you are using FormBuilder you might want to take a look at the FormBuilder section of this forum as well. There are many solutions to all kinds of issues. I your case - but that is just a guess - it seems either your hosting is issues sending the mail (security modules in Apache maybe or missing modules) or your form wasn't embedded in the correct way. Saw this a few times when I added the form twice on a page or missed some scripts.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By abdulqayyum
      Hy Processwire community,
      There are some problem in fileCompiler cache.
      when i change under the directory \site\templates\ it must change under the directory /site/assets/cache/FileCompiler/site/templates/
      but it does not update and functionality working with /site/assets/cache/FileCompiler/site/templates/ directory.
       
      In this case please suggest me how i clear fileCompiler cache?
      what i have to clear it manually?
      Thanks AbdulQayyum.
    • By abdulqayyum
      Hy everyone,
      i am using loginRegister module for front-end user login.
      In this module user can login with Email/username, i am showing with Email. done
      but not showing Email in Forgotton Password section. there still showing with username.

      i want to show Forgotton Password with Email instead username. and should reset with email.

      please help me in this section, how i can set it with Email.

      Thanks AbdulQayyum.
    • By abdulqayyum
      Markup-Google-Recaptcha is not working with LoginRegister module in Forgotton Password Form.
      Here is my code
      wire-> modules -> process -> ProcessForgotPassword.php
      protected function step1_renderForm() {
              $form = $this->modules->get("InputfieldForm");
              $form->attr('action', './?forgot=1');
              $form->attr('method', 'post');
          
              $field = $this->modules->get("InputfieldText");     
              $field->attr('id+name', 'username');
              $field->attr('class', 'redesign-field forgotPassFeild');
              $field->setAttribute('placeholder', 'Username');
              $field->required = true;
              $field->label = $this->_("Forgotton Password");
              $field->description = $this->_("If you cannot remember your password to access the affiliates portal. simply provide your username in the box below and we'll send you a reset link via email.");
              $form->add($field);
               
             // Calling MarkupGoogleRecaptcha Module.
              $captcha = $modules->get("MarkupGoogleRecaptcha");
             //  rendering form with recaptcha
              $captcha->render($form);
         
              $submit = $this->modules->get("InputfieldSubmit");
              $submit->attr('id+name', 'submit_forgot');
              $form->add($submit);
              $this->session->userResetStep = 1;
               
              // rendering form
               $out .= $form->render();
          
              // getting captcha script
              $out .= $captcha->getScript();
              return $out;
          }

      I am following this one example.

      please suggest me how i can show MarkupGoogleRecaptcha in forgotton password.
      Getting log error


      Thanks,
      Abdul Qayyum
    • By CareerTeam GmbH
      Hi there,
      We are an executive search agency based in Germany looking for a freelancer (2-5 days per week) supporting us with the development and design of our websites. The position will be located in Hamburg, Germany and it would be great if you are on short call. German language knowledge is mandatory. 
      You can reach me via email jobs@careerteam.de.
      Thank you!
      Regards
      Annemie
    • By Sephiroth
      Hi guys, so since I moved to Processwire, it has been my default go-to CMF/CMS for my website and client applications, apparently my previous job took a toll on me, and made me have less time, but now finally had the chance to change my website to something I always had in mind.
      I decided to go with something minimal, as I tend to enjoy writing, so wanted a website to have more text than graphics and I think I whipped up something clean. Currently I still have more to do, but this is my current website, the main purpose to have a content driven website where I will be writing tutorials , articles more and hopefully  technical  notes.
      Please let me know your honest opinion.
      PS: I am more of a coder than a designer but i think this old dog still pulled it off
       
      https://okeowoaderemi.com/
       
       




×
×
  • Create New...