Jump to content
Martin Wuehr

Upload Images on one Template doesn't work anymore | Not enough memory to load/resize

Recommended Posts

Hello everybody,

I'm hosting a Processwire Installation for a client. It runs on Processwire 2.5.3. Over the years everything was fine but now there is an issue with one Image-Field in one Template. Trying to upload an Image the Error "Not enough Memory to load/resize" occure. Other Image-Fields in all other Templates working without any issue. The Images I Tried to upload are very small (600px * 420px). The Images blongs to a News feed, and worked before.

I read about the problem in the forum but I can't get this solved. I have no access to the php.ini to modify the memory_limit.

I tried to update the Processwire Verion but failed. (Tried 2.7 /2.8 / 3.2) Got Always Internal Server Error and in the error Log: 

Compile Error:     Cannot redeclare PageEditFieldPermissionConfig()….

Has anybody any idea how I can get this solved?

Thank you so much



Share this post

Link to post
Share on other sites

try to increase the memory limit via .htaccess file

php_value memory_limit 256M

and check it by looking to the phpinfo() before you try to increase and afterwards, if it does take effect.

  • Like 1

Share this post

Link to post
Share on other sites

Thank you for your answers,

regarding to php info the Memory Limit is set to -1. So no Limit?

When I try to set the Limit via .htaccess to 256 a internal Server Error occure. the site is no longer reachable.

The strange thing is, other image fields in the Installation working just fine. These are also fields with bigger Image to load. So how can the php Limit an issue?

When integrating one of the other (working) Image fields in the template where the problem is, it's also not possible to upload an Image. So it's more a problem of the template?

Thank you



Share this post

Link to post
Share on other sites

What does the full error message say?
Are there any permissions set in that field or template or user?
Have you tried another image?
How large is your image - MB and pixels?
Can you switch to a more recent PHP version (your 5.6 seems a bit dusty)?

Also check upload_max_filesize and post_max_size.

Share this post

Link to post
Share on other sites


The error is: imagename - not enough memory to load / resize

There are permissions set for roles which have access to this template.

I tried other images too. All Image are small 640px * 480px with ~ 60kb - 80kb (jpg / 72dpi / rgb 8bit)

We can't upgrade the PHP Version here. (for complex reasons)

post_max_size and upload_max_filesize are 64M

The Image field was working fine. It belongs to a news feed. At one point it stoped working.


Share this post

Link to post
Share on other sites
9 minutes ago, Martin Wuehr said:

The Image field was working fine. It belongs to a news feed. At one point it stoped working.

Ok... well... I don't know. 

There are only a few things and thoughts left so far.

  1. check what has changed in the last days/weeks since it broke
  2. maybe GD or ImageMagick (don't know if this exists in 2.5.x) are failing
  3. ask the hosting company if there were any changes (security efforts, file scanners, whatever)
  4. remove any restrictions on that field
  5. use another browser
  6. use another user
  7. check console for errors
  8. check disk space

Last and final thought:

Make a backup, test it locally and take it apart.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By horst
      Hi, on a site I want to disable access to original images and only allow to access thumbnails and watermarked image variations.
      A good solution for protecting original images can be found a bit down in this thread:
      Old content of this initial post:
    • By Guy Incognito
      I seem to be running into a repeated fatal error in a fresh PW install version 3.0.148. I can't quite put my finger on the pattern but it seems to be around deleting image fields or removing images from certain image fields.
      This is the trace from the log generated by trying to save a page and delete an image from an image field:
      Fatal Error: Uncaught Error: Cannot access protected property Pageimage::$original in /wire/core/PageimageVariations.php:256 Stack trace: 1. /wire/core/Pageimage.php(1327): PageimageVariations->getInfo() 2. /wire/core/Wire.php(386): Pageimage->___isVariation() 3. /wire/core/WireHooks.php(823): Wire->_callMethod() 4. /wire/core/Wire.php(450): WireHooks->runHooks() 5. /wire/core/Pageimage.php(1369): Wire->__call() 6. /wire/core/Pageimage.php(399): Pageimage->getOriginal() 7. /wire/core/WireData.php(333): Pageimage->get() 8. /wire/core/PageimageVariations.php(256): Pro Line 256 of /wire/core/PageimageVariations.php Earlier in the day I was experimenting with custom fields for images for the first time and kept running into this error, thinking it was me using this feature wrong and not having time to read up I deleted the custom image fields template and went about my business. So now I don't know if I triggered an issue or whether it was never related to the custom image fields in the first place?
      Any ideas?
    • By humanafterall
      I'm using some Custom fields for images: 

      When I save the page, and return the fields are blank. When I re-add the text to the fields and save again then the fields save as expected.

      I know this is stated as being quite experimental but it's super useful feature I'd love to get working correctly.
      I have fields that are CKEditor fields but have overidden this on the image specific template. I've also tried it with regular text fields and I get the same bug.
      (currently using Processwire 3.0.155)
      I've found this issue is specific to editing on pages using the PageTable fieldtype. The fields are not saving when I save the page in the PageTable.
    • By Robin S
      Displays image tags overlaid on the thumbnail using customisable colours. This makes it easier to see which images have which tags without needing to open the edit pane for individual images or changing to the list view.

      Enable tags for one or more image fields. Install the Image Thumbnail Tags module. Optionally configure colours for any of your tags.
    • By EyeDentify
      Hello dear PW gurus.

      I have stumbled over a strange error that i all of sudden got when trying to upload an image to a images field on a page.
      There where images allready stored in the field that i wanted to keep, but during the upload the error apear and after that all images are gone from the field and i can´t upload any, i just get the error every time.
      I am running ProcessWire 3.0.153 dev.
      After looking in the assets folder i find the folder for the page and the image files seems to be there including the ones i tried to upload when the error occured.
      But they don´t show up in the images field in the page editor.
      The error reported:
      SQLSTATE[01000]: Warning: 1265 Data truncated for column 'ratio' at row 1 And here is a screenshot of the event:

      The TracyDebugger Error reporting:

      I hope you fine folks could point me in a direction.
      But it seems our old pal set_time_limit() is back.

      Regards, EyeDentify
  • Create New...