Jump to content
tonicastillo

Image meta description corrupted

Recommended Posts

Hi. Can I ask why this happens?

When I upload a jpg, the meta keywords and description of the file loses the accents and spanish symbols of the words.

Original image on the left, and the image generated by PW on resize on the right.

Imagen_4_7_19_13_03_pegada.thumb.jpg.bf0115c323d47064b12340f0589c37f1.jpg

This happens on resize. The uploaded file is ok.

How can I control which meta keep in the photo?

Thanks a lot (and sorry for my English)...

Share this post


Link to post
Share on other sites

Hi @tonicastillo,

I'm not sure, but it looks like something in your workflow is not utf-8 save. Can you send me one original (uploaded) image, where this happens? You can use PM or my email address, if you like: https://nogajski.de/contact/

Thanks.

  • Like 1

Share this post


Link to post
Share on other sites

@tonicastillo Many thanks for sending me your images.

I have tested with the original image on windows and on linux. My variations always had correct and 100% identical iptc metadata as the original has. (see my screenshot via PM).
It seems you have to control which part within your workflow chain is not properly set to UTF-8.

If you are using PW >= 3.0.132, you can use the following code to get direct debug output from images and variations:

    $image = $page->images->first();            // get the original image, (adapt to your needs!)

    //echo $image->getDebugInfo();              // THIS MUST BE OMMITTED, BECAUSE I FOUND SOME SORT OF "STATIC" BUG WITH THE NEW DEBUG-METHOD

	$options = ['forceNew' => true];
    $variation = $image->width(300, $options);  // create / recreate a (new) variation
    echo $variation->getDebugInfo($options);    // debug output

Parts you need to check can be the OS default charset and/or codepage, PWs php files, the Webserver DefaultCharset, etc.

In the modules directory you can find a useful set of inspection tools: https://modules.processwire.com/modules/process-diagnostics/ that assists in some parts.
It has diagnostics for PHP, Webserver, Filesystem, etc.

 

--------------------

PS: Normally it should be possible to query debugInfo for multiple images one after each other, but an optimization error has crept in

Edited by horst
  • Like 1

Share this post


Link to post
Share on other sites

Hi @horst.

The image debug info is everything ok. And the process-diagnostics plugin doesn't detect any problem.

I'll check my workflow chain

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By arnd
      Hi,
      I have a repeater with some images in it.
      As Superuser I can work with the Actions (rotate...). But my Users with lower Rights can't use this Actions.
      The same User can use the Actions on images outsite a Repeter-Field. So I think it's not a Problem of Rights-Management but from Images in Repeater Fields.
      ProcessWire 3.0.164.  Bug? Or can I manage this in the settings?
      Thanks in advance
    • By Mats
      BETA: SplashAndGrab
      https://github.com/madebymats/InputfieldSplashAndGrab
      This module attaches a search input to selected image fields that lets you search and download images from Unsplash.
      (Unsplash is a stock photo service where you can download images for free and use as you wish. No strings attached.)   
      You can search by string, colors, orientation/crop and order by relevance or time published
      I find Unsplash useful both for placeholder images when building sites but also as a time saver for editors if they don’t have any images at hand, just search, download and publish.

      Thanks to @apeisa for building the  FlickrInputField Module and @Robin S for AddImageUrls,  took a lot ideas and code from those modules.
    • By markus_blue_tomato
      We have created a module to create BlurHash strings for images while uploading in ProcessWire. This blurry images will be saved in the database because they are very small (20-30 characters) and can be used for Data-URL's  as placeholders for image-lazy loading.
      https://github.com/blue-tomato/ImageBlurhash
      E.g. where we use this in production:
      https://www.blue-tomato.com/en-INT/blue-world/ https://www.blue-tomato.com/en-INT/blue-world/products/girls-are-awesome/ https://www.blue-tomato.com/en-INT/buyers-guides/skateboard/skateboard-decks/ https://www.blue-tomato.com/en-INT/team/anna-gasser/
    • By EyeDentify
      Hello dear PW gurus.

      I have stumbled over a strange error that i all of sudden got when trying to upload an image to a images field on a page.
      There where images allready stored in the field that i wanted to keep, but during the upload the error apear and after that all images are gone from the field and i can´t upload any, i just get the error every time.
      I am running ProcessWire 3.0.153 dev.
      Update:
      After looking in the assets folder i find the folder for the page and the image files seems to be there including the ones i tried to upload when the error occured.
      But they don´t show up in the images field in the page editor.
       
      The error reported:
       
      SQLSTATE[01000]: Warning: 1265 Data truncated for column 'ratio' at row 1 And here is a screenshot of the event:

      The TracyDebugger Error reporting:

      I hope you fine folks could point me in a direction.
      But it seems our old pal set_time_limit() is back.

      Regards, EyeDentify
    • By rushy
      Hi all
      Continuing my first project where I am creating and manipulating stuff from the frontend. Till now I've always added things like images from the backend, but in this project I need to add and move images from a frontend control. This is a photo album where images are stored in albums, each album being a page containing a Pageimages array in the usual way. So what I want to know is how do I move an image from one album (page) to another in the frontend? I just need some guidance on how to approach this.  I suppose I need to do a copy and delete - but how do I copy an image or images from one page to another? What function should I use to create a new image on an existing page? I include a code snippet from the server side of my delete image request and it works fine. I'd like to implement something similar for a move and upload new image request. 
      Many thanks for any help. Paul 
      <?php namespace ProcessWire; // sanitize inputs as 1-line text $action = $sanitizer->text($input->post('action')); $instr = $sanitizer->text($input->post('input')); $sel = $input->post('selected'); // Expect JSON for image selected image list $selected = json_decode($sel); $nosel = count($selected); $response = array(); // for building JSON response switch($action) { // delete selected images case 'delete': $out = "<p>Deleted $nosel image(s)</p>"; foreach($selected as $item){ $album = $pages->get($item->album); $album->of(false); $out .= "<p>Image {$item->file} from album {$album->title}</p>"; $album->images->delete($item->file); $album->of(true); } $out .= saveUpdatedAlbums($pages, $selected); // add the response message for the delete $response['message'] = $out; break; ...... // save any album that had an image deleted function saveUpdatedAlbums($pages, $selected) { $cur = ''; $out = ''; foreach($selected as $item){ $album = $pages->get($item->album); if($album->id != $cur) { $album->of(false); $album->save('images'); $album->of(true); $cur = $album->id; $out .= "<p>Updated album {$pages->get($cur)->title}</p>"; } } return $out; }  
       
       
×
×
  • Create New...