Jump to content

Error when uploading files containing © symbol in file name


Recommended Posts

What kind of error? What did it say?

Just tried to upload files with © in it and... well it worked as expected. The © was translated to c.




In this case I'm using ProcessWire 3.0.123.

Update: tried it on a 3.0.98 now and even there it works without problems.


Link to comment
Share on other sites

I believe it has something to do with the server.
My local copy of the site (3.0.98) translated the © into a c, too.
There isn’t any explaining error message, just „invalid image“ (see German screenshot).

When I remove the © from the filename it’s uploaded without any error.
I also tried other filenames containing Umlauts like ä or special symbols like @ – this works.
A symbol like the „Registered Mark“ ® produces the same error like the ©.

It’s not a big thing, my client can rename the files, but it would be nice to know why this happens only to this kind of letters.


Bildschirmfoto 2019-06-18 um 12.53.57.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...