Jump to content
MarkE

Linking in CKeditor

Recommended Posts

The link insertion provided by CKEditor in ProcessWire gives an option to link to a page as well as an external url. This works fine when used in a field that will appear in the website, but, as it is a relative url, it does not work if clicked from outside the site. I am creating email texts in a Processwire page and then sending them. If I link using the "select page" option then the link does not work for the recipient. Is there a simple way of fixing this or do I just have to remember to put in the full link manually (or write some code to parse and enhance the email text)? The same problem occurs if linking to a file.

Share this post


Link to post
Share on other sites

You can choose between absolute and relative link types in ProcessPageEditLink module settings. 

Share this post


Link to post
Share on other sites

Or you can make such replace only for your email body text.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the linked discussions - I hadn't seen those. I do agree that "absolute" in the options needs clarification. Looks like I'll need to do a bit more php...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...