Jump to content

Persistent error


Peter Knight
 Share

Recommended Posts

Occasionally when I goto Modules > Upgrades I get the following type of error.

There's actually about three of them and each one mentions a different line. In the example below, line 266 is

$new = version_compare($versions[$name]['remote'], $versions[$name]['local']);

 

( ! ) Notice: Undefined index: local in /Users/peterknight/Sites/mysite.com/site/assets/cache/FileCompiler/site/modules/ProcessWireUpgrade/ProcessWireUpgradeCheck.module on line 266
Call Stack
#	Time	Memory	Function	Location
1	0.0011	405040	{main}( )	.../index.php:0
2	0.2602	5197688	ProcessWire\ProcessPageView->execute( )	.../index.php:55
3	0.2602	5198064	ProcessWire\ProcessPageView->__call( )	.../index.php:55
4	0.2602	5198064	ProcessWire\WireHooks->runHooks( )	.../Wire.php:442
5	0.2603	5198480	ProcessWire\ProcessPageView->_callMethod( )	.../WireHooks.php:733
6	0.2603	5198480	ProcessWire\ProcessPageView->___execute( )	.../Wire.php:383
7	0.3009	5463888	ProcessWire\Page->render( )	.../ProcessPageView.module:209
8	0.3009	5463944	ProcessWire\Page->__call( )	.../ProcessPageView.module:209
9	0.3009	5463944	ProcessWire\WireHooks->runHooks( )	.../Wire.php:442
10	0.3015	5465248	ProcessWire\PageRender->renderPage( )	.../WireHooks.php:834
11	0.3015	5465624	ProcessWire\PageRender->__call( )	.../WireHooks.php:834
12	0.3015	5465624	ProcessWire\WireHooks->runHooks( )	.../Wire.php:442
13	0.3016	5466040	ProcessWire\PageRender->_callMethod( )	.../WireHooks.php:733
14	0.3016	5466040	ProcessWire\PageRender->___renderPage( )	.../Wire.php:383
15	0.3032	5470760	ProcessWire\TemplateFile->render( )	.../PageRender.module:514
16	0.3032	5470816	ProcessWire\TemplateFile->__call( )	.../PageRender.module:514
17	0.3032	5470816	ProcessWire\WireHooks->runHooks( )	.../Wire.php:442
18	0.3033	5471848	ProcessWire\TemplateFile->_callMethod( )	.../WireHooks.php:733
19	0.3033	5471848	ProcessWire\TemplateFile->___render( )	.../Wire.php:380
20	0.3036	5493112	require( '/Users/peterknight/Sites/mysite.com/site/assets/cache/FileCompiler/site/templates/admin.php' )	.../TemplateFile.php:287
21	0.3038	5493616	require( '/Users/peterknight/Sites/mysite.com/wire/modules/AdminTheme/AdminThemeUikit/controller.php' )	.../admin.php:15
22	0.3038	5495120	require( '/Users/peterknight/Sites/mysite.com/wire/core/admin.php' )	.../controller.php:15
23	0.3085	5586144	ProcessWire\ProcessController->execute( )	.../admin.php:135
24	0.3085	5586200	ProcessWire\ProcessController->__call( )	.../admin.php:135
25	0.3085	5586200	ProcessWire\WireHooks->runHooks( )	.../Wire.php:442
26	0.3085	5586616	ProcessWire\ProcessController->_callMethod( )	.../WireHooks.php:733
27	0.3085	5586616	ProcessWire\ProcessController->___execute( )	.../Wire.php:380
28	0.3108	5596744	ProcessWireUpgrade->execute( )	.../ProcessController.php:333
29	1.2224	8773000	ProcessWireUpgradeCheck->getVersions( )	.../ProcessWireUpgrade.module:187
30	1.2227	8776256	ProcessWireUpgradeCheck->getModuleVersions( )	.../ProcessWireUpgradeCheck.module:185

I've been living with it for a while and while it doesn't seem to stop me upgrading etc, I'd love to fix it.

Anyone recognise this type of error?

Link to comment
Share on other sites

26 minutes ago, Peter Knight said:

site/assets/cache/FileCompiler/

I don't recall ever having seen this particular error, but I suggest you hit the "clear compiled files" button every once in a while. (at the very bottom of the modules overview page, where it says: "The button below clears compiled site modules and template files, forcing them to be re-compiled the next time they are accessed. Note that this may cause a temporary delay for one or more requests while files are re-compiled.")

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By prestoav
      Hi all and happy Christmas!
      I have an odd problem upgrading a site from 2.7.2 to 3.0.62. I've never had an issues upgrading PW versions before!
      Here's the error report:
      Fatal error: Exception: Unknown Selector operator: '' -- was your selector value properly escaped? field='1', value='', selector: '1' (in /Applications/MAMP/htdocs/idreamav/wire/core/Selectors.php line 396) #0 /Applications/MAMP/htdocs/idreamav/wire/core/Selectors.php(439): ProcessWire\Selectors->create('1', '', '') #1 /Applications/MAMP/htdocs/idreamav/wire/core/Selectors.php(159): ProcessWire\Selectors->extractString('1') #2 /Applications/MAMP/htdocs/idreamav/wire/core/Selectors.php(145): ProcessWire\Selectors->setSelectorString(Object(ProcessWire\Page)) #3 /Applications/MAMP/htdocs/idreamav/wire/core/PagesLoader.php(217): ProcessWire\Selectors->init(Object(ProcessWire\Page)) #4 /Applications/MAMP/htdocs/idreamav/wire/core/Pages.php(232): ProcessWire\PagesLoader->find(Object(ProcessWire\Page), Array) #5 /Applications/MAMP/htdocs/idreamav/wire/core/Wire.php(386): ProcessWire\Pages->___find(Object(ProcessWire\Page), Array) #6 /Applications/MAMP/htdocs/idreamav/wire/core/WireHooks.php(698): ProcessWire\Wire->_callMethod(' in /Applications/MAMP/htdocs/idreamav/index.php on line 64 For my eyes it looks like a selector format somewhere. I've been through all of the site templates and can; see anything wrong and they were all working under 2.7.2.
      Anyone have any ideas?
    • By prestoav
      Hi everyone,
      PW version 3.0.123
      I've recently tried to upgrade the Blog module in an installation from 2.4.0 to 2.4.5 and now get the following errors when trying to visit Blog > Posts in admin:
      Fatal Error: Uncaught Error: Call to a member function count() on null in /MYSITE/site/modules/ProcessBlog/ProcessBlog.module:1299 Stack trace: #0 /MYSITE/site/modules/ProcessBlog/ProcessBlog.module(1421): ProcessWire\ProcessBlog->renderItemsSummaries(Object(ProcessWire\PageArray)) #1 /MYSITE/site/modules/ProcessBlog/ProcessBlog.module(1989): ProcessWire\ProcessBlog->renderItemsList(Object(ProcessWire\PageArray)) #2 /MYSITE/wire/core/Wire.php(380): ProcessWire\ProcessBlog->___executePosts() #3 /MYSITE/wire/core/WireHooks.php(723): ProcessWire\Wire->_callMethod('___executePosts', Array) #4 /MYSITE/wire/core/Wire.php(442): ProcessWire\WireHooks->runHooks(Object(ProcessWire\ProcessBlog), 'executePosts', Array) #5 /MYSITE/wire/core/ProcessController.php(333): ProcessWire\Wire->__call('executePosts', Array) #6 /MYSITE/wire/core/Wire.php(380): ProcessWire (line 1299 of /MYSITE/site/modules/ProcessBlog/ProcessBlog.module) This error message was shown because: you are logged in as a Superuser. Error has been logged. I can see posts in Blog > Dashboard and all seems to work still on the front end.

      Anyone else seen this or know of a fix?
    • By muzzer
      Existing PW site version 2.7.2 core running on php7.1. Site is perhaps 7 yrs old and never misses a beat. Can't speak highly enough about this solid version, but....
      As new php versions are released (v8 in the next year I think?) and each seems to get quicker I'm looking at upgrading to php7.3 or 7.4 and upgrading the site to PW v3.x.
      I've been away from the forums since v3 was released so don't know much about it. I guess it's stable as it's been around for ages now, but what I'm wondering is:
      what are the real advantages of upgrading to v3 for a site which is actively used but with only periodic development. And what are the disadvantages if any? Is there any speed impact (good or bad) in either general site speed under 3.x or admin-use speed/ease of use? any issues with either PW version with newer php versions (>7.1) I should know about? is there any good write-ups/vids about new features etc of v3 compared to v2.7? Thank you
       
    • By BFD Calendar
      I'm still wrestling with the upgrade troubles on OVH.com hosting. I manually upgraded to PW 3.0.98 and Upgrade module 0.0.7. Checking upgrades gives me an "Error loading GitHub branches - https://api.github.com/repos/processwire/processwire/branches - HTTP error(s): 2: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version, 2: fsockopen(): Failed to enable crypto, 2: fsockopen(): unable to connect to ssl://api.github.com:443 (Unknown error) - Check that HTTP requests are not blocked by your server.".
      Upgrading or installing other modules doesn't work either. I know it probably has to do with some provider setting on OVH.com, but I've tried several things mentioned in the ProcessWireUpgrade support forum, all to no avail. Server is configured to use PHP 7.0. If anyone here is also on OVH.com and knows a solution I'd be most happy to hear about it.
    • By louisstephens
      So I recently upgraded my sandbox environment to the latest master version from .62(?). I logged in and received the following error:
      "There appear to be multiple copies of module "AdminThemeUikit" on the file system."
      Unfortunately, in my haste, I removed the theme from site->modules so it doesnt exist anymore, and the theme has defaulted somewhat to the old theme. Is there a way to restore UIkit as the theme for processwire natively, or do I need to completely re-install?
×
×
  • Create New...