Jump to content
PhotoWebMax

Blurry gallery image thumbnails?

Recommended Posts

Hi All,

Getting back to a working project. I have a working image portfolio system that uses the Lightbox2 jQuery script. The gallery works fine, it displays the full size images well and loading them to the site via Processwire is ok. The issue is that the generated thumbnails are very blurry?

This is the relevant chunk of code I am using in my gallery template:

  foreach ($images as $image) {        
        // create/get image thumbs
        $thumb = $image->size(100,100,$options=array('sharpening' => 'none','defaultGamma' => -1,'quality' => 100,)); 

I initially had the thumbnail dimensions larger at 120x120 but reduced the size to what is show above. The page has reduced the size correctly but the quality of the thumbnails is still bad, quite soft. 

Is this a PW issue, an issue with my template code, or something I need to track down or adjust in the  Lightbox2 jQuery script?

Thanks!

Share this post


Link to post
Share on other sites

@PhotoWebMax

Are you on GD or ImageMagick? Second should produce better results. Also, try to set sharpening to 'soft' which is PW default.

  • Like 1

Share this post


Link to post
Share on other sites

In addition to Zeka's reply, 100 or 120 pixels are not really the dimensions where one can expect sharp images without additional sharpening, so using "none" is not a good idea. Also, you might want to serve @2x resolutions for retina displays.

Share this post


Link to post
Share on other sites

Thanks Guys.

I will try some experimentation today. 

What I did late last night was adjust the sharpening to "strong" inside the foreach code. I kept the size the same at 100x100 and uploaded a new image. It looks better, definitely better than before. I will try different sharpening levels at 120, 150, etc sizes and see how it renders. 

I am using the default PW install, no extra Modules for images and the thumbnails. Zeka, I am not even sure what GD or ImageMajick is? I am using the Lightbox2 jQuery script to present the gallery slide show, but the PW foreach statement is generating the thumbnails.

Some of the new gallery scripts I see create (or use) really large thumbnails in a tight grid system that then links to a traditional Lightbox display for the full size images. My own personal view is that presenting overly large thumbnails can result in viewers not to even bother with viewing the image images at their full size? Most server generated thumbnails will have some level of pixel changes and compression when compared to the full size images that might have been processed more carefully. 

I would be interested if there is way for the thumbnails to have extra resolution (for detail and crispness) for retina displays without making them larger (width x length)?

 

Thanks!

Share this post


Link to post
Share on other sites

Quick update: I set the thumbnail sharpening to "medium" and the sizes to 150x150 and there its a noticeable improvement. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...