adiemus

No admin login after server change

Recommended Posts

Hello,

my site was moved to another server. They didn't informed me before.

From this moment on it was not longer possible to login into admin page. Site is working. The problem is only with the admin page.

Error is processwire/login/ was not found.  I didn't found this directory on the server.

Anyone any idea for this case?

Share this post


Link to post
Share on other sites

check your .htacces file. Is mod_rewrite enabled? are other urls working fine?

Share this post


Link to post
Share on other sites

mod_rewrite is enabled and other urls are working. If i install processwire completely new login is possible.

For admin login I have enabled HTTPS only. With new server I got a certificate warning. Could this be a reason?

Share this post


Link to post
Share on other sites

normally the backend login url is /processwire and not processwire/login /.

Did you tell your browser to accept the certificate anyways? Then it should work. 

Else do you have access to the files via FTP? Then you can insert following code into a template file to echo the admin url:

echo wire('config')->urls->admin;

 

Share this post


Link to post
Share on other sites

I accept the certificate anyway.

Admin url is correct. FTP access is aviable.

I call the admin page by www.xyz.de/processwire and get the massage for /processwire/login. The error-message is a message from apache.

Share this post


Link to post
Share on other sites
5 minutes ago, adiemus said:

. The error-message is a message from apache.

  1. What is the exact error message?
  2. What do Apache error logs say?
  3. What is chrome/firefox showing in network tab? 403?

Maybe temporarily set debug on in /site/config.php to see if you can get a better error message (I doubt though, since it seems this is stemming from a server mis-configuration and ProcessWire does not even come into play)

  • Like 1

Share this post


Link to post
Share on other sites

1. Exact error message:

Not Found

The requested URL /processwire/login/ was not found on this server.
Apache Server at Port 443

2. At the moment I have no acces to apache logfiles. But I attempt to request them.
3. Networt tab shows error 404.
It starts with a http 1.1 get request for the admin page (/processwire).
Next request is a http 2.0 get for /processwire/login.

Share this post


Link to post
Share on other sites
45 minutes ago, adiemus said:

It starts with a http 1.1 get request for the admin page (/processwire).
Next request is a http 2.0 get for /processwire/login.

This part sounds somewhat curious. HTTP 1.1 request to /processwire (seems to work), then HTTP 2.0 request to /processwire/login (doesn't work) – is it possible that the server is not properly configured to handle HTTP/2? What happens if you directly request /processwire/login/, i.e. type it to the address bar instead of /processwire/?

Also, just to clarify: when you enter /processwire/ you get the error for /processwire/login/ right away? You didn't even see the inputs for username and password? If so, it might also be that there's something in the site or browser cache that breaks things.

If your site is using default session management, i.e. files on the disk, you could start by clearing /site/assets/sessions/ of any session files currently in there. Also make sure that there's nothing odd in your browser cache by clearing that as well, or opening the admin in an incognito tab or something similar. If you've enabled database sessions, you'd probably have to clear them manually from the related database table (haven't used this feature, so not sure how exactly).

By the way, the certificate error doesn't sound too good either. Did you have a certificate set up on the old server, and can you set up one on the new one as well? Although this seems unlikely, one possibility is that the server isn't properly serving HTTPS content.

This is somewhat off-topic, but it seems really strange that a hosting company (assuming that this is the case) moves the site to a new server without informing you, and without providing proper support, or even making sure that things work as expected after the move. When that kind of thing happens, you might be better off looking for a new hosting provider. Just saying.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, adiemus said:

Not Found

The requested URL /processwire/login/ was not found on this server.
Apache Server at Port 443

 

17 hours ago, adiemus said:

For admin login I have enabled HTTPS only.

 

1 hour ago, teppo said:

one possibility is that the server isn't properly serving HTTPS content.

I think this is the issue (HTTPS would pass through Apache port 443 as opposed to normal port 80). Could you try and disable HTTPS for admin login and see if it works? Since you cannot login, you can either do this on a fresh install or you will have to edit the home template entry in the database. Do you have access to the database?

Is the frontend serving HTTPS content OK?

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, teppo said:

What happens if you directly request /processwire/login/, i.e. type it to the address bar instead of /processwire/?

A direct input of /processwire/login returns the same 404 error.

1 hour ago, teppo said:

Also, just to clarify: when you enter /processwire/ you get the error for /processwire/login/ right away?

You're right.

Browser cache are empty. Same behaviour on other PCs. 

1 hour ago, teppo said:

This is somewhat off-topic, but it seems really strange that a hosting company (assuming that this is the case) moves the site to a new server without informing you, and without providing proper support, or even making sure that things work as expected after the move. When that kind of thing happens, you might be better off looking for a new hosting provider. Just saying.

I totally agree with you. But the webspace is served by our commune for charitys.

Share this post


Link to post
Share on other sites

A fresh installation without https working perfect.

Access to database is available.

At the moment I attempt to disable https for admin. I got to templates and edit the admin template. There is a value https with is set to 1. I set it to 0. However https is enabled. Is this ok?

Serving HTTPS for frontend is disabled.

Share this post


Link to post
Share on other sites

Login is now possible. I deleted the https item completely from admin template. HTTPS for admin is now disabled.

Thanks to all for the great support.

Share this post


Link to post
Share on other sites
45 minutes ago, adiemus said:

Login is now possible

Great! Glad you got it sorted.

1 hour ago, adiemus said:

Serving HTTPS for frontend is disabled.

If it works, I'd enable HTTPS for frontend 🙂.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.