alexbach

Facing ERR_CACHE_MISS Error When Click Back Button

Recommended Posts

Hi, 

Though I already found a related thread to my problem, I couldn't find the fix for it. So, I have a page with a form for searching field data. So, whenever you see the results through the link, I see an error.

Whenever someone clicks to view a detail and try to go back to the results page I get ERR_CACHE_MISS on Chrome  and Firefox.

How do I fix this. Any input would help. 

Share this post


Link to post
Share on other sites
8 hours ago, dragan said:

 

Yes, I found this first. However, i couldn't find any necessary solution.

Share this post


Link to post
Share on other sites

Sorry to disturb you guys but I want to suggest you one tip to fix this error and, i.e., you can fix this by disabling Cache System of your PC or by removing unnecessary plugins I have resolved this issue with this solution may be this will work for you also.

Share this post


Link to post
Share on other sites
On 11/15/2018 at 2:40 PM, Novac Jokovic said:

Sorry to disturb you guys but I want to suggest you one tip to fix this error and, i.e., you can fix this by disabling Cache System of your PC or by removing unnecessary plugins I have resolved this issue with this solution may be this will work for you also.

Hi, I tried your suggestion but couldn't actually figure out how to do it. So I searched and found this to fix ERR_CACHE_MISS In Google Chrome. Also, there was a thread in StackOverflow too. Should I go with the fixes in them? 

https://stackoverflow.com/questions/26515991/chrome-err-cache-miss

 

Share this post


Link to post
Share on other sites

The solution is in the topic linked to in the third comment:

Generally you should use the GET method for a search form, so that the search results page can be cached, saved in the browser history, shared, bookmarked, etc.

Read more about GET vs POST here: https://www.guru99.com/php-forms-handling.html

Also see Ryan's "regular" profile for an example of a search form and search results template in ProcessWire:
https://github.com/ryancramerdesign/regular/blob/a8228074dfdc8ea99da80d23429b5f9cfa644f2f/site-regular/templates/_main.php#L78-L81
https://github.com/ryancramerdesign/regular/blob/a8228074dfdc8ea99da80d23429b5f9cfa644f2f/site-regular/templates/search.php

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.