Jump to content
Andreas Augustin

Use of special url-protocols in CKEditor Fields

Recommended Posts

How can I make links with urls which have some special internal protocols like this links:

  • contenthub://53634
  • page://some-cool-pag?param=xyz
  • team://foobar

This links will always be removed from my href="" in the field when I hit save. Also when I remove "HTML Purifier" and "Use ACF" setting from the field.

FYI: This urls will be replaced by an other service after processwire builds the page. So don't wonder too much about this strange urls :-)

Share this post


Link to post
Share on other sites
11 hours ago, Andreas Augustin said:

Also when I remove "HTML Purifier" and "Use ACF" setting from the field.

When I tested those URLs, I only had to turn off HTML Purifier and the links remained in the field after page save. Leaving ACF on did not affect the links.

2018-09-20_102733.png.8d1eda0bfa50a28aaf51917c75a75590.png

 

Share this post


Link to post
Share on other sites

Hm, strange. I will check it asap again.

In my first try it only worked when I deaktivated the PWLink Module and used the default CKEditor Link Module.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...