Jump to content

Internal Server Error 500 - Strato Shared Hosting


Recommended Posts


I have a fine working local installation of processwire and tried to transfer it to strato shared hosting.

First I tried to just copy the local files via ftp. It did not work. I get: 




Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Error has been logged.


Many wrote that it is about the .htaccess file. I commented out line by line, until everything was commented out. During that process I had once a little success, which finally showed me database table failures (which is reasonable), but I could not reproduce that anymore. Not even completely removing the file does help.

Any ideas?

I also tried to install ProcessWire directly on the shared hosting platform - downloaded the files, and completed the installation successfully (while once execute an additional check for the requirements). The result is that the many gui elements are missing in the admin interface after the installation. For instance, the bar on the top does not show any tabs. If I browse in the tree, I get a very broken view. I tried blank and intermediate.

What is going wrong?

I would appreciate any help. (Locally it works perfectly fine)


Link to comment
Share on other sites

Welcome @AndreasWeinzierl,

first of all I would recommend you to activate the debug mode inside your config file to get more informations about the error.

Also you could install the excellent TracyDebugger to check your local installation for errors. This module saved me many time and I think it is a must have.


4 hours ago, AndreasWeinzierl said:

Many wrote that it is about the .htaccess file

Usually some hosters have issues with the RewriteBase. On those hosters you should set the RewriteBase in the .htaccess file to "/":

 RewriteBase /

But with the hoster Strato this is not necessary.


Most likely on your hoster Strato there is the SiteGuard write protection activated, which can cause issues. You should deactivate it for the directories where files need to be created and written (f.e. the assets folder).


If none of this helps, there is a troubleshooting guide.

Regards, Andreas

  • Like 1
Link to comment
Share on other sites

additional to what is already mentioned above, it could be write access to the assets folders and files. Often when ftp-ing a complete site profile, I have to manually correct the access rights for the assets folders to include write access for php or wwwrun or how ever this is called by the different hosters.

Link to comment
Share on other sites

Just look inside the .htaccess file in your pw root directory ? 

# -----------------------------------------------------------------------------------------------
# 1. Don't show directory indexes, but do follow symbolic links 
# 500 NOTE: Some cloud hosting companies don't allow +FollowSymLinks. 
# Uncomment +SymLinksifOwnerMatch and comment +FollowSymLinks if you have 500 errors. 
# If that doesn't resolve the error, then set it back to +FollowSymLinks. 
# -----------------------------------------------------------------------------------------------

Options -Indexes
Options +FollowSymLinks
# Options +SymLinksifOwnerMatch

Just write a # before "Options +FollowSymLinks and delete the "# " from "# Options +SymLinksifOwnerMatch"


Link to comment
Share on other sites

As stated, I deleted the whole content of the htAccess file, like in the trouble shooting guide suggested - didn't help much.

Debugmode=true did not help either.

The problem was that there was a file called active.php, and the webaddress was not in httphosts in the config file. After that it worked quite well with the "just copy everything, import the sql dump"-method. 

I did not try the "install on hoster"-method anymore, since the former method already enables a nice&clean automated build process.


Thanks for your help though.

Ill look deeper into TracyDebugger, I think I could use that sometime - although the configuration tab looks pretty complicated at first sight. 

Link to comment
Share on other sites


next issue: I tried tracyDebugger, but somehow I cannot find the dumps or set working breakpoints. So I tried xdebug.

When I just run the request in PHPStormer, the breakpoints I set are being ignored/and/or I cant get over the initial first lines of index.php. After wire->config I get an exception (but only with debugging). So I tried a little around and finally I started the debugging the browser and got the following error: 

Warning: Uncaught Error: Class 'ProcessWire\WireDebugInfo' not found in www\wire\core\Wire.php:1758
 Fatal error: __debuginfo() must return an array in www\index.php on line 35

What am I doing wrong?

Link to comment
Share on other sites

TracyDebugger and Xdebug don't work well together in my experience. So you have to choose one or the other.

  • If you want to use Xdebug in your IDE PHPStorm, then you should uninstall TracyDebugger.
  • If you want to use TracyDebugger, then you should deactivate Xdebug.

I would recommend TracyDebugger over Xdebug.

I have just read that it should work nicely together with Xdebug. Although I have made a different experience, you can ignore the first part.


You can make Dumps like described in the blog post or documentation. Personally I prefer BarDumps, because they have their place inside a panel and not on the page. But it is up to you.

I have never used breakpoints and it seems that you cannot set breakpoints like with Xdebug inside your IDE. If that is important to you, then you should stick with Xdebug.

Edited by AndZyk
Corrected first part
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...