Jump to content
Dennis Spohr

Url with many url-segments gives 404 error

Recommended Posts

Hi all,

if my url has more than 6 url-segments it throws an 404 error. This happens just on my live-server, locally it works perfect. 

I already set

$config->maxUrlSegments = 15;

Is there any PHP setting that can cause this behaviour? 
I tried many things but got totally stuck now.

Thanks for your help!
Dennis

Share this post


Link to post
Share on other sites

I don't think the total length is the problem. The url is not that long (maybe 30 characters?) and it doesn't change anything if I shrink the segments itself. 

Now it's maybe a total length of 50 characters and it's the same problem. It's really the count of segments.

Share this post


Link to post
Share on other sites

I believe it is a difference in http server, nothing to do with php. 

Can you compare the settings or have you asked your hoster?

 

Share this post


Link to post
Share on other sites

You should ask him if there is a setting that limits urlsegments, if you are not able to check it by yourself. 🙂

Share this post


Link to post
Share on other sites

Looks like it doesn't have something todo with the server.

I created a test-url for them (without /6 it works):
https://www.coachy.net/seqtest/1/2/3/4/5/6

Their support wrote the following (freely translated from German):

Quote

I just checked it again, after loading https://www.coachy.net/seqtest/1/2/3/4/5/6 the process get killed in .../site/assets/cache/FileCompiler/site/modules/ProCache/ProCacheMinifyHTML.php

I can't do more and deeper debugging, because my following test-script works just fine:
https://www.coachy.net/test/1/1/2/3/4/5/6/7/8/9/10/11/12/13/14

There limits for the length of a request, but they are set to 2GB. In case of a server-limit, you would get a 500 error from Apache.

I'm guessing it's either a problem with ProCache or with your .htaccess-File.

For testing I removed the ProCache Module. Additionally I downloaded a clean .htaccess File (latest pw-version).

I'm still getting the same error.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...