Uniteam

Error JS upload image

Recommended Posts

Hello,

I have a problem after upload an image. In attach you can see the error.

The file was uploaded correctly, but the response of completed operation goes in loop...

Many thanks!

Immagine.png

Share this post


Link to post
Share on other sites

Hello,

Welcome to the ProcessWire forum!

Here is a thread discussing such errors:

 

  • Like 2

Share this post


Link to post
Share on other sites
19 hours ago, szabesz said:

Hello,

Welcome to the ProcessWire forum!

Here is a thread discussing such errors:

 

Hello,
I could not solve the problem.
I use Processwire 3.

My error is the same...

Help me :(

Thanks!

Share this post


Link to post
Share on other sites

Well, you didn't tell us what you have tried. Did you try any of the suggestions of the a.m. thread?

safe_mode, mod_security, increasing memory limit, check if GD library is installed, maybe upgrade PHP, what do you see in /site/assets/logs/errors.txt? etc.

  • Like 1

Share this post


Link to post
Share on other sites

I have modified the php.ini:

post_max_size = 100M
upload_max_filesize = 100M
max_execution_time = 60
max_input_time = 60
memory_limit = 512M

mod_rewrite is installed

In attach the error and the response by firebug

Immagine.png

Share this post


Link to post
Share on other sites

Maybe I have found the problem: the size of uploaded image.

when pw tries to resize the image something does not work.

 

Share this post


Link to post
Share on other sites

Sounds like a memory issue. How big is the image?

Share this post


Link to post
Share on other sites

644 x 450 px for 57 KB --> error

320 x 223 px for 23 KB --> upload success

 

Share this post


Link to post
Share on other sites

Do you have access to the server error logs? Or have you config->debug already enabled?

Share this post


Link to post
Share on other sites

I don't have access to the server error and my config->debug is false. I must ti activate?

Share this post


Link to post
Share on other sites

Yeah, a INTERNAL SERVER ERROR 500 doesn't help much.

Share this post


Link to post
Share on other sites

Does it show another error message?

Share this post


Link to post
Share on other sites

So you edited the php.ini but everything else works and it's not a misconfiguration you did? 

Sorry, I can't help you, ask your server admin to help.

 

EDIT: have you added $config->debug = true in site/config.php ?

Share this post


Link to post
Share on other sites
4 minutes ago, Soma said:

So you edited the php.ini but everything else works and it's not a misconfiguration you did? 

Exactly...with original php.ini the problem is the same

 

5 minutes ago, Soma said:

EDIT: have you added $config->debug = true in site/config.php ?

added in site/config.php

Share this post


Link to post
Share on other sites

the image is uploaded correctly because by ftp I can see the file, but after upload processwire try to resize the image maybe for the thumbnail in edit form...

Share this post


Link to post
Share on other sites

Yeah usually it's the php memory limit, but without knowing the error... 

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, Soma said:

Yeah usually it's the php memory limit, but without knowing the error... 

I have contact my provider for the apache error log...but my php memory limit is 512M

Edited by Uniteam

Share this post


Link to post
Share on other sites
3 hours ago, Uniteam said:

I have modified the php.ini:

post_max_size = 100M
upload_max_filesize = 100M
max_execution_time = 60
max_input_time = 60
memory_limit = 512M

You know, just because you have these settings in place, doesn't mean your host will actually allow / activate it.

Most hosting providers have some sort of limits that you can't override.

Do you have the same site installed locally? If so, do you see the same error 500? (with the same settings as in php.ini)

Share this post


Link to post
Share on other sites
15 hours ago, dragan said:

You know, just because you have these settings in place, doesn't mean your host will actually allow / activate it.

The settings are activate.

 

15 hours ago, dragan said:

Do you have the same site installed locally? If so, do you see the same error 500? (with the same settings as in php.ini)

No, I will create it this morning

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.