Jump to content
monollonom

Issue with a hook ?

Recommended Posts

Hi,

I have an issue when I try to save a profile page from a non-superuser. The server gets stuck and returns a 

Allowed memory size of X bytes exhausted

It is pointing to a line in a file, usually WireHooks.php, but I couldn't get anything more out of Tracy nor Processwire's logs so I started to put some echos here and there in the runHooks() function.

Apparently what is happening is that a "viewable" method gets called in loop through hooks. It seems to be related to a PagePermissions object as seen in the attached screenshot (here's a gist with the echos in the runHooks() function : https://gist.github.com/romaincazier/453261d49310aee4a279ac1c2352df9f) but I don't really know what to do from here. I tried to check the "user" template's view and edit access but it doesn't have any effects.

In my setup I created some modules that add hooks but nothing related to this. Just in case I tried to uninstall them but it didn't have any effects as well. Is it possible that hooks are persistent ? Is it possible to remove all custom hooks ?

Yeah... I am pretty lost here.

Last step would be to do a clean install, install my modules, and see how that goes.

Thanks in advance.

Capture d’écran 2018-06-13 à 14.07.11.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...