MarcoPLY

[Resolved] Go Live, help!

Recommended Posts

HiGuy,

I have a problem:

I have move my website form    nome_site/test/...   to    nome_site/...  But all link in the backend still point to nome_site/test/...  and also all the image.  What I can do? 

I mean all page like Setup, module, Access point to   nome_site/test/.

There are some command I can run in DB for fix this?

Why when I move from remoto to live in   nome_site/test/... this problem not show up. I can re link all the image, is a long work but i can do, but for the internal page? why they poin to other link?

Thank you

Share this post


Link to post
Share on other sites

Try to delete everything inside the site/assets/cache/ folder. Maybe also try to clear your browser cache.

Normally, you can move move around a PW site from anywhere to anywhere without such problems.

Share this post


Link to post
Share on other sites

Thank you @dragan for the reapply. I try to do it, I have clean all cache and also the /assets/cache/ folder.

I have in the dabatabe clean all the wrong extension with find and replace.  

But in the backend the main navigation links do not work still point to a wrong url. But the page inside work well. Like I can make some change to the module configuration.

Where I can fix this? 

UPDATE

This is valid only for the Super Admin, other users have the correct link

Share this post


Link to post
Share on other sites

try updating your config.php with your new site url :

 

$config->httpHosts = array('your.newsite.com');

 

  • Like 1

Share this post


Link to post
Share on other sites

You might have modified your .htaccess file to work on localhost and a subdirectory. Now, you should double check the .htaccess file, in particular this section :

  # -----------------------------------------------------------------------------------------------
  # 11. OPTIONAL: Set a rewrite base if rewrites aren't working properly on your server.
  # And if your site directory starts with a "~" you will most likely have to use this.
  # ----------------------------------------------------------------------------------------------- 
 RewriteBase /
  # RewriteBase /pw/
  # RewriteBase /~user/

 

How is looking your ?

 

Share this post


Link to post
Share on other sites

I am out of idea right now - I have 15 minutes, if you want I can take a look at your install if you feel confident..

 

Edit: was a browser cache issue.

Edited by flydev
solved
  • Like 3

Share this post


Link to post
Share on other sites

ok, I solved the problems this this way:

  • About the database link, I have open it and clean all the text with the wrong text just by find and replace with a empty filed.
  • About the link in the backend menu I have clean the cache multiple time, but only if I close the browser and restart the pc the link start to works. So, the problem was in the cache but was a bit strange have had to restart the pc.

Share this post


Link to post
Share on other sites

Maybe you try to configure your webbrowser(-profile), that you use for webdeveloping, to completely disable caching?

  • Like 2

Share this post


Link to post
Share on other sites
Just now, horst said:

Maybe you try to configure your webbrowser(-profile), that you use for webdeveloping, to completely disable caching?

yep. And / or: open the site in incognito mode. Everytime you close the browser in incognito mode again, the cache gets cleared automatically.

  • Like 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.