Jump to content

uploading processwire to hosting online


danielholanda
 Share

Recommended Posts

Quick question!

I have everything prepared. I created the web locally with my MAMP. So I have a web working perfectly with CMS processwire, locally. I want to upload this to a hosting server. I suppose I have to install again processwire in this server, or not?. UPloading all these files via FTP to the online server will be enough? Or if I upload via FTP all my files I will still have to create all the fileds again in the online hosting? Or will thee settings be automatic?

Pleas let me know what I would have to do?

Thank you very much!

Dani

Link to comment
Share on other sites

You have two options.

1. move all the files and the database to the server. You have instructions here http://processwire.com/talk/topic/27-moving-pw-between-staging-and-live-server/#entry63

2. create an installable copy of the website with the Site Profile Exporter module http://modules.processwire.com/modules/process-export-profile/

Link to comment
Share on other sites

Hello, thanks!!!

I'm first trying out with the site profile exporter module. Lets see if that works. I followed all the steps and once I'm installing the new processwire into my online hosting I get this alert before installation:

Apache mod_rewrite does not appear to be installed and is required by ProcessWire.

The hosting is of a client of mine. How can I install this before the installation? As its the hosting I have no idea how I should do this. Please let me know, thank you!

Link to comment
Share on other sites

Ask the hosting provider to install mod_rewrite. If it's hosted on a virtual server then you will probably find information on installing apache modules in the docs of one of the virtual host providers like SliceHost or Linode or on the apache website.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By theExo
      Hey folks,
      im pretty new to Processwire. A client of mine asked me to migrate his old (v2.5) Processwire Website. On his server its running on PHP 5.3 and i want to upgrade + migrate the site at the same time. I Downloaded the Site from his server to set it up locally, replaced the /wire directory, index.php and .htaccess with the files of the latest version. After that i changed the DB Connection details in the config.php, swapped to PHP 7.4 and now, when i open up the site on my localhost i get this error:
      compile(\ProcessWire\wire("config")->paths->root . "site/templates/includes/head.inc.php",array('includes'=>true,'namespace'=>true,'modules'=>true,'skipIfNamespace'=>true)))?> compile(\ProcessWire\wire("config")->paths->root . "site/templates/includes/header.inc.php",array('includes'=>true,'namespace'=>true,'modules'=>true,'skipIfNamespace'=>true)))?> compile(\ProcessWire\wire("config")->paths->root . "site/templates/includes/start_content.inc.php",array('includes'=>true,'namespace'=>true,'modules'=>true,'skipIfNamespace'=>true)))?> compile(\ProcessWire\wire("config")->paths->root . "site/templates/includes/footer.inc.php",array('includes'=>true,'namespace'=>true,'modules'=>true,'skipIfNamespace'=>true)))?> The page itself doesnt load, just a white space with this stuff on it
      I checked if the files exist, they do.
      I hope anyone can help me with that 🙂 Thanks in advance!
    • By Gazley
      Hi there! It's been a long time since I've been here. I've not developed for a good few years. My son has asked if I can create him a website for his personal training service. I used to have a Linode to host sites but I've not had that for a while. Also, it was a bit problematic being responsible for the web server and general setup. I wondered what the best/easiest way is to quickly establish hosting without the hassle? Something where the setup and PW installation is automatically handled? 
      Any ideas or suggestions would be very much appreciated! 👍
      Cheers.
    • By OrinTerry
      Hello everyone. I am running a small technology blog, which is in WordPress. The main problem with my blog is that it does not open on any Windows 7 computer normally. I know Windows 7 has lost official support from Microsoft but still, there are plenty of users who still use Windows 7. The blog site is already 'HTTPS' protected but after opening in any browser, it shows 'not protected' next to the URL box. So, if I migrate all the site data to 'ProcessWare', will I get the same problem here too? Any kind of feedback would be greatly appreciated.
    • By Marvin
      Hello, excuse me
      I'm new at processwire, i want to ask about a master detail system (Inheritance system) using a processwire. Can we create a Inheritance table using a processwire, and how we create it? Thank you for the help
    • By Max Esnée
      Hi,
      When I upload a large(ish) SVG (≈120ko in this case) into an image field, it tends to get stuck at 100% and block the whole website. If I force refresh the admin page, the svg has not been uploaded. The file is correctly copied into the assets folder though. Other svg tends to be uploaded fine albeit I've noticed that pages containing svg images in the admin are very slow to load generally. Other pages using the same template but with jpeg or png images are much faster to load.
      I get the following error in the JS console:

      I develop locally using MAMP on macOS and I'm using Firefox. I'm using the last ProcessWire version (3.0.165).
      I also tested in Chrome and got the same error.
×
×
  • Create New...