phillipschmitz

[SOLVED] InputfieldInteger not found on Core Update

Recommended Posts

500 Error after the latest Core Update.

I have no idea why and what causes the problem, or how to solve it. (Maybe reupload the wire folder?)

image.png.ec02c6fe633c7110de48607494d5caaf.png

 

image.thumb.png.000b1c7f8ddf5ea926e569edb7decbfd.png

Any ideas? 

Share this post


Link to post
Share on other sites
4 hours ago, phillipschmitz said:

(Maybe reupload the wire folder?)

That's a pretty good idea right there ;)

If that doesn't help, I'd start by checking if /wire/modules/Inputfield/InputfieldInteger.module exists and is readable to your Apache user. In case you have a /site/assets/cache/FileCompiler/ directory, I'd also clear that, just to be sure.

  • Like 1

Share this post


Link to post
Share on other sites

What happens if you empty the contents of ".../site/assets/cache"? You might want to back it up first but normally it should not store any vital stuff.

Share this post


Link to post
Share on other sites
4 hours ago, phillipschmitz said:

After i reuploaded the wire folder and cleared the cache the error changed (activated the debug mode):

http://senseering.de/processwire/

image.thumb.png.ee36930825946a237376af9f53ee5316.png

Processwire is still not accessible throug back- or frontend. 

FYI, Site is accessible through the frontend

frontend-view.thumb.png.3a4e3c3c855209bce4cfd7f7c4265911.png

Share this post


Link to post
Share on other sites

Not really sure where to go from here. The latest error itself seems to indicate that $config->preloadCacheNames is null, so either that setting is missing, or the entire config is not working right. Some things you might try:

  • Make sure that /wire/config.php exists and is readable for your Apache user
  • Check if $config->preloadCacheNames is set in /wire/config.php (value should be an array)
  • Make sure that you aren't overriding aforementioned config setting in /site/config.php

I must admit that I don't have a slightest clue about what has gone wrong here, so these are just random ideas. In theory it could have something to do with ProcessWire being installed in a subdirectory (haven't done that in ages myself).

According to your server, the PHP version shouldn't be an issue here, and since you're running on Apache, it's unlikely to be a web server issue – at least unless your host has done something strange for their setup.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/19/2018 at 9:03 AM, phillipschmitz said:

after the latest Core Update.

How did you update ProcessWire. Using some module? Manually? 

2 hours ago, phillipschmitz said:

Is there any other idea that i can test? 

For now, are you able to downgrade ProcessWire to the last stable version you had? What version of ProcessWire was that,  3.0.62? Does it work then? You can then upgrade incrementally, e.g. 3.0.62 to 3.0.7x to try replicate the issue. If you are able to do the test on a local server first, the better.

I'm probably clutching at straws here...

  • Like 1

Share this post


Link to post
Share on other sites

Update: I found multiple empty files in the wire folder.

After i reuploaded the wire folder two days ago through the console, i didn´t check if every file was uploaded correctly. 

I opened the first file mentioned in the error and it was empty, so i uploaded it manually and repeated that process for 7 more files. 

Now everything seems to work fine.

I have absolutely no idea why or how this can happen, nor the correlation to the Core Update. Seems really strange. 

 

Anyway, thank you guys for your replies! 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sam-vital
      Hi,
      So I'm working on my site, getting round to completing it. I remember that I haven't checked at all what it will be like on other devices, so that's my next task.
      I went to the index page and I get hit with this error:
      Fatal error: Exception: SQLSTATE[HY000] [2002] Connection refused (in /var/sites/b/mysite.org/public_html/wire/core/ProcessWire.php line 377) #0 /var/sites/b/mysite.org/public_html/wire/core/ProcessWire.php(209): ProcessWire\ProcessWire->load(Object(ProcessWire\Config)) #1 /var/sites/b/mysite.org/public_html/index.php(52): ProcessWire\ProcessWire->__construct(Object(ProcessWire\Config)) #2 {main} in /var/sites/b/mysite.org/public_html/index.phpon line 64
      All I have done from the last code update was change a links target to blank, pushed the update and tested it. Now my site is broken? Went back and changed to the original file and I'm still getting the error.
      I really don't understand what has happened. I am an ok {6 months} web developer with this being my first experience of PW.
      All help is appreciated 🙂
    • By Sergio
      All of a sudden, with nothing changed on the database or server, a website was getting error when doing a search:
      Error: Exception: SQLSTATE[HY000]: General error: 23 Out of resources when opening file './your-database-name/pages_parents.MYD' (Errcode: 24 - Too many open files) (in /home/forge/example.com/public/wire/core/PageFinder.php line 413) #0 /home/forge/example.com/public/wire/core/Wire.php(386): ProcessWire\PageFinder->___find(Object(ProcessWire\Selectors), Array) #1 /home/forge/example.com/public/wire/core/WireHooks.php(723): ProcessWire\Wire->_callMethod('___find', Array) #2 /home/forge/example.com/public/wire/core/Wire.php(442): ProcessWire\WireHooks->runHooks(Object(ProcessWire\PageFinder), 'find', Array) #3 /home/forge/example.com/public/wire/core/PagesLoader.php(248): ProcessWire\Wire->__call('find', Array) #4 /home/forge/example.com/public/wire/core/Pages.php(232): ProcessWire\PagesLoader->find('title~=EAP, lim...', Array) #5 /home/forge/example.com/public/wire/core/Wire.php(383): ProcessWire\Pages->___find('title~=EAP, lim...') #6 /home/forge/example.com/public/wire This error message was shown because: you are logged in as a Superuser. Error has been logged.  
      I tried several things, listed in this thread: https://serverfault.com/questions/791729/ubuntu-16-04-server-mysql-open-file-limit-wont-go-higher-than-65536
      But for some reason, MySQL was not getting its limit increased, but in the end, the one that did the trick was this:
      This worked for me on Ubuntu Xenial 16.04:
      Create the dir /etc/systemd/system/mysql.service.d
      Put in /etc/systemd/system/mysql.service.d/override.conf:
      [Service] LimitNOFILE=1024000 Now execute
      systemctl daemon-reload systemctl restart mysql.service Yes indeed, LimitNOFILE=infinity actually seems to set it to 65536.
      You can validate the above after starting MySQL by doing:
      cat /proc/$(pgrep mysql)/limits | grep files
    • By rareyush
      I am using new processwire and I am receiving this error in my _func.php
       
      Parse Error: syntax error, unexpected 'return' (T_RETURN) Parse Error: syntax error, unexpected '$out' processwire anyone knows anything ??
    • By ivineets
      Hi,
      Whenever I try to create a repeater field on my website, I get following error:
      General error: 3161 Storage engine MyISAM is disabled (Table creation is disallowed).
      If I still continue, it creates the field but doesn't allow storing any kind of data. How do I resolve this?  Is there any alternative to repeatable content that I can use?
       
      Thanks for your time.
       
       
    • By Rudy
      Hi all,
      Is there a way to turn off fatal error notification without nullifying or commenting out: 
      $config->adminEmail Thx
      Rudy