Jump to content

Recommended Posts

Hello,i  am new here. A hour ago i bought a vps and i want  to make a website about movies.

- a home page

- a movie page with title, description,  trailer ,year and actors

-categories, tags 

- a complex search page by name,tags,year and acts

- posts, latest news (about site)

 

It's already to much :D

I leave wordpress,from my needs it's very complicated. So,minimal speaking, i can do that with this cms,and which is the steps? I don't know yet how this work.Thank you,and sorry for my eng.

Screenshot_20180330-231735.png

Share this post


Link to post
Share on other sites

Hello and welcome to the forums!

You can certainly make a website like you describe with ProcessWire.  Have you checked the documentation?

https://processwire.com/docs/

Good article as an introduction:

https://www.smashingmagazine.com/2016/07/the-aesthetic-of-non-opinionated-content-management-a-beginners-guide-to-processwire/

About categorization (which seems to be one of the important part for your site):

Your first steps could go into creating templates (eg movie template) and create and add fields to it like, images, director, etc. 

  • Like 4

Share this post


Link to post
Share on other sites

hi @bystefu and welcome to the forum!

elabx linked to great resources. However, I would highly recommend you walk through the https://processwire.com/docs/tutorials/hello-worlds/ tutorial step by step. Not only reading. Really doing and following step by step. This will show you the basics of processwire: How you create templates, how you put fields there, how you create pages and finally how you display them on the frontend.

I wish you good luck and hope you enjoy the journey :)

  • Like 4

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mithlesh
      Changing it to null
    • By Mithlesh
      Hi, I have one URL - writerrelocations.com/contact-now/

      I have one issue where my header Image is appearing again after the contact form, for your reference:



      I have checked my processwire template section where have not added any Image field besides Header Image, attaching the same for the reference:




      PLEASE help me to get rid of the image below contact form

      Waiting for the swift response!

      Thanks
       
    • By benbyf
      Hi!
      Been doing some basic Twilio implementation for a client to enable them to automatically send text messages to registered users on page publish. As an upshot, I thought I would strip out the site specific work and stick up on github here: https://github.com/benbyford/TwilioChannels
      This modules pulls in the Twilio APi and enables you to send SMS messages from your front or backend.
      Send SMS message Truncate message to single message character limit Auto-select number from range of numbers depending on $To number country of origin–this enables you to send messages with a local number to that user if one added to the config. Templates usage:
      $twilio = $modules->get("TwilioChannels"); $twilio->sendSMS($toNumber, $message);  
    • By anderson
      Hi,
      For the purpose of learning, as shown in this photo, I created a repeater field "we", then a template, then a page.
      But in /templates/testrepeater.php, I has some problem, the "foreach" part does not work as expected.
      <html> <body> <?php echo "<h1>$page->title</h1><br>"; ?> <? foreach($page->we as $member); ?> <img src="<?php echo $member->images->url; ?>" alt=""> <?php echo $member->wemember; ?><br> <? endforeach;?> </body> </html> Could anybody please help point out my error?
      Thanks in advance.

×
×
  • Create New...