verdeandrea

Very very weird behaviour for repeaters

Recommended Posts

Hi guys,

I'm getting crazy trying to figure out what is the cause behind a weird problem is giving me some bad moments with my client.

I have a repeater field, with some fields as childre. From one day to the other the children fields of the repeater change and i find other fields as children. Also, all the content my client inserted in that repeaters are gone, cause now we have the new empty children fields. I really don't understand what can be the reasons behind this.

This happened more than once.

It' s like there is a repeating action that changes the repeater's children. The only repeating action I can think of is the chronjob for the database. Could this depend on that? Have you any idea or suggestion of what should i check or ho to solve this weird problem?

Thank you very much!

Share this post


Link to post
Share on other sites
56 minutes ago, verdeandrea said:

The only repeating action I can think of is the chronjob for the database

What exactly is this cron job doing?

Share this post


Link to post
Share on other sites

Thanks for the reply.

@dragan I'm using the CronjobDatabaseBackup module to make daily backups of the database

@Robin S no I'm not using it. 

If I remember correctly i had this problem for the first time when i used export / import fields tool in processwire to copy this new fields from my local pw to the remote one.

 

Share this post


Link to post
Share on other sites

Both your custom modules use the same hook, and the same function-name createSubPagesForEdition(). I find that a bit strange, and potentially dangerous. Do you have control over which module is executed first?

Also, the import/export function is labelled as "experimental" (don't know exactly why).

Share this post


Link to post
Share on other sites

@adrian sorry i forgot to mention: PW version is 3.0.62, so it should be the last.

@dragan thanks, i'll change my functions names se they are not the same.

But i think i understood where the problem is but i don't know how to fix it.

I have these two repeaters and their children fields where inverted when I imported them via pw import fields. Then i though i fixed but they are now somehow related.

That means that, if i fix one repeater's children also the other repeater get the same children. I suspect it could be some problem with ids in database. Maybe the best thing to do is create new repeater fields from scratch, if you don't have better suggestions on how to fix this problem.

Right know i tried to fix one repeater and when I checked the other one, its children fields were changed and were the same of the first repeater.

Share this post


Link to post
Share on other sites

Did you try to merge your two custom modules into one? And also (since it seems to be a live site): can you go back to an old state (backup) where you are sure everything worked fine?

  • Like 1

Share this post


Link to post
Share on other sites

@dragan unfortunately i can not go to old state cause a lot of contents are being inserted by my client during these last days.

I'll definitely try to merge the two custom modules into one.

Share this post


Link to post
Share on other sites

Yes, I'm pretty sure I have some messes on the database. I tried to delete the first repeater. First i removed it from the only template that was using it. But then, when i tried to delete it i got an error message that says it can not be deleted cause it's used in 56 pages (i also emptied the trash before and tried again).

Probably i have to dig in my database.

 

Share this post


Link to post
Share on other sites

Ok, i think I got where the problem is. The 2 repeaters have the same template id in the database. I have to fix that.

Share this post


Link to post
Share on other sites
4 hours ago, verdeandrea said:

PW version is 3.0.62, so it should be the last.

That's the last master - as I mentioned, the issue wasn't fixed until recently in the dev version. 

Share this post


Link to post
Share on other sites

Thanks @adrian

Yes probably the export/import feature messed my repeater fields. In the end I decided to trash all the old fields and to start again with new ones so now it should be fixed.

Thank you guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By benbyf
      Hi,
      Been updating fields on a live site from my dev site to get them in synch and I noticed repeater pages visible in my pagetree on teh live site. What might I have done to have this happen? The repeater module was enabled on both sites.

    • By quickjeff
      Hi Guys, 
      I have been using Processwire for years now and have mastered enough to create some amazing sites and applications. 
      However, recently I have been thrown a bit of a curveball and hoping some more veteran members can chime in. 
      I recently ran into a weird issue. I had imported about 100+ wordpress pages into a new Processwire site using namespaces. 
      I imported them under a parent page called /landing-pages/.
      However, I needed to move 20+ of these imported pages to a new parent page called /customers/.
      Since I was moving so many, I figured batcher was a solid module to run this task.
      Here are the steps I took:
      Located all the pages I needed using batcher Changed the pages templates Located the pages again after changing their template Made the pages hidden and then located them again using batcher Changed parent page from /landing-pages/ to /customers/ The issue that occurred is that not only did I change the parent page for these pages but apparently the pages also existed under /admin/repeaters/for-field-whatever which now changed to the new parent of /customers/.  
      for-page-1625 admin /admin/repeaters/for-field-108/ So I reverted this by using batcher again, here are the steps I took:
      Located all the pages that were not supposed to be moved  Changed the pages parent back to /admin/repeaters/ The issue is, after this was done, every time I clicked the new page under /customers/whatever-page I would get a 404. 
      To correct this I had to delete all the pages under /admin/repeaters/ and /admin/repeaters/for-field-whatever and then go back and delete the pages under /Customers/ and create them all from scratch. 
       My questions are: 
      Why did Processwire create pages under /admin/repeaters  for the imported pages? The steps I took to correct this issue, is this okay to keep building the site or am I better off starting fresh again?  
    • By Sipho
      I am trying to create a sort of database system using ProcessWire. I don't want all the data to show up as pages on the website but instead pull it into pages. Similar to the Skyscrapers demo except in that one the data shows up as pages. The data I wish to store is information about types of moths. So family, sub-family, genus and species. Each of these has information associated with it. For example, species has name, images and distribution. This is another example of information about the species. Initially, I attempted to do this using nested repeaters. This appears to work but I feel there is a better and more elegant way. Additionally, this page says: 
      So I then tried using pages with children, but this also didn't work well. I had to make every single page unpublished as I don't want them showing up in menus and other places. This means they all have strikethroughs in the admin tree which is very annoying.
      Is there a better way of handling this kind of data in ProcessWire or is this maybe not a suitable project for ProcessWire? I apologise if this is a silly question, but I could not find anything on this matter and am still new to ProcessWire.
    • By CarloC
      Hi everyone,
      I've upgraded one of my pw 2.7 websites to the 2.8 legacy version and I'm encountering some problems.
      As you can see in the image I don't see uploaded images thumbnails anymore, and the repeater fields previously added are no more usable.

      Why I'm having this strange behaviour simply after an upgrade from processwire 2.7 to 2.8?
      Hope you can help me, I'd like to use the 2.8 version features like the front-end inline editing, but it seems like I'll be locked in the 2.7 version forever
      Thank you!
       
    • By CarloC
      Hi everyone!
      this is my first topic and I need to say thanks to @ryan and all the other contributors for this incredible framework that changed my life as a web dev!
      But now I go to the point. I developed a project with pw 2.7 and it worked like a charm.
      Today i'm trying to update the project to pw3 on a local environment, to test that everything will continue working after the upgrade, and that's not the case.
      The major bug I'm encountering is that repeater field doesn't work properly.
      Existing Repeater field
      This is what I see when I try to edit a page that already has a repeater field (Brand concepts) with some elements:

      If I click on one of the "... blocks" nothing appens.
      New repeater field
      If I create a new repeater field and assing it to a template, when I open a page with that template I see the new repeater field, but the "Add new" link, to add a new element, doesn't work. I click it and nothing appens.

      I never had this kind of strange behaviours in PW, and this is one of the reasons why I consider it the best cms/framework I've ever used.
      I hope you can help me.
      Thank you!