Jump to content

Very very weird behaviour for repeaters


Recommended Posts

Hi guys,

I'm getting crazy trying to figure out what is the cause behind a weird problem is giving me some bad moments with my client.

I have a repeater field, with some fields as childre. From one day to the other the children fields of the repeater change and i find other fields as children. Also, all the content my client inserted in that repeaters are gone, cause now we have the new empty children fields. I really don't understand what can be the reasons behind this.

This happened more than once.

It' s like there is a repeating action that changes the repeater's children. The only repeating action I can think of is the chronjob for the database. Could this depend on that? Have you any idea or suggestion of what should i check or ho to solve this weird problem?

Thank you very much!

Link to comment
Share on other sites

Both your custom modules use the same hook, and the same function-name createSubPagesForEdition(). I find that a bit strange, and potentially dangerous. Do you have control over which module is executed first?

Also, the import/export function is labelled as "experimental" (don't know exactly why).

Link to comment
Share on other sites

@adrian sorry i forgot to mention: PW version is 3.0.62, so it should be the last.

@dragan thanks, i'll change my functions names se they are not the same.

But i think i understood where the problem is but i don't know how to fix it.

I have these two repeaters and their children fields where inverted when I imported them via pw import fields. Then i though i fixed but they are now somehow related.

That means that, if i fix one repeater's children also the other repeater get the same children. I suspect it could be some problem with ids in database. Maybe the best thing to do is create new repeater fields from scratch, if you don't have better suggestions on how to fix this problem.

Right know i tried to fix one repeater and when I checked the other one, its children fields were changed and were the same of the first repeater.

Link to comment
Share on other sites

Yes, I'm pretty sure I have some messes on the database. I tried to delete the first repeater. First i removed it from the only template that was using it. But then, when i tried to delete it i got an error message that says it can not be deleted cause it's used in 56 pages (i also emptied the trash before and tried again).

Probably i have to dig in my database.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...