Jump to content

[SOLVED] SSL on Localhost (Windows)


kongondo
 Share

Recommended Posts

So, all of a sudden, Chrome is blocking all of my localhost sites, claiming my connection is not Private, blah blah..Here is the full text of what Chrome is telling me.

Quote

blog.sandpit.dev normally uses encryption to protect your information. When Google Chrome tried to connect to blog.sandpit.dev this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be blog.sandpit.dev, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit blog.sandpit.dev right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

I get no option to 'continue to this unsafe site'. 

It seems I have no option but to install SSL on my local sites. I have seen some articles on how easy it is to do in a Mac but I am on Windows. Anyone has pointers on how I can do this? Alternatively, anyone knows what this Chrome error is about? Bottom line is, unless I change browsers, I am not currently able to develop and test stuff locally. Grr!

Thanks.

Link to comment
Share on other sites

10 minutes ago, horst said:

are you not able to test and develop those sites without SSL? (configuring your local sites to run under http: and https: besides each other)

Not on chrome. It is blocking the connection and tells me what I've quoted above. Hence, I am thinking if I migrate to SSL, Chrome will let me through.

9 minutes ago, fbg13 said:

Thanks. I'll have a look.

7 minutes ago, horst said:

what is about using the .local tld? Is it forced to https too?

I haven't tried this. The issue is that I have been using the same .dev tld forever. This problem with Chrome just started this afternoon.

Link to comment
Share on other sites

as far as I could see by a quick glance over the url provided by @fbg13, it is due to that G**gle has owned some .dev tlds, and that chrome (now) implements a HSTS.

So best bet would be to change to .local what never will change to become a public tld.

Or you installs LetsEncrypt on windows. (not really) :)

 

Edit: ok, you were faster in reading than I was in writing. :)

Edited by horst
  • Like 1
Link to comment
Share on other sites

I read the opening post earlier and I was like wha? Just now I loaded up my localhost pw.tuts.dev and BOOM! "Your connection is not private". The same damn site I was working on like 6hrs ago without issue. Now I gotta change my hosts and vhosts and all that crap. Looks like I'll be going down the .local route.

Thanks for the answers here everyone.

  • Like 1
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By NooseLadder
      Hi,
       
      I've been out of the game for a number of years (6/7). I have a few projects lined up. I used to use XAMPP on my Windows PC back then. I have a Windows 8.1 laptop atm. Is XAMPP still ok or can you recommend anything better? I used to upload files to server using FileZilla. Thanks.
    • By Peter Knight
      Hi all
      My .htaccess file is correctly redirecting all requests to
      https:// www. That's great until I want to work locally.
      I thought I had seen a blog post by Ryan where there was a new config setting to ignore both of these if working from localhost?
      I can't find it now so wondering if I was imagining 😕
       
       
    • By Marco Angeli
      Hi there,
      I added a ssl certificate to my site and I'd like to redirect every single http url to its new https version
      So I added this code in the .htacces file, after the RewriteEngine On :
      Redirect 301 /about https://www.mysite.it/about
      Unfortunately this is now working: I get the "too many redirects" error.
      The following code works, but it's a bulk redirection to the home page, something I don't want for SEO reasons (https://moz.com/blog/save-your-website-with-redirects😞
      RewriteCond %{HTTP_HOST} mysite\.it [NC]
      RewriteCond %{SERVER_PORT} 80
      RewriteRule ^(.*)$ https://www.mysite.it/$1 [R,L]
      Any suggestions?
    • By cosmicsafari
      Hi all,
      Just a quick question, when using the multisite module is there anything different that needs to be done in order to setup HTTPS for each of the domains its serving?
      Would a single SSL certificate for the main domain be enough to cover the others aswell or would you need multiple ceritficates one for each domain the mutlisite setup uses?
       
    • By Peter Knight
      I think I've been through every GoDaddy related post on the forum but not had any success so far with this.
      Basically, a client's site started to throw various errors after a failed SSL install by their host. 
      Accessing https://www.domain.com results in an error and a redirect to
      https://www.domain.not/cgi-sys/defaultwebpage.cgi
      Accessing http://www.domain.not gives a blank 500 page
        Im happy to side step the SSL issue at the moment if I could get the site up.
      I'm pretty sure it's a .htaccess issue as adding "blahdhdgdgd" to the start of the .htaccess file results in an "internal Server Error"
      Tried every .htaccess tweak I could find to no avail. Even restored an older .htaccess file from last week before the SSL issue doesn't work.
      It's a "real doozy", this one
       
×
×
  • Create New...