Jump to content
dreerr

Weird Bug with Page Ref Fields

Recommended Posts

In PW 3.0.80 I've experienced a bug when using multiple Page Ref fields. The Select button keeps fading in and out again. I've made a video to illustrate the problem. Any ideas how to solve this?

video showing the error: PageRefError.mov

greetings, d.

Share this post


Link to post
Share on other sites

Just tried it with a fresh install of 3.0.80 and I am able to reproduce the error described above. Anyone also getting the same results? Steps to reproduce the issue:

1. create a Page Reference field with page field value type Single Page and input field type Page List Select

2. create a Page Reference field with page field value type PageArray and input field type Page List Select Multiple

3. assign these two fields to a template 

4. edit a page of that template type and try to select a page.

 

EDIT:

I pushed it to the server here so you can take a look http://dada.ninja/page-ref-error/processwire/ User: admin / Password: pageref  > take a look at the home and try to select something in the fields pageref or pagerefs

Share this post


Link to post
Share on other sites
40 minutes ago, BitPoet said:

Does this also happen on local installs? I'm asking because your demo site uses cloudflare's rocket loader, which may break some javascript.

It has to be something along this, as after I login, I don't get page tree, just header. I also get no content on Pages, Setup, Modules, Access...

Share this post


Link to post
Share on other sites

Does not make a difference if its local or remote. Turned Cloudflare in Development mode, Backend is working normally except from the bug.

Share this post


Link to post
Share on other sites
30 minutes ago, gmclelland said:

Did you turn off cloudflare's rocket loader?

He did. It look like ProcessPageList.js is hiding it in SetTimeout. But I can't find out why. And, I can't reproduce on my install... 

Share this post


Link to post
Share on other sites

Is ProcessPageList.js the stock js file and not a modified one?

Share this post


Link to post
Share on other sites

Can't tell for sure, but it looks like... its minified, but files are equal.

@dreerr are you sure you installed "clean", that is you are not overwriting wire folder but instead create a new wire folder? Just to be sure...

<ul class="PageListActions actions" style="display: none; opacity: 0;">...</ul>

This is triggered on hover, I can "see" the style is changed to display: inline; opacity: 1 but after that it is hidden by Jquery hide()...

Share this post


Link to post
Share on other sites

I could reproduce the problem with a clean install. It seems that all event listeners on the page list select items get attached twice. I didn't have time to check with different browsers though. I might be able to do some more digging tomorrow when I'm back at work.

  • Like 1

Share this post


Link to post
Share on other sites

@tpr I did no modifications whatsoever. 

Yes @matjazp it's stright from the GitHub repository.

Thank you @BitPoet that I'm not the only one with the error, I've experienced the problem with Chrome, Safari, iOS Safari and Firefox so far.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Guy Incognito
      I added some custom styles to the CKeditor menu bar using the example mystyles.js and the PW tutorial. This worked fine for fields when editing on the frontend. But none of our custom styles showed in the backend editor dropdown unless we edited the core copy of mystyles.js in wire/modules.
      Is this correct behaviour, a bug or a mistake on my part? Tried clearing cache, logging in/out etc but the backend ignores our custom styles in the site/modules path.
    • By karian
      I don't know why multiple instances (repeater_repeat_columns1, repeater_repeat_columns2, ...) of my repeater field are displayed inside Template field (see image).
      Is there a way to clean/reset it ?
       

    • By Noel Boss
      Short description of the issue
      Since PW 3.0.88: When I try to retrive a croped file using the api filesManager() and it's basename, I get the original version instead of the croped variation.
      Expected behaviour
      Looking up a variation using the path and filesManager should return the variation file.
       $page->filesManager->getFile("/path/to/filebasename.400x400.jpg"); // $file->basename > filebasename.400x400.jpg Actual behavior
      The variation is returned.
       $page->filesManager->getFile("/path/to/filebasename.400x400.jpg"); // $file->basename > filebasename.jpg  
      » Is this a bug or do I miss something here?
       
      Code:
      dump($page->filesManager->path.$input->get->filename('f')); $file = $page->filesManager->getFile($page->filesManager->path.$input->get->filename('f')); dump($file); dump($page->filesManager->path.$file->basename); Output:
      "/home/ubuntu/workspace/www/site/assets/files/-1579/colin-rex-434063.400x400.jpg" (79) ProcessWire\Pageimage #796f pageimages protected => ProcessWire\Pageimages #d195 original protected => ProcessWire\Pageimage #796f { RECURSION } variations private => null imageInfo private => array (2) width => 0 height => 0 error protected => "" pagefiles protected => ProcessWire\Pageimages #d195 data protected => array (6) basename => "colin-rex-434063.jpg" (20) description => "" tags => "" formatted => true modified => 1516025386 created => 1516025386 useFuel protected => true _instanceNum private => 870 localHooks protected => array () trackChanges private => 2 changes private => array (1) formatted => array (1) 0 => null _notices protected => array (3) errors => null warnings => null messages => null _wire protected => ProcessWire\ProcessWire #28d0 in .../www/site/templates/app/utils/download.php:29
      "/home/ubuntu/workspace/www/site/assets/files/-1579/colin-rex-434063.jpg" (71)
    • By Cloud8888
      Greetings from germany,

      i develop a shop for a customer and wanted to give them the opportunity to find products without any images so they could easily fill this empty sites.
      The problem is, that this images are placed inside a repeater.
      So the structure for the repeater field is:
      title
      bild (where 1 image can be placed)
      bildrecht (another repeater for placing the copyright  text)

      But here comes my problem.
      I designed a selector that should show me all sites where the repeater count is 0.
      Like :
      template=sorte|artikel,bilderrepeater.count=0
      But it also shows me results, where the repeater count is still 1 or even greater.
      If i save one of these bad results, the selector works fine.

      Is there a way around it ?
      I use pw 3.0.76.

       
    • By benbyf
      One of my clients found a bug when viewing the PW admin on chrome using windows - the admin tab nav doesn't appear, they could only see the tool icon either though they were a superadmin user. When viewed on Edge the tabs where present. The site is running on PW 3.0.62 with the default admin.
      I was screen sharing with my client when we found the bug, I don't actually have anyway to test this and see what's wrong myself as I dont run windows and dont currently have a cross broswer testing suite. Could someone please look into it briefly?
×
×
  • Create New...