Jump to content

Automatic Logout after using the CKEditor


Recommended Posts

Hey guys,

I never had problems with PW but now I have a strange problem with frequent logout issues. As an example: When I click in the CKEditor at the Image Button then Processwire asks me to login. What I tried:

$config->sessionFingerprint = false;
$config->sessionFingerprint = 8;
Session Handler Database

I don´t know how to solve the problem. This is what phpinfo() outputs:

Directive Local Value Master Value
session.auto_start Off Off
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_httponly On Off
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure Off Off
session.entropy_file /dev/urandom /dev/urandom
session.entropy_length 32 32
session.gc_divisor 1000 1000
session.gc_maxlifetime 86400 1440
session.gc_probability 0 0
session.hash_bits_per_character 5 5
session.hash_function 0 0
session.lazy_write On On
session.name wire PHPSESSID
session.referer_check no value no value
session.save_handler user files
session.save_path /var/lib/php/sessions /var/lib/php/sessions
session.serialize_handler php php
session.upload_progress.cleanup On On
session.upload_progress.enabled On On
session.upload_progress.freq 1% 1%
session.upload_progress.min_freq 1 1
session.upload_progress.prefix upload_progress_ upload_progress_
session.use_cookies On On
session.use_only_cookies On On
session.use_strict_mode Off Off
session.use_trans_sid 0 0


Do you have any ideas how to solve this problem? I already updated PW but it didn´t help.

Link to comment
Share on other sites

It's been a while since I had these issues, but yes it's definitely tied to some setting in CKEditor as not everyone seems to have this issue. As Robin mentioned, it's most likely one of the image related settings in CKEditor under the "HTML Options" settings. One of those checkboxes is messing with things. I haven't had time to try and debug/test it further, but that's where my suspicions are at.

Link to comment
Share on other sites

  • 4 years later...

I confirm that the CKeditor image is the problem... with ProCache!

I'm using ProCache and if I disable it, all works: the image is shown and I (the admin user) am not logget out.

It also works if ProCache stays enabled and I set in ProCache > CDN > CDN status > "Enabled for guest visitors only".

Maybe there is a bug somewhere. @ryan

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...