Jump to content
Johannes P.

ProcessWire 2.7 Installation Error: Exception: Missing system template: 'permission'

Recommended Posts

Dear all,

My name is Johannes and this is the first time I'm posting something in this forum.

I get following error installing Processwire 2.7 in a subfolder:
2017-09-14 13:37:27    ?    ?    Missing system template: 'permission' (in /wire/core/ProcessWire.php line 262)

2017-09-14 13:59:35    ?   http://www.domain.com/?/  Error:     Exception: Missing system template: 'permission' (in /data/www/www.domain.com/docfinder/wire/core/ProcessWire.php line 262)

I have used "processwire-legacy-master.zip". Please see also the screenshots from the installing process:

Hoster is Plusserver (formerly HostEurope) on Linux and Apache/mysql.

I have tried also to install 2.8.62 but result in the same error. 

Any ideas? Should I try to install the most recent versin of Processwire? I have to migrate an existing page to this new server, thats why I used the version 2.7





Share this post

Link to post
Share on other sites

Welcome to the forum!

9 hours ago, Johannes P. said:

I have to migrate an existing page to this new server, thats why I used the version 2.7

You mean an "exported site profile"? Did you export it form the same version you are trying to install? If not, you might want to try that first.

Please note that you do not have to do it by exporting the site profile and installing it along with ProcessWire. You can simply clone the database, copy over all files and change at least Database Configuration and $config->httpHosts in /site/config.php accordingly. Should you have issues afterwards, you can delete the contents of /site/assets/cache

EDIT: I forgot to mention that .htaccess might need different rules too, but that a is server specific issue

Edited by szabesz
  • Like 1

Share this post

Link to post
Share on other sites

Hi Gábor,

Thank you for your reply and the warm welcome.

What i did was following:

1. Copied files and imported DB from old server to this server and ended up with the error Missing system template: 'permission' (in /wire/core/ProcessWire.php line 262).

2. i did a new installation of Processwire 2.7 (see screenshots above) and ended up with the same error.

3. I installed PW 2.8 (also from ZIP file) and got same error.

For steps 1 to 3 I used same DB. May this be the problem?

I will try to install PW 3.x and see what happens.





Share this post

Link to post
Share on other sites
6 minutes ago, Johannes P. said:

For steps 1 to 3 I used same DB. May this be the problem?

Probably not. I forgot to point out that – especially when manually copying files/folders – it is possible to run into permission issues, so you might want to double check that too.

Also, you can install the very same ProcessWire version with the blank profile, replace /site, adjust config.php, .htaccess, permissions and you also need to reset passwords in this case because the difference in $config->userAuthSalt in config.php will prevent the login in this case.  userAuthSalt is generated during ProcessWire's install process and tied to all passwords, the login process depends on it as a security measure.

  • Like 1

Share this post

Link to post
Share on other sites

I forgot to add that to keep the old database, you still need to clone it manually... You can also copy userAuthSalt over form the old one so you will not need to reset passwords.

Share this post

Link to post
Share on other sites

I found the problem.

On the new server I could install PW 3.x with the option INNODB. Installation also fails with the default option MyISAM. 

Now what to do? 

I need to migrate from the old server with PW2.7 and MyISAM to the new server with INNODB.

Is it possible to convert MyISAM to INNODB?

Is it possible to install PW 2.7 with MySQL and INNODB? I coud not find this option. 



  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By alanxptm
      Hi, I have already tried in different ways and many times to migrate but I always have issues at the end.
      Here's what I have done so far:
      case 1:
      1. Install PW on live server (all normal)
      2. Import local DB into live DB
      3. Front page site seems to work but I cannot login into admin page
      case 2 (I'm currently on this stage):
      1. Copied all files from local to live server
      2. Import local DB into live empty DB
      3. Front page works, but any other page and admin page are 404
      In both cases:
      - I have changed config.php info accordingly to live server (DB name, DB user and pwd, userauthsalt code)
      - Uncommented RewriteBase / and RewriteBase /pw/ lines on .htaccess
      - applied owner and group permissions to www-data for PW location
      - applied permissions to folders and files accordingly
      - applied a2enmod rewrite to apache2 on live server and restarted service
      I have read some posts (Ryan's too) about migration and it seems to me that I'm doing it fine, don't know what it fails-
      I'm on VMWare machine, Ubuntu Server 18.04, php 7.2, phpMyAdmin 5.0.1
      Hope you can help me, thanks in advance
    • By rushy
      Hi. I've been using Processwire for a few years now and installed it on a few different shared hosting servers without issues, but I'm now running into an issue on a Fasthosts shared server that I've not seen before. The installation goes ok and I have a working default site profile but I am unable to complete any uploads of images. It just hangs at the progress spinner during the upload. I thought it might be a priviledge issue so have temporarily set the dir / file privs. as 777 / 666 just to test that but it made no difference. I have no errors in the wire log. In server error log I have:
      set_time_limit() has been disabled for security reasons in ....htdocs/wire/core/ImageSizerEngine.php on line 1035 and i note in the assets/file dir. where the image is being stored the date on the file being created has a year of 1970 and 0 length. If I leave the page this file disappears and nothing has been stored. 
      Does anyone know how I can enable set_time_limit if this is likely to be the problem? 
      Many thanks! Paul
    • By Robin S
      After forgetting the class name of the wonderful AdminPageFieldEditLinks module for what feels like the 100th time I decided I needed to give my failing memory a helping hand...
      Autocomplete Module Class Name
      Provides class name autocomplete suggestions for the "Add Module From Directory" and "Add Module From URL" fields at Modules > New.
      Requires ProcessWire >= v3.0.16.

      Install the Autocomplete Module Class Name module.
      Add Module From Directory
      Choose the type of autocomplete suggestions list: "Module class names from directory" or "Custom list of module class names". The latter could be useful if you regularly install some modules and would prefer a shorter list of autocomplete suggestions. The list of class names in the modules directory is generated when the Autocomplete Module Class Name module is installed. It doesn't update automatically (because the retrieval of the class names is quite slow), but you can use the button underneath when you want to retrieve an updated list of class names from the directory. Add Module From URL
      If you want to see autocomplete suggestions for the "Add Module From URL" field then enter them in the following format:
      [autocomplete suggestion] > [module ZIP url]
      Example: RepeaterImages > https://github.com/Toutouwai/RepeaterImages/archive/master.zip Awesomplete options
      The "fuzzy search" option uses custom filter and item functions for Awesomplete so that the characters you type just have to exist in the autocomplete suggestion item and occur after preceding matches but do not need to be contiguous. Uncheck this option if you prefer the standard Awesomplete matching. Custom settings for Awesomplete can be entered in the "Awesomplete options" field if needed. See the Awesomplete documentation for more information.  
    • By gregg
      While trying to install 3.0.123, i encountered the following error: 
           Parse error: syntax error, unexpected '[' in /home/naucom5/public_html/wire/core/FunctionsAPI.php on line 469
      In cPanel, i extracted the zip file to 'public_html', which created the directory 'processwire-master', and then moved the files from 'processwire-master' to 'public_html' (which previously had 1 unrelated directory).
      Installation went well choosing Uikit profile, including connecting to database. Compatibility check ok (mod_rewrite error cleared after recheck), successful database connection, config.php saved, unchecked a few cleanup items, then the error message.
      Any suggestions appreciated. 
    • By Inxentas
      I love the option to export fields via the CMS, and wondered about using that export data in a module. Basicly, I'd want to configure a field using the CMS and then paste it's export data in the module code as a string, or save it in a seperate file I can read from the module code. Once I have that string as a variable or file, I'd want to run the same code the import option does... but then from my module code's install method!
      Is that possible? It would save a lot of time configuring fields through the API.
  • Create New...