SoccerGuy3

Multi-Language URL Fields Missing

Recommended Posts

SoccerGuy3    5

Running the latest PW install. Installed all 4 Language modules and the language pack for Spanish. I can change my default language and see all the labels in the admin change to spanish. But when I go to ANY page in the tree, I see only a single URL field (default). I do not see the additional field to enter the "/es/" into.

From the docs (what I don't see):

Quote

Once the Language Support Page Names module is installed, go and edit your homepage and click on the settings tab.  For the URL Name, you should see multiple inputs, one for each language.

Any suggestions on where to look?

Share this post


Link to post
Share on other sites
AndZyk    421

Hello @SoccerGuy3,

have you added a second language under "Setup => Languages" or have you just installed the language pack in the default language?

You need to create a second language to use multilanguage. ;)

Regards, Andreas

  • Like 1

Share this post


Link to post
Share on other sites
adrian    7,645

To expand on what @AndZyk said - there are two parts to multi-language support in PW. The language packs you have installed are for translating the admin interface. If you want site editors to be able to enter content in alternate languages, then you need to create those languages under Setup > Languages.

  • Like 1

Share this post


Link to post
Share on other sites
SoccerGuy3    5

@AndZyk and @adrian thanks for getting back to me. Yes to both your questions. I have added a second language, Spanish, and can see the option in Admin to switch between Default and Spanish. I have even tested this and see the entire admin in Spanish. I can see the alternate language fields in the individual pages in the admin (actually have already populated them).

The one piece that I am missing is the ability to switch languages in the front end. The docs say there should be a place to enter the second language URL piece (see screenshot attached):

http://domain.com/es/

I cannot find that. It appears that it didn't get installed or isn't working as the docs say it should. Or I am looking in the wrong spot.

Screen Shot 2017-09-13 at 7.02.30 AM.png

Share this post


Link to post
Share on other sites
SoccerGuy3    5

@adrian - Thank you for your offer to help.... You know there are days I really like programming, then there are other days! This is one of those others. I moved the site from my local machine to our dev server so I could give you access. Guess what? When I did that the extra fields for language URL showed up!!

Thanks again. Looks like we are all good now.

  • Like 1

Share this post


Link to post
Share on other sites
adrian    7,645

@SoccerGuy3 - I wonder if a Modules > Refresh would help with that on your local machine - perhaps the Language Support Page Names modules didn't initialize properly?

Share this post


Link to post
Share on other sites
SoccerGuy3    5

@adrian - Tried the refresh. Tried changing permissions and ownership at the command line for the site on the local machine. Nothing works. Frustrating, but moving on. It works on the server that's all that matters (at least for now - hopefully won't break when I move it to the live server!).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.