Jump to content

PW UI: Load denied by X-Frame-Options


Recommended Posts

When I try to load one of the modals in the PW Admin panel, say Insert Link or Crop Image, the modal is blank, and I'm registering a "Load denied by X-Frame-Options" in my console. This option used to work, but I've since ported to a different server and it stopped working.

I've tried adding this to my .htaccess file, with no results.

Header set X-Frame-Options "ALLOW-FROM http://[my_server_ip]"

I also tried commenting out the 'Header always append" line there as well (which I don't really want to do).

I'm assuming it might, but could this have anything to do with the fact that my HTTPS is self-signed and not really configuring?

I'm not at production stage so I'm still futzing around on the server, and moved onto web development and was going to fix my TLS later. Maybe I should fix it now? That's what i'm going to try. Let me know if you have any other ideas.

Edited by alexhowl
Link to comment
Share on other sites

No luck. I'm assuming it has something to do with my port/SSL configuration. I'll come back if fiddling with that doesn't help.

My .htaccess file just needs to be in my / folder correct? I don't need one in /wire/ or anywhere else?

Link to comment
Share on other sites

Wow, Ok. So this was a Firefox issue. It works just fine in IE. But it's strange, because my other ProcessWire instance doesn't throw this X-Frame error.

Still want to know why it would work on Firefox on one instance of PW and not the other. I'm still suspecting it has something to do with my TLS/SSL settings.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...