joshuag

Recurme – Processwire Recurring Dates Field & Custom Calendar Module.

Recommended Posts

13 hours ago, Juergen said:

Works also with UiKit calendar and Bootstrap calendar if you are using a framwork. If you are using UiKit calendar you can make fe a template which outputs all the calendar dates in a json array. Then you can load this template (or lets say the event dates) via ajax into the UiKit calendar template engine. Its very easy.

@Juergen Sorry if I miss something, but where do you find a calendar component at Uikit (https://getuikit.com/docs/introduction)?

Share this post


Link to post
Share on other sites

Sorry, @totoff,

my fault. It mean the Fullcalendar. I use it with Uikit markup (badges,..) so I always call it "UiKit calendar". This was a mistake. Anyway, you can use it with recurme. Here you can find the Bootstrap calendar. Both are available on Jsdelivr CDN. So no need to include the files locally.

Best regards

  • Like 1

Share this post


Link to post
Share on other sites

I'm having an issue when trying to uninstall the Recurme module (v1.0.1) - after checking "Uninstall" and submitting I get a fatal error from PHP timeout (60 seconds).

The issue occurs when trying to uninstall from any of the Recurme sub-modules.

 

Share this post


Link to post
Share on other sites
5 hours ago, Juergen said:

Sorry, @totoff,

my fault. It mean the Fullcalendar. I use it with Uikit markup (badges,..) so I always call it "UiKit calendar". This was a mistake. Anyway, you can use it with recurme. Here you can find the Bootstrap calendar. Both are available on Jsdelivr CDN. So no need to include the files locally.

Best regards

would you mind share some code of your uikit implementation? sounds very interesting. if so, please pm me. thanks.

Share this post


Link to post
Share on other sites

@Robin S Ok, I will do some test and see if I can reproduce this error and fix it. Thanks for bringing it to my attention. 

Share this post


Link to post
Share on other sites

Sorry @totoff, but I have no example here at the moment, but Fullcalendar provides some render functions. I have used them to manipulate the output via Jquery. Fe adding Uikit classes to the buttons (uk-button) and so on. This was the way I have done some manipulations to the calendar. Take a look at this functions and use standard Jquery code to add classes, markup and so on. The calendar itself doesnt need to be manipulated, but as I have written above I have used UiKit markup at the buttons and I have used Uikit badges for the events in the calendar and Uikit tooltips after hovering a link . That was it.

  • Like 1

Share this post


Link to post
Share on other sites

Is it not possible to use recurme within an Repeater? In Repeater Matrix it works, so it is not a big problem, but for my purpose a repeater would suffice...

 

BTW great module and support, Joshua!

Share this post


Link to post
Share on other sites
8 minutes ago, pideluxe said:

Is it not possible to use recurme within an Repeater? In Repeater Matrix it works, so it is not a big problem, but for my purpose a repeater would suffice...

 

BTW great module and support, Joshua!

I have been working on regular repeater support, but it's not quite there. The current problem is that the event object is taking its data from the parent page, in the case of a repeater, it's the repeater page (not what we want). So I have to do a bit more work detecting if it's in a repeater and use getForPage() to populate the event object. A couple other little details. Getting close, but still not there. 

It's coming though! 

  • Like 2

Share this post


Link to post
Share on other sites
35 minutes ago, joshuag said:

I have been working on regular repeater support, but it's not quite there. The current problem is that the event object is taking its data from the parent page, in the case of a repeater, it's the repeater page (not what we want). So I have to do a bit more work detecting if it's in a repeater and use getForPage() to populate the event object. A couple other little details. Getting close, but still not there. 

It's coming though! 

Sounds great, thanks for the quick answer!

Share this post


Link to post
Share on other sites

I am having a complete failure to comprehend the way this field is structured, so while I can use the provided examples to render a list or calendar, from the individual pages I can't manage to access the individual date(s) in the field.

I sent this question to the help email address on Tuesday but haven't received an answer and I'd like to wrap up what seems like it should be a simple thing.

While working on the template for an event page, how do I specify the RecurMe dates from within that template using $page->xxx?

For instance I would normally echo a dateTime field like:

$datefield = $page->datefield;
$pubdate = strftime('j M Y', $datefield);
echo $pubdate; // outputs nothing

But since my recurme field, $page->eventsort, is an array(?), I figured I’d have to crack open the array first like so:

 

$eventsort = $page->eventsort;
foreach ($eventsort as $event) { //it loops through one $event because there is only a non-repeating day listed.
   $pubdate = $event->startDate;
   echo strftime('j M Y', $pubdate); // outputs nothing
}

I used startDate because when I once got the array to output, that was what was listed there. But this returns null. Same with start_date/date/any $event page fields listed in the faqs

I also tried :

$event = $page;
$newsdate = $recurme->event($event); //not sure this is any different than attempting to call $page->xxx?
$nd = $newsdate->start_date;
echo strftime('j M Y', $nd); // outputs "j M Y" on the page.

I've looked in the module files, and in the ready.php hook on page 1 of this thread to see how to take apart the field data, but nothing I've tried has worked.

So rather than continue chasing my tail, I thought I might as you for help with this as well. Thanks!

 

 

Share this post


Link to post
Share on other sites

Hi creativeJay,

Sorry about the slow response. I was away from email yesterday. 

You are correct, It was returning NOTHING if you didn't toggle active. I have fixed it in the attached file. 

Thank you for bringing this to my attention!

Please download the fixed file here:
MarkupRecurme.module

 

Share this post


Link to post
Share on other sites
On 23/06/2017 at 0:12 AM, Robin S said:

I'm having an issue when trying to uninstall the Recurme module (v1.0.1) - after checking "Uninstall" and submitting I get a fatal error from PHP timeout (60 seconds).

The issue occurs when trying to uninstall from any of the Recurme sub-modules.

Hi @joshuag - any update on this issue? Are you able to reproduce the issue at your end?

Share this post


Link to post
Share on other sites
16 hours ago, Robin S said:

Hi @joshuag - any update on this issue? Are you able to reproduce the issue at your end?

Hi Robin :) thanks for checking in. 

Yes, I have fixed the problem and it will be part of the updated release in the next couple days. 

Thanks,

  • Like 1

Share this post


Link to post
Share on other sites

Another reason we need to expand the ProcessWire store @ryan . All these modules spread across different sites - this one is even priced the same way as the official modules.

Share this post


Link to post
Share on other sites

Is it possible to run a 'sort' selector on $recurme->find()?

When I attempt to sort by a particular field, only a single result is output. I can reverse the sort and it will output the opposite result so the sort works, but I get only one result.

Share this post


Link to post
Share on other sites
On 7/21/2017 at 11:03 AM, joshuag said:

Hi Robin :) thanks for checking in. 

Yes, I have fixed the problem and it will be part of the updated release in the next couple days. 

Thanks,

Has this updated version been released yet?  Thanks

Share this post


Link to post
Share on other sites
3 hours ago, DonPachi said:

Is it possible to run a 'sort' selector on $recurme->find()?

When I attempt to sort by a particular field, only a single result is output. I can reverse the sort and it will output the opposite result so the sort works, but I get only one result.

The find method needs to have a startDate and endDate to find results, then a selector. The results will always be sorted by date. Any other sort option will be ignored. If you use ->find() with out those dates, it will only return the recurme events for today  

$recurme->find($dateFrom, $dateTo, $selector)

Share this post


Link to post
Share on other sites
Just now, joshuag said:

The find method needs to have a startDate and endDate to find results, then a selector. The results will always be sorted by date. Any other sort option will be ignored.


$recurme->find($dateFrom, $dateTo, $selector)

Thanks, makes complete sense. The issue I had was with a particular date outputting as AM when it was actually saved as PM so appearing before all other results.

The module is fantastic, but I'm having a consistent issue where if I enter and save a recurme field in a page it displays fine, but when I go back to edit another field on the page and save, it will begin outputting the time as AM when it was selected as PM. Going back in and altering the date fixes this until I alter another field again.

Share this post


Link to post
Share on other sites
6 hours ago, cstevensjr said:

Has this updated version been released yet?  Thanks

 

3 hours ago, DonPachi said:

Thanks, makes complete sense. The issue I had was with a particular date outputting as AM when it was actually saved as PM so appearing before all other results.

The module is fantastic, but I'm having a consistent issue where if I enter and save a recurme field in a page it displays fine, but when I go back to edit another field on the page and save, it will begin outputting the time as AM when it was selected as PM. Going back in and altering the date fixes this until I alter another field again.

I have just sent out a general update via email that resolves the problems mentioned. Thanks everyone :)

  • Like 3

Share this post


Link to post
Share on other sites
2 hours ago, joshuag said:

I have just sent out a general update via email that resolves the problems mentioned.

@joshuag, you say in the email: 

Quote

I have not updated the version number or released the changelog as this is in response to a couple messages on the processwire forum

I think it would be good if you do bump the version number each time you make a release even if it is for bug fixes. Otherwise it isn't clear from the PW modules listing whether that installation has been updated to the latest version, so it's harder to keep track if you have multiple sites running Recurme.

Also, it will be easier for you in terms of support if you can ask what the installed version number is and know from that what release of Recurme the user has installed.

  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, joshuag said:

I have just sent out a general update via email that resolves the problems mentioned.

Hi @joshuag, unfortunately this update does not resolve the problem I am having with uninstallation. When I do the following steps... 

  1. Remove the existing module files
  2. Add the updated module files
  3. Do a modules "Refresh"
  4. Clear compiled files

...I still get the PHP timeout when I try and uninstall, regardless of which sub-module I try and uninstall from. Sometimes timeouts like this are caused by a circular reference in the code. I'm wondering about the fact that each sub-module installs and uninstalls all the others. That seems non-standard to me: normally where there are multiple sub-modules there is one "main" module file that installs/uninstalls the others. The other modules only require the main module but do not install/uninstall them. See FieldtypeRepeater for example. Could there be some circularity where FieldtypeRecurme tries to uninstall ProcessRecurme, which tries to uninstall FieldtypeRecurme, which tries to... and so on?

Share this post


Link to post
Share on other sites
On 8/6/2017 at 9:09 PM, Robin S said:

Hi @joshuag, unfortunately this update does not resolve the problem I am having with uninstallation. When I do the following steps... 

  1. Remove the existing module files
  2. Add the updated module files
  3. Do a modules "Refresh"
  4. Clear compiled files

...I still get the PHP timeout when I try and uninstall, regardless of which sub-module I try and uninstall from. Sometimes timeouts like this are caused by a circular reference in the code. I'm wondering about the fact that each sub-module installs and uninstalls all the others. That seems non-standard to me: normally where there are multiple sub-modules there is one "main" module file that installs/uninstalls the others. The other modules only require the main module but do not install/uninstall them. See FieldtypeRepeater for example. Could there be some circularity where FieldtypeRecurme tries to uninstall ProcessRecurme, which tries to uninstall FieldtypeRecurme, which tries to... and so on?

Has there been any update to this last posting?  Thanks

Share this post


Link to post
Share on other sites

Hi guys, 

I am trying to solve this problem. I cannot reproduce the error. Making it a bit hard to debug.  I tried removing the circular reference to what modules each file installs. Made no difference to me. 

@Robin S any other ideas? 

Share this post


Link to post
Share on other sites

Love the promise of this module. Should save me a bunch of time on this project.

Edited by SoccerGuy3
Removed error message. Figured it out 5 minutes after posting.

Share this post


Link to post
Share on other sites

Working on the detail page now and having a problem getting the date/time of the event to show on the page. If my page array contains this:

[calev_datetime] => {"startDate":1504821600,"endDate":false,"dates":["W36/07/Thu/Sep/2017",...,"W19/07/Wed/May/2025"],"excluded":[],"active":false,"showResults":false,"rrule":"WKST=MO;FREQ=DAILY;DTSTART=20170907T150000Z;INTERVAL=1"}

How can I get the date to output to the page like: 09/07/2017 3:00 pm? I've tried various bits and pieces to get at the startDate or the DTSTART, but always end up with a nothing on screen (in that area).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Robin S
      Another little admin helper module...
      Template Field Widths
      Adds a "Field widths" field to Edit Template that allows you to quickly set the widths of inputfields in the template.

      Why?
      When setting up a new template or trying out different field layouts I find it a bit slow and tedious to have to open each field individually in a modal just to set the width. This module speeds up the process.
      Installation
      Install the Template Field Widths module.
      Config options
      You can set the default presentation of the "Field widths" field to collapsed or open. You can choose Name or Label as the primary identifier shown for the field. The unchosen alternative will become the title attribute shown on hover. You can choose to show the original field width next to the template context field width.  
      https://github.com/Toutouwai/TemplateFieldWidths
      https://modules.processwire.com/modules/template-field-widths/
    • By horst
      Croppable Image 3
      for PW 3.0.20+
      Module Version 1.1.16
      Sponsored by http://dreikon.de/, many thanks Timo & Niko!
      You can get it in the modules directory!
      Please refer to the readme on github for instructions.
       
      -------------------------------------------------------------------------
       
      Updating from prior versions:
       
      Updating from Croppable Image 3 with versions prior to 1.1.7, please do this as a one time step:
      In the PW Admin, go to side -> modules -> new, use "install via ClassName" and use CroppableImage3 for the Module Class Name. This will update your existing CroppableImage3 module sub directory, even if it is called a new install. After that, the module will be recogniced by the PW updater module, what makes it a lot easier on further updates.
      -------------------------------------------------------------------------
       
      For updating from the legacy Thumbnail / CropImage to CroppableImage3 read on here.
       
      -------------------------------------------------------------------------
       
    • By MoritzLost
      UPDATE: I have published a stable version of this module!
      Discussion thread:
      Github: https://github.com/MoritzLost/TextformatterPageTitleLinks
      ---
      Hello there,
      I'm working on a tiny textformatter module that searches the text for titles of other pages on your site and creates hyperlinks to them. I'm not sure if something like this exists already, but I haven't found anything in the module directory, so I wrote my own solution 🙂
      It's not properly tested yet and is still missing some functionality I would like to implement, so at the moment it should be considered in BETA. Features include limiting the pages that will get searched by template, and adding a custom CSS class to the generated hyperlinks. As I'm writing this I noticed that it will probably include unpublished and hidden pages at the moment, so yeah ... it's still in development alright 😅
      You can download the module from Github:
      https://github.com/MoritzLost/TextformatterPageTitleLinks
      There's some more information in the readme as well.
      Anyway, let me know what you think! I'm happy about any feedback, possible improvements or ideas on how to improve the module. Cheers.
    • By blad
      Hi guys!
      I just uploaded a module to explore files based on elFinder. By default it will show the "Files" folder.
      Screenshots:

      Video:
       
      To do:
       More options To fix:
       The function of rotating or scaling an image fails  Image editors V 1.01 (view issue)
      Fixed the bug working with the Multi-Language support ( translation of folders ). Fixed the name of elfinder.en  Github:
      https://github.com/LuisSantiago/ProcessElFinder/
      I hope you like it.
    • By BitPoet
      I'm really in love with FormBuilder, but the one thing missing to match all my end users' expectations were repeatable field groups. Think repeaters, in ProcessWire terms. Our primary application of PW is our corporate intranet, so "lines" of fields are quite common in the forms I build. We have all kinds of request forms where the information for a varying number of colleagues needs to be entered (from meal order to flight booking request) and where it is simply impractical to send a form for each, and I don't want to clutter my forms with multiple instances of fields that may only get used ten percent of the time.
      That's why I started to build FormBuilderMultiplier (link to GitHub).
      What it does:
      Adds an option to make a regular Fieldgroup repeatable Lets you limit the number of instances of a Fieldgroup on the form Adds an "Add row" button the form that adds another instance of the Fieldgroup's fields Adds a counter suffix at the end of every affected field's label Stores the entered values just like regular fields Makes the entered values available in preview and email notifications Supports most text based fields, textareas and selects (really, I haven't had enough time to test all the available choices yet) What it doesn't do (yet):
      Support saving to ProcessWire pages (i.e. real Repeaters) I haven't tested all the validation stuff, Date/Time inputs etc. yet, but since I'm utterly swamped with other stuff at work, I didn't want to wait until I have it polished. Any feedback is welcome. There might also be some issues with different output frameworks that I haven't encountered yet. The forms I work with mostly use UIKit.
      Status:
      Still alpha, so test well before using it in the field.
      Known issues:
      When rows are added, the form's iframe needs to be resized, which isn't completely clean yet.
      How it works:
      The Fieldgroup settings are added through regular hooks, as is the logic that adds the necessary field copies for processing the form and displaying previews.
      "Multiplied" field instances are suffixed with _NUM, where NUM is an incremental integer starting from 1. So if you have add two fields named "surname" and "givenname" to a fieldgroup and check the "multiply" checkbox, the form will initially have "surname_1" and "givenname_1" field (I'm still considering changing that to make the risk to shoot oneself into the foot by having a regular "surname_1" field somewhere else in the form less likely).
      When a "row" is added, the first row is cloned through JS and the counter in the fields' IDs, names and "for" attributes as well as the counter in the label are incremented before appending the copies to the Fieldset container in the form.
      To keep backend and frontend in sync, a hidden field named [name of the fieldset]__multiplier_rows is added to the form. Both the backend and the frontend script use this to store and retrieve the number of "rows".
      ToDo:
      Naturally, add the option to store the data in real repeaters when saving to pages. Do a lot of testing (and likely fixing). Make a few things (like the "Add row" button label etc.) configurable in field(set) context. Add a smooth API to retrieve the multiplied values as WireArrays. The mandatory moving screenshot: