fredmv

ProCache causing strange default URI behavior

Recommended Posts

fredmv    0

Hi folks,

 

We recently turned on ProCache and have noticed this happening when the homepage of the site is accessed:

When you go to our homepage (as in, typed into an address bar -- oddly it doesn't happen with bookmarked pages), it results in this:

https://www.villasofdistinction.com/site/assets/ProCache-5a95c48539bfade3888cb4c439f//index-www_villasofdistinction_com.html

 

Of course, nothing should appear in the address but the "https://www.villasofdistinction.com/". 

 

Why does the rest, "site/assets/ProCache-5a95c48539bfade3888cb4c439f//index-www_villasofdistinction_com.html" appear? And what can be done to get rid of it?

Thanks for any help - Happy Friday!

 

Share this post


Link to post
Share on other sites
fredmv    0

Thanks, Sérgio.   Very fast response!

 

I'm looking at the .htaccess now - what specifically would you recommend tweaking?  There's a LOT of mentions of ProCache in it. 

Share this post


Link to post
Share on other sites
rick    329

Your site loads fine for me (chrome) when first entered in the address bar. One thing I did notice is each menu item is prefixed with 'Header:' in the title field.

Nice site by the way. Costa Rica here I come. :)

Share this post


Link to post
Share on other sites
fredmv    0

Thanks, Rick!   Alas, some folks here are noticing that issue, and I do need to figure out how to correct it. 

 

It took me a second to be able to 'trigger' the bug, too, but it does seem to happen sometimes in some contexts.

Share this post


Link to post
Share on other sites
Sérgio Jardim    396
2 hours ago, fredmv said:

Thanks, Sérgio.   Very fast response!

 

I'm looking at the .htaccess now - what specifically would you recommend tweaking?  There's a LOT of mentions of ProCache in it. 

Well, things look ok to me, I can access the site fine.

It appears there's no problem with your .htaccess after all as you said ProCache already edited it. Maybe it's a cache from your browser. 

  • Like 1

Share this post


Link to post
Share on other sites
kongondo    5,016

Hi @fredmv,

Welcome to the forums. If you have an active ProCache licence then it is best to post your question in that module's VIP forum. Ask @ryan for access if you don't have one yet.

Share this post


Link to post
Share on other sites
fredmv    0
4 hours ago, kongondo said:

Hi @fredmv,

Welcome to the forums. If you have an active ProCache licence then it is best to post your question in that module's VIP forum. Ask @ryan for access if you don't have one yet.

 

Thanks, @kongondo, I wasn't aware of that forum.   @ryan, could you please set up access and/or offer insight to the above issue?  Thanks.

Share this post


Link to post
Share on other sites
fredmv    0

Bumping this -  also I can't seem to find this "VIP forum".  I guess I don't have access.  

 

 

Share this post


Link to post
Share on other sites
fredmv    0
17 hours ago, kongondo said:

PM or email @ryan

 

I did yesterday; still haven't heard back.

 

When I think about this more, it probably does have something to do with .htaccess, particularly mod_rewrite.   Likely, that "[...] /site/assets/" address is the real URI, and .htaccess/mod_rewrite should rewrite and display the URL just as "villasofdistinction.com".   I'm just not quite sure how to do that.

Share this post


Link to post
Share on other sites
Macrura    2,142

@fredmv

i would recommend contacting Ryan again to request access to the ProCache forum.

If you have your receipt email from the shop, you may be able to reply to that, in case the PM doesn't work.

Note that Ryan is only typically addressing the pro module forums on Sundays.

Share this post


Link to post
Share on other sites
fredmv    0
15 hours ago, Macrura said:

@fredmv

i would recommend contacting Ryan again to request access to the ProCache forum.

If you have your receipt email from the shop, you may be able to reply to that, in case the PM doesn't work.

Note that Ryan is only typically addressing the pro module forums on Sundays.

Thanks, @Macrura.  Contacted him again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rst
      Seems like procache minify removes a trailing slash within embedded svg files tags ( path, polygon, rect etc ) It causes the svg not display correctly in Safari and Chrome. How do I force it to keep that slash?
       
      Thanks
    • By andy-jfd
      Hey! 
      I've just installed ProCache which is awesome. 
      I did notice though that my <body> tag was omitted in the minified HTML output. I managed to get the body to render by adding a class to it. 
      Any else had this issue before? 
      Andy 
    • By Guy Verville
      Hi,
      I'm running several speed tests for my personal site using http://webpagetest.org.  My site has the ProCache module installed. The lifespan is set to 1 week, but I am not sure it is the same as the expire date seen in the following report : WebpageTest for guyverville.com.
      Setting Expire Headers can be done in .htaccess. I don't want to interfere with ProCache, but would like to understand what I can do here. 
      Thanks
    • By overoon
      hi,
      i have a question, which i should be able to work out with htaccess, i just wanted to ask, if there's an easier way using processwire:
      i set up a new site using processwire with multilang etc. since a lot of stuff changed on the website (contents, hierachy, ...) there's now also a different domain structure. the old structure was:
      www.example.com/outlet-1
      and now it's
      www.example.com/en/find-us/outlet-1
      is there any way i can do a (temporary) 301 redirect, without having to remodel to the whole structure? the main reason for this is, that there are still tons of flyers and other advertising materials with this domain structure (transitionphase should end in <6months)
      the whole thing comes down to about 4-5 pages -- so nothing really drastic. also if there's no way in doing this with processwire, help with a proper RewriteRule for htaccess would be greatly appreciated. current workaround doesnt really do the trick.
      thanks so far!
    • By vxda
      Hi guys, im thinking about purchasing ProCache module, but i dunno if it will be any good on my site http://hejtuje.com.
      Content on the site is added by users and its changing all the time. Would my site benefit from proCache or caching is just a bad idea for this type of site ? Please advice.
      Thanks!