derdogan

SQL Errors while installing

Recommended Posts

Hey there,

I just discovered Process Wire and wanted to give it a try, but I can't complete the installation process. I try to install it on my local Ubuntu installation. After entering the MySQL credentials I get a bunch of SQL errors on the next step of the install script.

The given database exists and I'm using a user with full permissions for that DB. Some tables do exist after the step but apparently not all of them.

MySQL server version: 5.7.18

PHP version: 7.0.18

Any ideas?

Bildschirmfoto von »2017-05-14 18-41-32«.png

wire-fullpage.png

Share this post


Link to post
Share on other sites

@derdogan,

Welcome to the forum!

I have installed ProcessWire on my Ubuntu system many times without any errors. The only thing I can see that looks odd is naming the database 'wire', since that is internal to ProcessWire. Try starting again, but with a different database name.

Share this post


Link to post
Share on other sites

Hello rick, thanks for your answer. I tried a database with another name ('foobar') and the same errors occur.

Edit: Hm I think there is something wrong with my php setup. I will post what was wrong once I figured this one out.

Share this post


Link to post
Share on other sites

If I remember correctly, there were a couple of mods that weren't enabled by default in the initial apache/php install that needed to be set. I don't remember which ones specifically, so here is a listing of mine you can use to compare...

access_compat.load
alias.conf
alias.load
auth_basic.load
authn_core.load
authn_file.load
authz_core.load
authz_host.load
authz_user.load
autoindex.conf
autoindex.load
cgi.load
deflate.conf
deflate.load
dir.conf
dir.load
env.load
filter.load
headers.load
mime.conf
mime.load
mpm_prefork.conf
mpm_prefork.load
negotiation.conf
negotiation.load
php7.0.conf
php7.0.load
rewrite.load
setenvif.conf
setenvif.load
status.conf
status.load

 

  • Like 1

Share this post


Link to post
Share on other sites

I had similar problems after updating MYSQL via homebrew and importing a Backup made by ProcessDatabaseBackups. I could fix it by adding a few lines to my .sql file. Could you give some information about  MYSQL version and your global settings (my.cnf) especially sql_mode? Try the following to solve

# --- check sql mode
SELECT @@sql_mode;
+-------------------------------------------------------------------------------------------------------------------------------------------+
| @@sql_mode                                                                                                                                |
+-------------------------------------------------------------------------------------------------------------------------------------------+
| ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
+-------------------------------------------------------------------------------------------------------------------------------------------+

# --- you could add this on top in the .sql file
# --- remove values STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE from the returned values and overwrite sql mode. Looks like
SET @@session.sql_mode ="ONLY_FULL_GROUP_BYERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION";

# --- should also work
SET @@session.sql_mode ="ALLOW_INVALID_DATES";

# --- or
SET @@session.sql_mode ="";

 

Share this post


Link to post
Share on other sites
On 15.5.2017 at 0:17 AM, kixe said:

I had similar problems after updating MYSQL via homebrew and importing a Backup made by ProcessDatabaseBackups. I could fix it by adding a few lines to my .sql file. Could you give some information about  MYSQL version and your global settings (my.cnf) especially sql_mode? Try the following to solve


# --- check sql mode
SELECT @@sql_mode;
+-------------------------------------------------------------------------------------------------------------------------------------------+
| @@sql_mode                                                                                                                                |
+-------------------------------------------------------------------------------------------------------------------------------------------+
| ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
+-------------------------------------------------------------------------------------------------------------------------------------------+

# --- you could add this on top in the .sql file
# --- remove values STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE from the returned values and overwrite sql mode. Looks like
SET @@session.sql_mode ="ONLY_FULL_GROUP_BYERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION";

# --- should also work
SET @@session.sql_mode ="ALLOW_INVALID_DATES";

# --- or
SET @@session.sql_mode ="";

 

Hi! Sorry for my late answer, I had been busy and couldn't mess around with PW any further.

However, setting the sql_mode to "" in my mysql configuration worked! Thank you (and all other people who responded).

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.