Jump to content
rayorg

Processwire Not User-Centric?

Recommended Posts

Hi all,

I discovered Processwire a little over a week ago and have been playing around with it ever since.  Going through the tutorials, creating templates, pages, etc. and see what a nice system it is.  However, I'm led to believe that's it's not meant for user-centric sites, and by that I mean a site where you expect to have hundreds/thousands of users and expect them to log in, update their profiles, submit content, create galleries, message each other, chat in the Forum, get email notifications, etc. etc., you get the idea.  

I was trying to update the Profile page last night by adding fields for First Name, Last Name, Profile Pic, and a bunch of others and realized that it's not that easy to do.  There's not even a template.php file for the Profile page.   Am I just not seeing it because I'm so inexperienced with the CMS?  Or, is Processwire really geared more towards sites where not much user interaction is expected?

thanks,

Ray

Share this post


Link to post
Share on other sites

Go to Setup/Templates:

 

pw-user0.thumb.png.19cec7df18e70a29e280ae961f74d78d.pngpw-user1.thumb.png.ce237673e7dae66fb7ce54e6cd3a57bc.pngpw-user2.thumb.png.61a24d5c5ef674e692a2f90b8738d279.png

You should now be able to add any additional fields that you need.

 

 

 

 

  • Like 6

Share this post


Link to post
Share on other sites

Additionally, if you look at the link on the user template that says: To configure what fields a user can edit in their profile, see the profile module settings.

You will be able to choose which fields are editable by users themselves.

Like so:

1.thumb.PNG.6a1594134e53dc8d5f8a167c32e8efd6.PNG

When users log in, their profile will be editable like:2.thumb.PNG.35bb1552184e62176d4573ac3d4bf790.PNG

  • Like 5

Share this post


Link to post
Share on other sites

Awesome!  Thank you.  I just need to get more familiar with the CMS I think.   My current sites are very much user-driven, so a lot of that functionality was built-in from the get-go.

-Ray

Share this post


Link to post
Share on other sites

Some more links you might also find useful:

Hope this helps too.

Edited by szabesz
typo
  • Like 6

Share this post


Link to post
Share on other sites

Great thread, will be bookmarking this one.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By louisstephens
      Not really sure where to post this, but I routinely receive a 502 Bad Gateway with the forums after I refresh. If I refresh after the error, the forum loads but the sidebar widget with "latest" posts is gone and just the user list is there. After a 2nd refresh, it loads normally. Has anyone else experienced this issue before or is the forum just being stubborn for me.
    • By AndZyk
      Hello,
      this maybe a simple question, but it bothers me for a while now:
      There used to be a warning, if two or more user try to edit the same page. But ever since AdminThemeUIkit I haven't seen it any more.
      Is this a bug or are there special circumstances under which the warning will be displayed?
      If I am logged-in in the same browser with one default and one privat window, I don't see this warning. But also different browsers on different machines in the same network don't see this warning.
      I was looking for the blog post on which this feature was announced, but couldn't find it anymore.
      We had the case, that two people were writing a text for the same page, but after person A saved the page first, the text of the person B was lost. I know we could have used ProDrafts for this case, but it shouldn't happen in the first place.
      I would appreciate some feedback. 😀
      Regards, Andreas
    • By SwimToWin
      I have a website that allows users to create their personal "website" (a page with sub-pages).
      Users shall be able to:
      Log in (frontend and/or admin), Edit "their" page(s) - I am using the "Page Edit Per User"-module (https://modules.processwire.com/modules/page-edit-per-user/) to grant access to the relevant pages Create child pages - possible? Users shall not be able to see other pages in the admin interface - "Admin Restrict Page Tree" may do the trick (https://modules.processwire.com/modules/admin-restrict-page-tree/)? Frontend editing shall be possible - I am considering "Fredi" (https://modules.processwire.com/modules/fredi/) for this. The challenge is that it takes a lot of modules and configuration.
      Is there a way to set this up that doesn't require a lot of configuration for each new user?
    • By benbyf
      Hello, having trouble getting PW to save my user or field in cron hook.
      It seems to report the same field info each time unchanged. It should be counting down in seconds.
      public function init() { // set to every30Seconds in settings $this->defaultInterval = $this->cron_check; // add hooks to CRON $this->addHookAfter("LazyCron::{$this->defaultInterval}", $this, 'checkUserSubscription'); } public function ___checkUserSubscription(HookEvent $e){ // seconds since last lazycron $seconds = $e->arguments[0]; $log = wire('log'); $field = $this->exclusiveRole; // users with specific role and field $users = $this->users->find("roles=$field"); foreach ($users as $user) { // get stored time $currentTime = $user->get($this->fieldName); // if time not null if($currentTime){ // evalute stored time minus time past $resultTime = intval($currentTime) - intval($seconds); $log->message("result ".$resultTime); // save user page $user->set($this->fieldName, $resultTime); $this->users->save($user); } } }  
    • By benbyf
      HELLO! having user Role issues.
      I've got a Role:  members and a template that is set to only allow view of Members and to redirect anyone else to / but id redircts Member users still currently, and only alows people to view the page if the template is set to view on the guest role also.
      Any help would be appreciated. I'm running  ProcessWire 3.0.62



×
×
  • Create New...