Jump to content
Wanze

ProcessGoogleAnalytics

Recommended Posts

I can't get this to work. Always getting the attached screen from Google. Client_ID, URLs and secret are triple checked, no success. Any ideas?

post-472-0-07601700-1393583530_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Wanze, thx! That did the trick. But no matter which account I choose, there are no records displayed. No errors in console.

post-472-0-16663200-1393844651_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Wanze, thx! That did the trick. But no matter which account I choose, there are no records displayed. No errors in console.

Did you use the account "All Website Data"?

Note:

I had the same issue as you, using this account worked for me.

Share this post


Link to post
Share on other sites

Did you use the account "All Website Data"?

Note:

I had the same issue as you, using this account worked for me.

I can't see this selection. I only can select from about 15 domains I have configured in my GA account.

Share this post


Link to post
Share on other sites

When i run into problems with the GA Api it was usually due to Curl, that was somehow configured wrong or different.

Could you try if it maybe works after trying this here: http://processwire.com/talk/topic/1609-processgoogleanalytics/?p=43877

Otherwise I think you'd have to debug directly in the code and check if Google returns any error codes from the queries.

Tell me if I can help you there.

I will update the module and add the date range as main header rather than h2, which gets messed up with the new admin theme.

Share this post


Link to post
Share on other sites

Great, Wanze! 

Tried following all the steps, but after Authentication I get a "Errore:invalid_client no application name"

What do you think it might be? 

Thanks!!

Share this post


Link to post
Share on other sites

@Manaus,

Please take a look at some posts before, this solution may help: https://processwire.com/talk/topic/1609-processgoogleanalytics/?p=55523

@all

I just updated the module to 1.2.1 which fixes the issue with the dates in the header with the new admin theme from 2.4.

Looking at my code, I realized that this will need some refactoring if I finally find time (most likely during summer holidays).

However, the fact that everything still works speaks very much for ProcessWire :)

@MadeMyDay

Could you solve the problems? I just installed on a brand new dev version of Pw and everything was working as expected.

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

I am getting this error after updating to installed: 1.2.1

Each time i click the google analytics TAB I see the below message.

Method ProcessGoogleAnalytics::wire does not exist or is not callable in this context

I tried to revoke my google account, i even tried uninstalling module, but this didn't work either.

Can anyone explain why this is happening? 

And any possible solutions?

Thanks.

Share this post


Link to post
Share on other sites

Hi JasonS,

Hmm it looks like the wire method is missing. What version of ProcessWire are you using?

With version 1.2.1 I used the wire method two times: https://github.com/wanze/ProcessGoogleAnalytics/commit/81cb793eb7870226389b3609ab78f6af27602344

Can you try to change the two lines where this method is called like this:
Edit: In the file /site/modules/ProcessGoogleAnalytics/ProcessGoogleAnalytics.module

// $this->wire('breadcrumbs')->append(new Breadcrumb($this->page->url, $this->page->title));
wire('breadcrumbs')->append(new Breadcrumb($this->page->url, $this->page->title));

// $this->wire('processHeadline', $startDate . " - " . $endDate);
Wire::setFuel('processHeadline', $startDate . " - " . $endDate);

Does this solve the issue?

  • Like 1

Share this post


Link to post
Share on other sites

Hi Wanze,

I'm using Processwire version 2.3.1 .

Amazing!!! Your solution worked.

Many Thanks.

Share this post


Link to post
Share on other sites

Thank you very much indeed for this Module Wanze.

After fixing a silly from Google

401. That’s an error.Error: invalid_client
no application name

that you'd kindly posted the fix to, I was in! And wow... It's clean view of GA data is in ways a significant step up from the native view in GA console. Let alone the convenience of seeing this data when I am working on a site.

Fabulous Wanze! :D

Share this post


Link to post
Share on other sites

Hey Wanze,

Just a small thing :)

Could you please have the chart color config setting also control the color of the bar graphs throughout the module, rather than just the jQPlot charts?

Thanks.

Share this post


Link to post
Share on other sites

Hi Adrian,

Thanks for your suggestion, it makes totally sense - will update the module later this week.

The reason I've chosen to add this setting is that the color has to be set with javascript (jqplot) so it can't be controlled with CSS.

The bar graph colors could be changed with CSS, but of course the colors should match by default!

Cheers

  • Like 3

Share this post


Link to post
Share on other sites

Thanks! Works like a charm :)  i will translate to spanish.

  • Like 2

Share this post


Link to post
Share on other sites

Hi Wanze,

Tried on local install. Getting cannot fetch token error Ideas? Thanks.

PW 2.4.15 (dev)

Edit:

Working fine on live server. Thanks!

Edited by kongondo
  • Like 1

Share this post


Link to post
Share on other sites

I think you'll never get a negative amount of visitors (so you don't need "-50")  :)

post-140-0-02160500-1419511548_thumb.png

How to solve:

Change line 42 in the js file (0 instead of null):

yaxis:{min:0,

----------

And another little thing:

post-140-0-18846000-1419512564_thumb.png

  • Like 2

Share this post


Link to post
Share on other sites

Thanks Nico, will integrate your suggestions in the next version :)

  • Like 1

Share this post


Link to post
Share on other sites

Hello.

    I'm getting confuse with the installation in step 5:

  • Enter a Redirect URI to the GA-Page in your Processwire Installation:http://yourdomain.com/processwire/google-analytics/

google-analytics is under the administration pages and uses the admin template, where do I've to do the redirect?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi Manol,

You have to enter the redirect URL in the Google API console. Google needs to know the URL of the app.

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

Solved after adding slash after domain name, or maybe was a question of time from google to update.

Thank you.

  • Like 1

Share this post


Link to post
Share on other sites

I have already used a previous version of this module,

now i have created a new website and everything works to authorize but i can't select an Account, this dropdown is empty (while have 3 diffrent accounts that are working on other older sites where the module still uses the "Google Analytics Account Id" field)

What am i doing wrong?

Thank you.

***

Solved,

forgotten to enable the Analytics API

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2019-10-18
      2019-08-08
      2019-06-15
      2019-06-02
      2019-05-25
      If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      (please have a look at the screenshots to get an idea what I'm talking about)
       




    • By eelkenet
      Hi! I've created a small Inputfield module called InputfieldFloatRange which allows you to use an HTML5 <input type="range" ../> slider as an InputField. I needed something like this for a project where the client needs to be able to tweak this value more based on 'a feeling' than just entering a boring old number. Maybe more people can use this so I'm hereby releasing it into the wild.  
       
      What is it?
      The missing range slider Inputfield for Processwire. 
      What does it do?
      This module extends InputfieldFloat and allows you to use HTML5 range sliders for number fields in your templates.
      It includes a visible and editable value field, to override/tweak the value if required.  
      Features
      Min/max values Precision (number of decimals) Steps (Read more) Manual override of the selected value (will still adhere to the rules above) Usage
      Clone / zip repo Install FieldtypeFloatRange, this automatically installs the Inputfield Create new field of type `Float (range)` or convert an existing `Float`, `Integer` or `Text` field. To render the field's value simply echo `$page->field` Demo
      A field with Min=0, Max=1, Step=0.2, Precision=2

      Field with settings Min=0, Max=200, Step=0.25, Precision=2

       
      Todo
      Make the display-field's size configurable (will use the Input Size field setting)  Hopefully become redundant If it's usable for others I'll add it to the Modules list  
      Changelog
      v002
      - Fix issue where setting the step value to an empty value created problem with validation
      - Make the display-field optional 
      v001
      - Initial release
       
      Thanks!
       
       
    • By Robin S
      Another little admin helper module...
      Template Field Widths
      Adds a "Field widths" field to Edit Template that allows you to quickly set the widths of inputfields in the template.

      Why?
      When setting up a new template or trying out different field layouts I find it a bit slow and tedious to have to open each field individually in a modal just to set the width. This module speeds up the process.
      Installation
      Install the Template Field Widths module.
      Config options
      You can set the default presentation of the "Field widths" field to collapsed or open. Field widths entered into the Template Field Widths inputfield are only applied if the Edit Template form is submitted with the Template Field Widths inputfield in an opened state. "Collapsed" is the recommended setting if you think you might also use core inputs for setting field widths in a template context. You can choose Name or Label as the primary identifier shown for the field. The unchosen alternative will become the title attribute shown on hover. You can choose to show the original field width next to the template context field width.  
      https://github.com/Toutouwai/TemplateFieldWidths
      https://modules.processwire.com/modules/template-field-widths/
    • By adrian
      Tracy Debugger for ProcessWire
      The ultimate “swiss army knife” debugging and development tool for the ProcessWire CMF/CMS

       
      Integrates and extends Nette's Tracy debugging tool and adds 35+ custom tools designed for effective ProcessWire debugging and lightning fast development
      The most comprehensive set of instructions and examples is available at: https://adrianbj.github.io/TracyDebugger
      Modules Directory: http://modules.processwire.com/modules/tracy-debugger/
      Github: https://github.com/adrianbj/TracyDebugger
      A big thanks to @tpr for introducing me to Tracy and for the idea for this module and for significant feedback, testing, and feature suggestions.
×
×
  • Create New...