Jump to content

strange problem with DB dump and $config->urls at localhost


Recommended Posts

Hi there,

today i run in a very strange Problem. I downloaded a DB dump from a working processwire site (online) and importet it.
When i use this DB with my local development version of the site the $config->urls seem to be "broke".  
But only as long as i am not logged in to the admin pannel! FYI the online version is just a copy of my local version with
one difference - i had to change a RewriteRule in the .htaccess because the online version works with a VirtualDocumentRoot.

And now here comes the next very strange thing:
When using the DB dump and  $config->urls isent working (points only to localhost:8888/) and i make changes in the home.php
they dont show up when i refresh the local version in browser. I can even delete everything in home.php and the browser still shows
the broken version of the site. I mean that's more than strange or?

Anybody any idea to this mess? Would be glad because i realy stuck here. Thanks in advance.

Best regards Simon 

Link to comment
Share on other sites

In this case at a time i had setup the cache module with an timeout of a month ... but dunno why i uninstalled it later.
I use mainly chrome with dev tools and set cache to disabled. BTW it happens in all my installed browsers - xcode simulator
and my android phone.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By NooseLadder
      I've been out of the game for a number of years (6/7). I have a few projects lined up. I used to use XAMPP on my Windows PC back then. I have a Windows 8.1 laptop atm. Is XAMPP still ok or can you recommend anything better? I used to upload files to server using FileZilla. Thanks.
    • By Peter Knight
      Hi all
      My .htaccess file is correctly redirecting all requests to
      https:// www. That's great until I want to work locally.
      I thought I had seen a blog post by Ryan where there was a new config setting to ignore both of these if working from localhost?
      I can't find it now so wondering if I was imagining 😕
    • By kongondo
      So, all of a sudden, Chrome is blocking all of my localhost sites, claiming my connection is not Private, blah blah..Here is the full text of what Chrome is telling me.
      I get no option to 'continue to this unsafe site'. 
      It seems I have no option but to install SSL on my local sites. I have seen some articles on how easy it is to do in a Mac but I am on Windows. Anyone has pointers on how I can do this? Alternatively, anyone knows what this Chrome error is about? Bottom line is, unless I change browsers, I am not currently able to develop and test stuff locally. Grr!
    • By totoff
      Hi Forum,
      we moved an installation from the live server to localhost for further development. Unfortunately now PW doesn't find files in the /templates/ directory anymore (e.g. css, js and so on). Functions testing for existing files abort with an error and the console throws 404 for the files in question.
      Two developers have checked (so far several times):
      site/config.php $config->httpHosts .htaccess file permissions on /templates/ and all subdirectories (set to 777 just to be on the safe side) our own php functions Our version is 3.0.22 devns.
      We are running out of ideas. Any help is appreciated. Thanks.
    • By j00st
      Hi everyone!
      Although I've set up a couple of sites using Processwire now, I still run into typical 'Getting Started' errors - and I figured this is yet another one...

      On the previous site I built (locally and on a server) I had no problems with modules (downloaded them, placed them in the folder, installed, worked) but this time around two of the modules I want to use are not working. 
      I'm using a textarea with Markdown (Parsedown Extra to be more precise - which works fine), but on the same textarea fields I want to use both the TextFormatterVideoEmbed (for YouTube & Vimeo) and the ImageTags (for embedding from the images field on the same page)
      Current situation for:
      VideoEmbed – Link is shown as link.
      ImageTags - Throws the following error Notice: Array to string conversion in ../site/modules/ImageTags/TextformatterImageTags.module on line 20
      Should I use a different version of Markdown? (Haven't tried that - just realised it while typing this post...)
      I have the feeling I might be overlooking something really obvious, but I can't put my finger on it. Suggestions? Tips? Cheers!
  • Create New...