Doc

Many db sessions but not so many users ??

Recommended Posts

Hello,

My website is live for 24h now.

In the admin, setup->session section, I see many sessions but apparently own buy the same user, is it normal ? (see the screenshot).

I guess it eats database ram ? Is there a way to change that behavior ? Stop the db sessions maybe ?

Update : 

Don't know if it's related but my Guest user is inserting dozens and dozens of lines in session table... (10 to 100 / minute)

Thanks

 

Screen Shot 2017-03-22 at 15.06.13.png

Share this post


Link to post
Share on other sites

The most UAs, regarding your screenshot, are a Facebook Browsers: FB_IAB/FB4A

So, you first should check why / which Facebook-Apps are polling your site, and if they properly send session-cookies with each following request, or if they open a new session with every poll.

  • Like 3

Share this post


Link to post
Share on other sites

Mmhhhh, very good move.

I've launched some promote ads with FB, it could comes from that.

I'm going to investigate and will post result here.

Thanks a lot !

Share this post


Link to post
Share on other sites

I get rid of facebook (stopped campaigns, not enough effective according to me actually), and now discover other peoples walking here (see screenshot).

I still don't understand why does it hit several times per second the DB...

(checkmy.ws is my external monitoring solution)

Perhaps I'll go back to file based sessions, I'm a bit scared to see those access to the DB...

Screen Shot 2017-03-22 at 18.39.04.png

Share this post


Link to post
Share on other sites

Using filebased sessions is slower, and for every DB record, you will get a file in filesystem. This would be fighting the symptoms and not the reason! :)

To be honest, a monitoring service that sends 7-15 requests in one second, each starting a new session is not what I would expect from professionals.

At next step, I would drop that service and see how it comes with the total amount. Or maybe there are config options with that service? One request every five minutes would be enough, maybe?

Share this post


Link to post
Share on other sites

Monitoring service dropped, but I think I have regular users who generate the same symptoms, this one is coming from an android phone :

Dalvik/2.1.0 (Linux; U; Android 5.1.1; A0001 Build/LMY48Y)

 

 

Screen Shot 2017-03-22 at 20.06.15.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.