Jump to content

Modules Manager


Recommended Posts

Hi Soma,

there is one mystery left with a module which insists to be outdated although it's not.

No idea what that is. The effect is on all my processwire installations. I left a note in the modules

section of the board already...

Found following updates for installed modules:
Module: FieldtypeCropImage v1.0.2
Found new version available: v1.0.3
More infos at: http://modules.processwire.com/modules/fieldtype-crop-image/


Link to comment
Share on other sites

  • 4 weeks later...

I could not able to open the module manager page.

 cannot read cache file /var/www/processwire/site/assets/cache/ModuleManager.cache

I checked the folder is 777

Even I try to install module from Modules->New, download and install page

I got

Error retrieving data from web service URL - 110: Connection timed out

solved. For some reasons, firewall was blocked all outgoing tcp ports for that machine's ip address.

Link to comment
Share on other sites

  • 1 month later...

Just pushed a little but important update to 2.1.3.

Previously module files/folder didn't get deleted before updating a module. This would possibly would leave orphaned files that may get removed in a new module version. Now it just deletes folder and writes new folder.

Fix small issue with module cache not getting updated when installing new version of a module.

  • Like 3
Link to comment
Share on other sites

  • 2 months later...

Today I stumbled over an issue regarding the iFrame-overlay-preview in Modules Manager.

The Processwire site now sends an "X-Frame-Options: SAMEORIGIN" header, which breaks the preview function:


Refused to display 'http://modules.processwire.com/modules/process-abbreviate/' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

Link to comment
Share on other sites

  • 4 weeks later...

Yes correct, it's limited to 350 currently by Ryan.

Today I stumbled over an issue regarding the iFrame-overlay-preview in Modules Manager.

The Processwire site now sends an "X-Frame-Options: SAMEORIGIN" header, which breaks the preview function:


Yep that was added by Ryan some time ago and looks like processwire.com got an upgrade with that also, but it's currently working for me. Not sure if he changed it.

Link to comment
Share on other sites

  • 1 month later...

On installations and updates appears the well known warning whether to trust the source of a zip flle. A useful reminder.

But there is only a "yes/no" modal. You do not see that link displayed anywhere (or only encoded in the browser's status bar, it that bar is set to "visible"). - I am always temped to click "yes" and simply ignore the warning. 

I was thinking whether some more evaluation before a download would be useful to add some security:

  •  maybe at least showing that link in the modal dialog.
  • maybe having an active link to the corresponding GitHub/Bitbucket page - so you can open if and, on updates, quickly look through the changes there first
  • maybe give a louder warning if the target is not a zip file coming from GitHub/Bitbucket.
Link to comment
Share on other sites

  • 2 weeks later...


Sorry for my ignorence but where do I change what to solve the following statement when I try to update modules:
Forbidden - You don't have permission to access /processwire/module/download/ on this server 



PW 2.5.3 

  • the JqueryDataTables module to be installed before you can install Modules Manager. ok
  • "allow_url_fopen" to be enabled in your php.ini.   ok
  • "openssl" PHP extension needs to be installed on your server. ok

UPDATE: It works like a charm! Sorry - The mistake was on my side

Link to comment
Share on other sites

  • 2 weeks later...


Having an issue with one of our PW sites running PW 2.5.3 & Modules Manager v215. Modules manager simply doesn't load any of the modules on processwire.com. Inspecting the page with Chrome Developer Tools shows this error in the console from jQuery Data Tables.

Uncaught TypeError: Cannot read property 'sError' of nulljquery.dataTables.min.js?v=194:132




TJqueryCore.js?v=183:2 r


Any suggestions? I've attempted to reinstall jQuery Data Tables & Modules Manager as well.

Also just updated to ModulesManager v215 same issue. Looked at the jquery.dataTables.js and this is the code where the error is being thrown

"fnServerData": function ( sUrl, aoData, fnCallback, oSettings ) {
	oSettings.jqXHR = $.ajax( {
		"url":  sUrl,
		"data": aoData,
		"success": function (json) {
			if ( json.sError ) {
				oSettings.oApi._fnLog( oSettings, 0, json.sError );
			$(oSettings.oInstance).trigger('xhr', [oSettings, json]);
			fnCallback( json );
		"dataType": "json",
		"cache": false,
		"type": oSettings.sServerMethod,
		"error": function (xhr, error, thrown) {
			if ( error == "parsererror" ) {
				oSettings.oApi._fnLog( oSettings, 0, "DataTables warning: JSON data from "+
					"server could not be parsed. This is caused by a JSON formatting error." );
	} );
Edited by zgjonbalaj
@zgjonbalaj. Welcome to the forums. Moved this here to MM forum :-)
Link to comment
Share on other sites


Hope this helps someone but it seems the culprit was the php memory limit set to 32M. I increased this to 128M and everything works fine. I added 

ini_set('memory_limit', '128M');

to the init() on ModulesManager.module but will sooner or later be updating the php.ini to increase this. I recommend that maybe this be included in ModulesManager for those servers with low memory limit.

I'm not sure really, but maybe there's no cache created on first open. Can you see a ModuleManager.cache n the site/assets/cache folder?

Yea the cache is there this is what comes up for the modules manager in the cache, also when clicking on refresh at the top right the page simply doesn't load it will post the request i see the get param but the page doesn't return anything but empty head & body.

Update: The page returns this when clicking refresh

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 262144 bytes) in /home/ascentav/public_html/site/modules/ModulesManager/ModulesManager.module on line 801

Error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 262144 bytes) (line 801 of /home/ascentav/public_html/site/modules/ModulesManager/ModulesManager.module) 
This error message was shown because site is in debug mode ($config->debug = true; in /site/config.php). Error has been logged.

Note: Debug Mode tools shows that both ModulesManager & jQueryDataTables have been loaded also when opening ModulesManager I do notice that it is pulling the number of modules because it shows this:

Modules found on modules.processwire.com (319)

{"id":1136,"class_name":"ModulesManager","name":"modules-manager","title":"Modules Manager","summary":"Module Manager enables you to browse the modules directory on modules.processwire.com, download, install or update them.","version":215,"module_version":"2.1.5","created":1343336504,"modified":1418136602,"url":"http:\/\/modules.processwire.com\/modules\/modules-manager\/","details_url":"http:\/\/modules.processwire.com\/export-json\/modules-manager","requires":["JqueryDataTables"],"requires_versions":{"JqueryDataTables":[">=",0]},"installs":[],"author":"Philipp 'Soma' Urlich","icon":"","likes":59,"release_state":{"id":1084,"name":"beta","title":"Beta","url":"http:\/\/modules.processwire.com\/release-states\/beta\/"},"pw_versions":[{"id":1012,"name":"2.2","title":"2.2","url":"http:\/\/modules.processwire.com\/versions\/2.2\/"},{"id":1216,"name":"2.3","title":"2.3","url":"http:\/\/modules.processwire.com\/versions\/2.3\/"},{"id":1377,"name":"2.4","title":"2.4","url":"http:\/\/modules.processwire.com\/versions\/2.4\/"},{"id":1466,"name":"2.5","title":"2.5","url":"http:\/\/modules.processwire.com\/versions\/2.5\/"}],"categories":[{"id":1078,"name":"admin-helper","title":"Admin Helpers","url":"http:\/\/modules.processwire.com\/categories\/admin-helper\/"},{"id":1018,"name":"process","title":"Process Modules","url":"http:\/\/modules.processwire.com\/categories\/process\/"},{"id":1080,"name":"proof-of-concept","title":"Proof of Concept","url":"http:\/\/modules.processwire.com\/categories\/proof-of-concept\/"}],"authors":[{"id":1050,"name":"soma","title":"soma","url":"http:\/\/modules.processwire.com\/authors\/soma\/"}],"project_url":"https:\/\/github.com\/somatonic\/ModulesManager","download_url":"https:\/\/github.com\/somatonic\/ModulesManager\/zipball\/master","forum_url":"http:\/\/processwire.com\/talk\/topic\/1550-modules-manager\/"}
  • Like 1
Link to comment
Share on other sites

@z Thanks for getting back and glad you found the issue. I think you'll run into many problem with 32mb real quick so I don't think setting memory limit in modules is a good way as it belong to server configuration.


Note about an update to 2.1.6

- Fixed issue with an unexpected "\n" char in a summary of a newly added module that caused and error with jQueryDataTables parsing the json.

So I'm sure many will run into this issue once they hit refresh and haven't updated to 2.1.6 yet. But see and make an update of ModulesManager you'd need to hit refresh. - So not sure how this will play out. Damn "\n"!

In case just manually update or use the core module manager.

  • Like 3
Link to comment
Share on other sites

  • 1 month later...

Hi @Soma,

On my local computer the Module MAnager works well.

But i try install on a production-server and a clean PW-install.

It gives a Internal Server Error .

I removed the the ModuleManager-dir and the site works again.

Have anyone an idea what the problem is?

This is the phpinfo from the shared hosting:




Link to comment
Share on other sites

I have some modules included as a git submodule. So I don't use the update manager but the command ``git submodule update``. Everything works well except the display of the version.

Is there a way to clear the module listing cache or to do something else to get the right version listed?

EDIT: ok, that was too easy  :-[

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...