Jump to content
ryan

Module: Video embed for YouTube/Vimeo (TextformatterVideoEmbed)

Recommended Posts

Antti, I was able to reproduce that and have fixed it. Thanks for finding it. The last pull request broke the preg_match index association and I didn't catch it. :)

Share this post


Link to post
Share on other sites

Antti, I was able to reproduce that and have fixed it. Thanks for finding it. The last pull request broke the preg_match index association and I didn't catch it. :)

Hi Ryan, when did you update the module to fix the repeating vid problem? I downloaded this module at 11:30 am EST and I'm having the same problem as Apeisa. If you updated it seconds after my DL finished I can re download. Weird coincidence on the timing.

Share this post


Link to post
Share on other sites

@digitex, update hasn't been pushed to GitHub yet -- I should know, since it was my pull request that broke this before, terribly sorry for that!

Just opened a pull request with a fix for this problem, just in case. If you need to make the fix locally you can review required changes here:

https://github.com/ryancramerdesign/TextformatterVideoEmbed/pull/2/files

Share this post


Link to post
Share on other sites

@teppo, no worries. It's funny how Apeisa and I both ran into the same problem on the same day.

thanks for the link, it's all fixed up at my end.

Share this post


Link to post
Share on other sites

I know that I pushed this update yesterday right when I wrote my message. But look what was waiting for me in my shell window when I just now checked:

[rytower]$ git push origin master

Username:

I typed in the push and just assumed it went through yesterday, as it always does. Then moved onto the next thing. For some reason GitHub is prompting me for a username (didn't expect that). Anyway, I just typed it in now so hopefully it should be online finally. :)

  • Like 1

Share this post


Link to post
Share on other sites

I have a video embedded a youtube with this module. At the end of the video youtube displays related videos. Can this be changed? The customer just wants to stop the video, without displaying any related videos.

Normally you can add "rel=0" to the embed url, but I don't know how to change this in the module.

Share this post


Link to post
Share on other sites

I have a video embedded a youtube with this module. At the end of the video youtube displays related videos. Can this be changed? The customer just wants to stop the video, without displaying any related videos.

Normally you can add "rel=0" to the embed url, but I don't know how to change this in the module.

Good point. I second this. I tried adding ?rel=0 to the embed url and it breaks it and just displays the link as text. Currently at the end of the vids it shows some pretty unrelated and annoying, so called "related" items.

Share this post


Link to post
Share on other sites

I've been experimenting with this by including the "rel=0" in the oEmbed call, but apparently YouTube ignores it. It looks to me like they don't support specification of this option with oEmbed, though if anyone can figure out how to do it I'll be happy to integrate it.

Share this post


Link to post
Share on other sites

What does it add the rel=0 to? The URL in the iframe tag I'm assuming, but thought I'd tried this... Anyway, if this works, we might want to support other options too. What other worthwhile GET variables can be specified to youtube?

Share this post


Link to post
Share on other sites

This is the embed code from youtube:

<iframe width="560" height="315" src="https://www.youtube.com/embed/YsCpDaSooWA?rel=0" frameborder="0" allowfullscreen></iframe>

So it does go into url in iFrame tag.

I think only other relevant option might be privacy mode. This is the embed code for privacy mode and no for related videos combined:

<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/YsCpDaSooWA?rel=0" frameborder="0" allowfullscreen></iframe>
  • Like 1

Share this post


Link to post
Share on other sites

I've pushed an update to this module so that it now recognizes any youtube query string variable. So you can use rel=0 or whatever you want from the link that Diogo posted. To use it, just append them to your youtube in your body copy, i.e.

https://www.youtube.com/watch?v=Wl4XiYadV_k&rel=0

Note the extra "rel=0" at the end. Of course, you can also specify multiple things too:

https://www.youtube.com/watch?v=Wl4XiYadV_k&rel=0&controls=0

Share this post


Link to post
Share on other sites

Diogo, that's a good one to know about, thanks. That one should work too as it's not detecting specific options but rather pulling the entire query string out of the URL and then packaging it back up into the iframe embed code that youtube provides. Once I saw all the options on the page you linked, I figured that was the only way to go.

Share this post


Link to post
Share on other sites

Ok. What am I doing wrong? I downloaded the new update, replaced it on the server and now all I get is the link as text on the page. I uninstalled everything so that I could reinstall from scratch and it's still not working.

I went back to the previous version I got originally (v 1.0.1) and it started working again. So I tried to upgrade again with the updated version and it broke. I don't know what's causing it.

Share this post


Link to post
Share on other sites

Digitex, I think I found the issue. Please try the latest update and it should work now.

Share this post


Link to post
Share on other sites

Digitex, I think I found the issue. Please try the latest update and it should work now.

Sorry Ryan. I hate to be a pain but the new update fixes the video embed...until I add the ?rel=0 to the link. That breaks it again. If it's now working for interrobang then maybe the problem is something else particular to my server configuration.

Share this post


Link to post
Share on other sites

For YouTube, you would actually be adding "&rel=0", not "?rel=0", i.e.

https://www.youtube.com/watch?v=Wl4XiYadV_k&rel=0

This works here. Is it possible that you used '?' rather than '&' ? If not, please post the exact URL that doesn't work.

Share this post


Link to post
Share on other sites

For YouTube, you would actually be adding "&rel=0", not "?rel=0", i.e.

https://www.youtube.com/watch?v=Wl4XiYadV_k&rel=0

This works here. Is it possible that you used '?' rather than '&' ? If not, please post the exact URL that doesn't work.

Turns out that is the case. I was going by the youtube embed code from the site which would use a URL that looks like this:

https://www.youtube.com/embed/Wl4XiYadV_k?rel=0

But using &rel=0 is correct and works. Thanks for the correction.

  • Like 1

Share this post


Link to post
Share on other sites

The TextformatterVideoEmbed module has been updated to support responsive embed codes. To enable, grab the latest version (v1.0.4) go to the module configuration screen and check the responsive box. Now when your videos are embedded, they will be output in a width-flexible format that adjusts to the container.

  • Like 3

Share this post


Link to post
Share on other sites

I had a bizarre report today from someone using this module. She copied and pasted the embed code into the body field, like I showed her how to do, and it rendered as a link. In other words the anchor tag was added automatically turning

https://www.youtube.com/watch?v=j-AMV7yAiAo&rel=0

into

<a href="https://www.youtube.com/watch?v=j-AMV7yAiAo&rel=0">https://www.youtube.com/watch?v=j-AMV7yAiAo&rel=0</a>

When her husband tried using Safari on a mac, no problem, but when she does it on, I think, Vista or XP using IE7 (I know I know some people just don't like to upgrade) she gets the above.

Anyone else ever see this happen?

Share this post


Link to post
Share on other sites

Are there any other textformatters enabled on this 'body' field?

Where was it copied/pasted from? If you copy and paste something that is an HTML link from one window and paste it into a TinyMCE field, then the link will be retained. It's possible that IE7 inserts the <a> tag around an URL copied from its address bar? If that's the case, she could either click the 'remove link' icon after pasting it on, or paste the link into Notepad, and then copy it out of there before pasting into TinyMCE (which should render it plain text).

Share this post


Link to post
Share on other sites

She emailed me her process which is the same approach I took and the same as her husband:

Opened up the desired video on Youtube.

Clicked "share".

selected and copied the URL that showed up directly below.

Logged in to my editing page.

Selected "video"

Selected "edit"

Scrolled down past "title", "headline", "summary", to "body"

Put my cursor at the end of the previous line of text

hit return

hit Ctrl v to paste

She then reported her husband tried again using the same method and it worked fine just as it did for him the first time he tried. She knows that it's something on her computer/browser. Clicking "remove link" is something i didn't think to tell her but that's good advice.

Just curious if anyone else has seen this and can confirm it's the browser doing it. Frankly I don't think it's a good idea to backwards engineer a module to be compatible with a browser as old and s****y as IE7, far better to encourage people to upgrade. If that's the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mike Rockett
      Jumplinks for ProcessWire
      Release: 1.5.56
      Composer: rockett/jumplinks
      Jumplinks is an enhanced version of the original ProcessRedirects by Antti Peisa.
      The Process module manages your permanent and temporary redirects (we'll call these "jumplinks" from now on, unless in reference to redirects from another module), useful for when you're migrating over to ProcessWire from another system/platform. Each jumplink supports wildcards, shortening the time needed to create them.
      Unlike similar modules for other platforms, wildcards in Jumplinks are much easier to work with, as Regular Expressions are not fully exposed. Instead, parameters wrapped in curly braces are used - these are described in the documentation.
      Under Development: 2.0, to be powered by FastRoute
      As of version 1.5.0, Jumplinks requires at least ProcessWire 2.6.1 to run.
      View on GitLab
      Download via the Modules Directory
      Read the docs
      Features
      The most prominent features include:
      Basic jumplinks (from one fixed route to another) Parameter-based wildcards with "Smart" equivalents Mapping Collections (for converting ID-based routes to their named-equivalents without the need to create multiple jumplinks) Destination Selectors (for finding and redirecting to pages containing legacy location information) Timed Activation (activate and/or deactivate jumplinks at specific times) 404-Monitor (for creating jumplinks based on 404 hits) Additionally, the following features may come in handy:
      Stale jumplink management Legacy domain support for slow migrations An importer (from CSV or ProcessRedirects) Feedback & Feature Requests
      I’d love to know what you think of this module. Please provide some feedback on the module as a whole, or even regarding smaller things that make it whole. Also, please feel free to submit feature requests and their use-cases.
      Note: Features requested so far have been added to the to-do list, and will be added to 2.0, and not the current dev/master branches.
      Open Source

      Jumplinks is an open-source project, and is free to use. In fact, Jumplinks will always be open-source, and will always remain free to use. Forever. If you would like to support the development of Jumplinks, please consider making a small donation via PayPal.
      Enjoy! :)
    • By BitPoet
      As threatened in Ryan's announcement for 3.0.139, I built a little module for sliding toggles as a replacement for checkboxes. Styling of the input is CSS3 only (with all the usual caveats about older browsers), no JS necessary, and may still be a bit "rough around the edges", so to speak, since I didn't have much time for testing on different devices or brushing things up enough so I'd feel comfortable pushing it to the module directory. But here's the link to the GitHub repo for now:
      InputfieldSlideToggle
      Fieldtype and Inputfield that implements smartphone-style toggles as replacement for checkbox inputs. The visualization is CSS-only, no additional JS necessary.
      Status
      Still very alpha, use with caution!
      Features / Field Settings
      Size
      You can render the toggles in four different sizes: small, medium, large and extra large.
      Off Color
      Currently, "unchecked" toggles can be displayed either in grey (default) or red.
      On Color
      "Checked" toggles can be rendered in one of these colors: blue (default), black, green, grey, orange or red.
      Screenshots

      Some examples with checkbox label


      View all Size and Color Combinations
      Small toggles Medium toggles Big toggles Extra big toggles  









    • By Orkun
      Hi Guys
      I needed to add extended functionalities for the InputfieldDatetime Module (module is from processwire version 2.7.3) because of a Request of Customer.
      So I duplicated the module and placed it under /site/modules/.
      I have added 3 new Settings to the InputfieldDatetime Module.
      1. Day Restriction - Restrict different days based on weekdays selection (e.g. saturday, sunday) - WORKING

       
      2. Time Slots - Define Time slots based on custom Integer Value (max is 60 for 1 hour) - WORKING

       
      3. Time Range Rules per Weekday - Define a minTime and MaxTime per Weekday (e.g. Opening Hours of a Restaurant) - NOT WORKING PROPERLY

       
      The Problem
      Time Slots and Day Restriction working fine so far. But the Time Range Rules per Weekday doesn't work right.
      What should happen is, that when you click on a date, it should update the minTime and maxTime of the Time Select.
      But the change on the select only happens if you select a date 2 times or when you select a date 1 time and then close the datepicker and reopen it again.
      The time select doesn't get change when you select a date 1 time and don't close the picker.
      Here is the whole extended InputfieldDatetime Module.
      The Files that I have changed:
      InputfieldDatetime.module InputfieldDatetime.js jquery-ui-timepicker-addon.js (https://trentrichardson.com/examples/timepicker/) - updated it to the newest version, because minTime and maxTime Option was only available in the new version  
      Thats the Part of the JS that is not working correctly:
      if(datetimerules && datetimerules.length){ options.onSelect = function(date, inst) { var day = $(this).datetimepicker("getDate").getDay(); day = day.toString(); var mintime = $(this).attr('data-weekday'+day+'-mintime'); var maxtime = $(this).attr('data-weekday'+day+'-maxtime'); console.log("weekday: "+day); console.log("minTime: "+mintime); console.log("maxTime: "+maxtime); var optionsAll = $(this).datetimepicker( "option", "all" ); optionsAll.minTime = mintime; optionsAll.maxTime = maxtime; $(this).datetimepicker('destroy'); $(this).datetimepicker(optionsAll); $(this).datetimepicker('refresh'); //$.datepicker._selectDate($(this).attr("id"),date); //$.datepicker._base_getDateDatepicker(); // var inst = $.datepicker._getInst($(this)); // $.datepicker._updateDatepicker(inst); /*$(this).datetimepicker('destroy'); InputfieldDatetimeDatepicker($(this), mintime, maxtime); $(this).datetimepicker('refresh'); */ // $(this).datetimepicker('option', {minTime: mintime, maxTime: maxtime}); } } Can you have a look and find out what the Problem is?
      InputfieldDatetime.zip
       
      Kind Regards
      Orkun
    • By teppo
      This module tracks changes, additions, removals etc. of public (as in "not under admin") pages of your site. Like it's name says, it doesn't attempt to be a version control system or anything like that - just a log of what's happened.
      At the moment it's still a work in progress and will most likely be a victim of many ruthless this-won't-work-let's-try-that-instead cycles, but I believe I've nailed basic functionality well enough to post it here.. so, once again, I'll be happy to hear any comments you folks can provide
      https://modules.processwire.com/modules/process-changelog/
      https://github.com/teppokoivula/ProcessChangelog
      How does it work?
      Exactly like it's (sort of) predecessor, Process Changelog actually consists of two modules: Process Changelog and Process Changelog Hooks. Hooks module exists only to serve main module by hooking into various functions within Pages class, collecting data of performed operations, refining it and keeping up a log of events in it's own custom database table (process_changelog.) Visible part is managed by Process Changelog, which provides users a (relatively) pretty view of the contents of said log table.
      How do you use it?
      When installed this module adds new page called Changelog under Admin > Setup which provides you with a table view of collected data and basic filtering tools See attached screenshots to get a general idea about what that page should look like after a while.
      For detailed installation instructions etc. see README.md.
       


    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2019-08-08
      2019-06-15
      2019-06-02
      2019-05-25
      If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      (please have a look at the screenshots to get an idea what I'm talking about)
       




×
×
  • Create New...