Jump to content

Module: Video embed for YouTube/Vimeo (TextformatterVideoEmbed)


ryan

Recommended Posts

I’m developing on Localhost (MAMP), never had this problem before. Installed a fresh Processwire, installed TextformatterVideoEmbed, added this to a textarea (CKE), enter YouTube URL, nothing happens.... no error messages, just no formatting. So I wondered if this has to do with latest version 3.0.165?

Link to comment
Share on other sites

Just gave it a try and this is the response I get from YouTube when not using HTTPS:

{ "error": { "code": 403, "message": "SSL is required to perform this operation.", "status": "PERMISSION_DENIED" } }

Happens on 3.0.148 as well as 3.0.165.

The way TextformatterVideoEmbed is set is that if it doesn't get a proper response (one with "html" key) it won't do anything, so this is technically expected behaviour. That being said, I don't see any reason why this module should use the HTTP protocol even if the site itself does, and since YouTube no longer seems to allow that it's definitely not the right thing to do.

I've opened an issue for this for @ryanhttps://github.com/ryancramerdesign/TextformatterVideoEmbed/issues/16 🙂

  • Like 1
Link to comment
Share on other sites

Hi,

@EricS Having the same kind of issue with a current website i'm working on, i've used this one
https://github.com/jacmaes/TextformatterLiteYouTubeEmbed

it works fine if you just need youtube videos to be displayed, incredibly fast and really easy to use
less options than Ryan's one but videos are natively responsive and xith a few css tweaks (Paul Irish lite youtube embed css) it does all i needed

in case it helps
have a nice day

Link to comment
Share on other sites

1 hour ago, teppo said:

Just gave it a try and this is the response I get from YouTube when not using HTTPS:


{ "error": { "code": 403, "message": "SSL is required to perform this operation.", "status": "PERMISSION_DENIED" } }

Happens on 3.0.148 as well as 3.0.165.

The way TextformatterVideoEmbed is set is that if it doesn't get a proper response (one with "html" key) it won't do anything, so this is technically expected behaviour. That being said, I don't see any reason why this module should use the HTTP protocol even if the site itself does, and since YouTube no longer seems to allow that it's definitely not the right thing to do.

I've opened an issue for this for @ryanhttps://github.com/ryancramerdesign/TextformatterVideoEmbed/issues/16 🙂

Hi Teppo, thanks for your response! The strange thing is that on version 3.0.148 on my localhost everything works fine! This is the first time I use the latest version. But maybe when it's live (https) it will work... Keep you posted.

28 minutes ago, virtualgadjo said:

Hi,

@EricS Having the same kind of issue with a current website i'm working on, i've used this one
https://github.com/jacmaes/TextformatterLiteYouTubeEmbed

it works fine if you just need youtube videos to be displayed, incredibly fast and really easy to use
less options than Ryan's one but videos are natively responsive and xith a few css tweaks (Paul Irish lite youtube embed css) it does all i needed

in case it helps
have a nice day

Hi Virtualgadjo, thanks for your suggestion! I'll try this one 😉

Have a nice day!

Link to comment
Share on other sites

36 minutes ago, EricS said:

The strange thing is that on version 3.0.148 on my localhost everything works fine! This is the first time I use the latest version. But maybe when it's live (https) it will work... Keep you posted.

Version shouldn't matter, since this change has occurred on the YouTube side. If neither of these sites is using HTTPS, then I'd suspect that it's a caching thing: Textformatter Video Embed stores embed codes in the database, so if that other site has fetched the code via HTTP while it was still possible, it'll continue to work until you clear said cache from the database.

Google has in the past also deprecated features in weird ways, so that they've kept working for existing sites/domains but not for new ones, though I doubt that'd be the case here 🙂

  • Like 3
Link to comment
Share on other sites

On 1/16/2021 at 4:07 PM, teppo said:

Version shouldn't matter, since this change has occurred on the YouTube side. If neither of these sites is using HTTPS, then I'd suspect that it's a caching thing: Textformatter Video Embed stores embed codes in the database, so if that other site has fetched the code via HTTP while it was still possible, it'll continue to work until you clear said cache from the database.

Google has in the past also deprecated features in weird ways, so that they've kept working for existing sites/domains but not for new ones, though I doubt that'd be the case here 🙂

Hi Teppo, you were completely right (of course ;-)). The module is working fine on HTTPS! Thanks.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

In the latest version 2.0.1 from April 9, the padding-bottom {pct} variable sometimes results in an invalid CSS value, like 56,25% (with comma)

This value should be locale independent, so please use an intval or use forced dot notation in the calculation. Thanks

image.thumb.png.3a2cff396c7c43448b0796feebaf79b1.png

image.png.57a7572ba0a662c04440a831bb24b010.png

Link to comment
Share on other sites

  • 5 months later...

Anyone seeing issues with the generated thumbnail for vimeo-based embedded videos?   Currently just getting a stripy image back from vimeo no matter what video is embedded. Pressing play works - the video is streamed and played without issue, it's just the thumbnail from vimeo that's the problem. Looks like this...

Selection_248.png

Link to comment
Share on other sites

8 hours ago, netcarver said:

Currently just getting a stripy image back from vimeo not matter what video is embedded.

I think this relates to a problem at the video/Vimeo end rather than a problem with the textformatter module. The post below suggests that the stripes thumbnail is what appears when Vimeo fails to successfully generate a thumbnail for a video:

http://support.syngency.com/en/articles/3048197-set-a-new-thumbnail-for-your-video

  • Like 3
Link to comment
Share on other sites

I contacted vimeo support and this is what they told me:

Quote
My name is xxx and I'm stepping in for the Vimeo team today.
 
I'm very sorry for any inconvenience this issue may have caused.
 
We recently made an update to our security protocols that included all thumbnails in videos. This was intended to be a non-breaking change across the platform but in cases like yours where links were hardcoded, we were not able to seamlessly update to the new image link structure. 
 
You will need to update your current workflow/codebase to reflect these new changes. Please review our documentation on initiating an API call to GET the thumbnail of a specific video from the Vimeo servers. Additionally our API allows you to GET the thumbnails for all your videos. (ex. https://api.vimeo.com/me/videos?fields=uri,name,pictures). You can use additional parameters listed on our developer page to specify the results you need
 
While we do not expect the updated thumbnail links to change in the near term, our engineers recommend implementing this regularly instead of caching the video thumbnail URLs and also recommend batching these calls if possible, which will be more efficient. 
 
I understand this change alters what’s required for your application and your workflow as a whole. Our team is committed to finding solutions that allow you to maximize your usage of Vimeo to deliver the highest quality experience for your customers. To that, please do let me know if you have any other questions or if there’s anything else I can do to help.

Sincerely,
xxx

So apparently the TextformatterVideoEmbedLazy module needs some adapting.

I have attached that file, does anybody know what to change in there?

Thanks

TextformatterVideoEmbedLazy.module

Link to comment
Share on other sites

  • 8 months later...

although the module works fine, i found an error today when you make a backup of the database. the backup cannot be restored and an error message appears. If I uninstall the module, the backup works fine again. It took me several hours to find that this module is causing the error. I did the backup using the ProcessDatabaseBackups module. Maybe someone else can confirm this?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...