Jump to content
ryan

Module: Video embed for YouTube/Vimeo (TextformatterVideoEmbed)

Recommended Posts

I would install the 1.0.9 module in PW 2.5 and then upgrade PW to latest 3.x

after that upgrade the module. 

Just my 2 cents. 

Share this post


Link to post
Share on other sites

I already have 109 and it's working. So, jumping straight ahead to 3.x? Will try and report back, probably on Sunday.  Thx dragan & horst.

I upgraded PW from 2.5.4 to 3.0.104 and then php from 5.5.12 to 7.2.2 in one go. Everything went fine. I needed DynamicRoles module that is compatible with PW3. 

Edited by matjazp
Update
  • Like 2

Share this post


Link to post
Share on other sites
On 5/15/2018 at 10:40 PM, tires said:

Is there a way to use the youtube nocookie url like https://www.youtube-nocookie.com/embed/XYZ123

The module does not support this, but you could edit the module file, adding the following line here:

$embedCode = str_replace('youtube.com', 'youtube-nocookie.com', $embedCode);

If you later update the module the change would be overwritten and you would have to redo it.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Robin S said:

The module does not support this, but you could edit the module file, adding the following line here:


$embedCode = str_replace('youtube.com', 'youtube-nocookie.com', $embedCode);

If you later update the module the change would be overwritten and you would have to redo it.

Thanks a lot Robin, you saved my day!!!!

Share this post


Link to post
Share on other sites

Sorry, but i got another issue:

What if i want to add the "rel=0" feature?

Where do i have to put the:

?rel=0

 

Share this post


Link to post
Share on other sites
9 hours ago, Robin S said:

The module does not support this, but you could edit the module file, adding the following line here:


$embedCode = str_replace('youtube.com', 'youtube-nocookie.com', $embedCode);

If you later update the module the change would be overwritten and you would have to redo it.

I did the same for the TextformatterVideoEmbed module. Also added an option to it, if you want to use the nocookie domain or not.

Share this post


Link to post
Share on other sites
2 hours ago, tires said:

Sorry, but i got another issue:

What if i want to add the "rel=0" feature?

Where do i have to put the:


?rel=0

 

Install this module.

Share this post


Link to post
Share on other sites
1 hour ago, PWaddict said:

Install this module.

Thanks for this hint!
Great Module!

Would be great to have this nocookie url setting in there!

Share this post


Link to post
Share on other sites
2 hours ago, jmartsch said:

I did the same for the TextformatterVideoEmbed module. Also added an option to it, if you want to use the nocookie domain or not.

Couldn't you add this option into the module?
Would be great!

Share this post


Link to post
Share on other sites
22 hours ago, tires said:

Couldn't you add this option into the module?
Would be great!

I am planning to make a PR on github the next few days, in the meantime you could download my version of the module, as soon as I release it on github. Will notify you here.

  • Like 1

Share this post


Link to post
Share on other sites

Hey,

 

I would like to use this module as well but when I use it the whole website slows extremely down. It doesn't work. On my colleguage's system it works as charme. He uses v  3.0.62 and I use v  3.0.98. I really need this module to work. Any ideas? We compared the settings on both systems / backends and they're the same. Any ideas? I would appreciate it.

Share this post


Link to post
Share on other sites
39 minutes ago, Marcel said:

Hey,

 

I would like to use this module as well but when I use it the whole website slows extremely down. It doesn't work. On my colleguage's system it works as charme. He uses v  3.0.62 and I use v  3.0.98. I really need this module to work. Any ideas? We compared the settings on both systems / backends and they're the same. Any ideas? I would appreciate it.

Are you both on the same web host?   What other third-parry Process modules are you using? Please tell us more about your web environment.  That will provide critical information for someone to help you.

Share this post


Link to post
Share on other sites
15 minutes ago, cstevensjr said:

Are you both on the same web host?   What other third-parry Process modules are you using? Please tell us more about your web environment.  That will provide critical information for someone to help you.

No, we are on seperates ones. On modules there are Process, Protected and Textformatter. As soon as I go to Fields>myfield>Details>Text Formatters>Video embed for YT/Vimeo even the backend is immediately super slow or doesn't even react. 

Share this post


Link to post
Share on other sites
11 hours ago, simonsays said:

@ryan

Any chance this module could be used for multilanguage textarea?

It only appears as a text formatter for single language textarea.

I just converted a Textarea field to Textarea (Multi-language) and the module is working properly for every language.

Share this post


Link to post
Share on other sites
19 hours ago, Marcel said:

As soon as I go to Fields>myfield>Details>Text Formatters>Video embed for YT/Vimeo even the backend is immediately super slow or doesn't even react. 

That is strange, because Textformatters are only active on the frontend and not in the backend (far as I know). I never experienced a real slowdown with this module active and in use. Maybe it has something to do with your database access, because the module caches the embed code in the database.

The module also works with multilanguage fields, as I am using it for that purpose on https://p-jentschura.com

  • Like 1

Share this post


Link to post
Share on other sites

Hey !

I added the module and am trying to implement it into my body field but it doesn't work for youtube videos. I tried with a vimeo link and it's perfect but not with youtube.

I unlinked, I tried the no-cookie stuff into the module code and now I'm getting crazy ! Any hint ?

cheers !

Share this post


Link to post
Share on other sites

I'm trying to use Text formatter in conjunction with the multiplier pro module using a text field but it doesn't work. Does anyone have any thoughts of why that is or might be at all?

Share this post


Link to post
Share on other sites

Ok so it's because there is a preg_match expecting <p> tags as it is intended solely for rich text fields.

Share this post


Link to post
Share on other sites

In this day and age I feel like the responsive option should be enabled by default! I nearly didn't notice it.

How tricky would it be to pass on parameters like ?loop=1 in the URL?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gebeer
      I am happy to present my new fieldtype FieldtypeImageFromPage. It is made up of 2 modules:
      Fieldtype Image Reference From Another Page is a Fieldtype that stores a reference to a single image from another page. The image can be selected with the associated Inputfield.
      Inputfield Select Image From Page is an Inputfield to select a single image from images on a predefined page and it's children.
      And there also is a helper module that takes care of cleanup tasks.
      This module evolved out of a discussion about my other Module FieldtypeImagePicker.  It caters for use cases where a set of images is being reused multiple times across a site. With this fieldtype these images can be administered through a chosen page. All images uploaded to that page will be available in the inputfield.
      When to use ?
      Let editors choose an image from a set of images that is being used site-wide. Ideal for images that are being re-used across the site.
      Suited for images that are used on multiple pages throughout the site (e.g. icons).
      Other than the native ProcessWire images field, the images here are not stored per page. Only references to images on another page are stored. This has several advantages:
      one central place to organize images when images change, you only have to update them in one place. All references will be updated, too. (Provided the name of the image that has changed stays the same) Features
      Images can be manipulated like native ProcessWire images (resizing, cropping etc.) Image names are fully searchable through the API Accidental image deletion is prevented. When you want to delete an image from one of the pages that hold your site-wide images, the module searches all pages that use that image. If any page contains a reference to the image you are trying to delete, deletion will be prevented. You will get an error message to help you edit those pages and remove references there before you can finally delete the image. How to install and setup
      Download and install this module like any other modules in ProcessWire Create a page in the page tree that will hold your images. This page's template must have an images field Upload some images to the page you created in step 2 Create a new field. As type choose 'Image Reference From Another Page'. Save the field. In 'Details' Tab of the field choose the page you created in step 2 Click Save button Choose the images field name for the field that holds your images (on page template from step 2) Click Save button again Choose whether you want to include child pages of page from step 2 to supply images Add the field to any template You are now ready to use the field View of the inputfield on the page edit screen:

      View of the field settings

      The module can be installed from this github repo. Some more info in the README there, too.
      In my tests it was fairly stable. After receiving your valued feedback, I will eventually add it to the modules directory.
      My ideas for further improvement:
      - add ajax loading of thumbnails
      Happy to hear your feedback!
       
    • By gebeer
      Although the PW backend is really intuitive, ever so often my clients need some assistance. Be it they are not so tech savvy or they are not working in the backend often.
      For those cases it is nice to make some help videos available to editors. This is what this module does.
      ProcessHelpVideos Module
      A Process module to display help videos for the ProcessWire CMS. It can be used to make help videos (screencasts) available to content editors.
      This module adds a 'Help Videos" section to the ProcessWire backend. The help videos are accessible through an automatically created page in the Admin page tree. You can add your help videos as pages in the page tree. The module adds a hidden page to the page tree that acts as parent page for the help video pages. All necessary fields and templates will be installed automatically. If there are already a CKEditor field and/or a file field for mp4 files installed in the system, the module will use those. Otherwise it will create the necessary fields. Also the necessary templates for the parent help videos page and it's children are created on module install. The module installs a permission process-helpvideos. Every user role that should have access to the help video section, needs this permission. I use the help video approach on quite a few production sites. It is stable so far and well received by site owners/editors. Up until now I installed required fields, templates and pages manually and then added the module. Now I added all this logic to the install method of the module and it should be ready to share.
      The module and further description on how to use it is available on github: https://github.com/gebeer/ProcessHelpVideos
      If you like to give it a try, I am happy to receive your comments/suggestions here.
    • By Robin S
      A module created in response to the topic here:
      Page List Select Multiple Quickly
      Modifies PageListSelectMultiple to allow you to select multiple pages without the tree closing every time you select a page.
      The screencast says it all:

       
      https://github.com/Toutouwai/PageListSelectMultipleQuickly
      https://modules.processwire.com/modules/page-list-select-multiple-quickly/
    • By gebeer
      Hello all,
      sharing my new module FieldtypeImagePicker. It provides a configurable input field for choosing any type of image from a predefined folder.
      The need for it came up because a client had a custom SVG icon set and I wanted the editors to be able to choose an icon in the page editor.
      It can also be used to offer a choice of images that are used site-wide without having to upload them to individual pages.
      There are no image manipulation methods like with the native PW image field.
      Module and full description can be found on github https://github.com/gebeer/FieldtypeImagePicker
      Kudos to @Martijn Geerts. I used his module FieldTypeSelectFile as a base to build upon.
      Here's how the input field looks like in the page editor:

      Hope it can be of use to someone.
      If you like to give it a try, I'm happy to hear your comments or suggestions for improvement. Eventually this will go in the module directory soon, too.
    • By bernhard
      @Sergio asked about the pdf creation process in the showcase thread about my 360° feedback/survey tool and so I went ahead and set my little pdf helper module to public.
      Description from PW Weekly:
       
      Modules Directory: https://modules.processwire.com/modules/rock-pdf/
      Download & Docs: https://github.com/BernhardBaumrock/RockPDF
       
      You can combine it easily with RockReplacer: 
      See also a little showcase of the RockPdf module in this thread:
       
×
×
  • Create New...