flydev

Duplicator: Backup and move sites

Recommended Posts

11 minutes ago, flydev said:

Answering from my mobile.

Good catch ! I will update the module with  your patch, we need now to alert the user that some files are not resdable and thus excluded from the zip. Thanks again @theo!

Yes, it took a while. I had the idea before, but was using "file_exists" which is not enough. The file has to be readable.

It's all fine now. The files were some hidden ".directory" files, which for a reason were not readable for the webserver.

These were blocking the entire zip building process.

Thank you.

  • Like 1

Share this post


Link to post
Share on other sites

There is another little problem. I guess it has to do with mod_userdir.

If you go to the package manager page and delete a package (trashcan), the item will be deleted but you will get redirected to an invalid URL.

Sort of:

/~theo/mysite/~theomysiteprocesswire/setup/duplicator/?action=none

Thank you.

  • Like 1

Share this post


Link to post
Share on other sites

Could you check (inspect) with your browser the data attribute of the "Delete All" button please ?

The result should be something like this :

path.thumb.png.2c267b78d5046735ef19d64a5876892e.png

Share this post


Link to post
Share on other sites
9 hours ago, flydev said:

I just installed a fresh XAMP on a Windows machine for a test and everything worked there. (XAMP and the bitnami PW module)

 

Are you running the last version of Duplicator (1.1.5) ?

When you say briefly, did you mean "instantly" ? if yes,  it can be the problem that @theo encountered which is fixed in the 1.1.5.

Please let me know, thanks you.

I think it is the same problem (I read the rest of the thread). Updating made progress but then I was getting the same error as @theo. I'm a beginner with processwire so I will let you two hash things out and try to update again in a few days. 

  • Like 3

Share this post


Link to post
Share on other sites

@flydev

"Delete All" seems OK, but I was talking about the trashcans.

<button id="deletePackages" class="ui-button ui-widget ui-corner-all ui-state-default" name="deletePackages" value="Delete All" type="button" data-action="http://localhost/~theo/mysite/processwire/setup/duplicator/?action=deleteAll"><span class="ui-button-text"><i class="fa fa-trash"></i> Delete All</span></button>

Trashcan is wrong:

<a href="?action=delete&file=2017-12-07_15-22-42-localhost.package.zip" class="trashTrigger" data-action="http://localhost/~theo/mysite/~theomysiteprocesswire/setup/duplicator/?action=none"><i class="fa fa-trash"></i></a>

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I read you too fast!  Ok yes I forgot to update this link! :-[

Will fix it in 1.1.6 - Thanks theo !

 

@msavard and did you tried the 1.1.5 if it solve your issue ?

Also a small tip for you in case you're not aware. You can use this module - ProcessWireUpgrade - and update the module you want in one click.

Edited by flydev
tip
  • Like 3

Share this post


Link to post
Share on other sites

Module updated to version 1.1.6, I fixed what we discussed here and included various small fix in ProcessDuplicator and GoogleDrive.

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
16 minutes ago, flydev said:

Module updated to version 1.1.6

Cool :) Do you have a rough timing estimate for DropBox API v2 support?

  • Like 1

Share this post


Link to post
Share on other sites

I will try to find the time this week @szabesz

Also, if you got 5 minutes and you still have the 1&1 host account, could you test duplicator on it ?  I just built a package successfully on 1&1 :)

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
8 minutes ago, flydev said:

I just built a package successfully on 1&1

Also cool :)

Luckily I moved the site to a speedy VPS and the 1&1 account is cancelled. Since I prefer DropBox it would be great to be able to use the module for remote backups too.

I have my own shared hosting account but that is a lot better one than 1&1's shoddy service. Anyway, I will test the current version with my account this weekend.

Edited by szabesz
missing words
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, flydev said:

Module updated to version 1.1.6, I fixed what we discussed here and included various small fix in ProcessDuplicator and GoogleDrive.

Great! Thank you!

  • Like 1

Share this post


Link to post
Share on other sites

@flydev I've uploaded the "Duplicator-SDKs" folder via FTP into the "Duplicator" folder in the modules directory, but the checkbox for Google Drive (I'm only interested in this SDK, not Amazon's) stays greyed out. Is there something else I should do?

Share this post


Link to post
Share on other sites
1 minute ago, jacmaes said:

I've uploaded the "Duplicator-SDKs" folder via FTP into the "Duplicator" folder

As the readme say, you have to only upload/merge the SDKs folder which reside inside the Duplicator-SDKs folder.

 

After downloading and opening the Duplicator-SDKs ZIP archive, you have this tree :

paths.png.9f9a22641ea03deb30ae958f307e527a.png

  • Like 2

Share this post


Link to post
Share on other sites

Sorry, I should have checked the docs first. I'm getting the following error with Google Drive:

Error: Call to undefined function GuzzleHttp\Handler\curl_reset() (line 78 of /home/mydomain/public_html/site/site/modules/Duplicator/SDKs/google-api-php-client-2.2.0/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php)

This site is hosted on a cheap, shared Godaddy account by the way.

Share this post


Link to post
Share on other sites

What is the version of your ProcessWire installation ?  I tested it on 2.8 and 3.x and everything is running fine.

Share this post


Link to post
Share on other sites

The latest dev, 3.085. Maybe curl support is restricted on Goddady, which wouldn't surprise me considering my (awful) experience with them.  I'm trying on another server (VPS). So far I'm not getting this error message.

Share this post


Link to post
Share on other sites

Thanks, yeah it can be the issue. I am googling  just to be sure. Thanks again for your input on this.

 

@jacmaes could you check which version of PHP is installed on the GoDaddy host ? Its almost sure that is a PHP config server error.

Share this post


Link to post
Share on other sites

Good ! 

and for the GoDaddy host then, you have to upgrade PHP through CPanel to at least PHP 5.6 and "maybe" it will work :)

I say maybe because as crappy shared host, you will may encounter timeout issue there. If you upgrade your host and test Duplicator on it, let me know if you managed to build a package successfully. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By holmescreek
      Question 1
      I recently installed PW 3.0.62 for a new site and also have sites running older version of PW 3.x.
      Can I export the database on an older version of PW 3.x and import it to PW 3.0.62 without any issues?
       
      Question 2
      (This is kind of alternative to the above for long term use - and maybe a better solution...)
      On  the sites I've previously built I have templates (home, basic-page, contact) and fields that I commonly use, such as business_name, phone_1.  The last site I built is running PW 3.0.42.  I was considering cloning this into a local site and running the upgrade module to bring it up to PW 3.0.62. From there on out when I start I new project I could just run the PW upgrade module, copy the folder to the location for the new project and duplicate the database using the new projects name.

      So basically, I'll always keep a "blank slate" site that I can just run the PW upgrade on, then duplicate into a new project. This would cut down on the work and time spent having to re-create these common fields, that I use. From there, I would just add fields, templates, etc, specific for the new website project.

      Is this a sound approach to speed up development?

       
    • By holmescreek
      I just posted a question about moving PW from a resting domain to a production domain, after consideration I figure I would create a new post for a second question I have.
      I noticed the coming feature of client size image resizing. This will be really helpful, as I have some clients on a Satellite connection. I'm telling you, them trying to upload 15MB images, or them getting them straight on batch resizers (or Photoshop) to resize before upload is a real chore. Needless to say, Ryan has been doing an excellent job addressing this.
      My question, is that I have several clients on PW 2.x thru 3.x. Is there a really good guide on steps that I need to take to update the core to take advantage of the features of new releases? Are their perils to look out for?
      Yeah, after developing several sites, I feel a bit silly about asking this one, but, the docs doesn't seem to be clear in a "general" sense of upgrading the core across all versions.
      Thanks everyone for your time and assistance.
    • By suntrop
      Hi all
      I have big troubles with my DB backups and phpMyAdmin. I can't manage to import a backup.
      The phpMyAdmin export settings are left to the defaults. The error message I get:
      #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO `caches` (`name`, `data`, `expires`) VALUES ('ModulesUninstalled.in' at line 11 When I delete the complete 'cache' section there are almost for all tables the same errors. (part of the dump attached)
      I had this problem before and back then (couple months ago) I think I copied almost every table individually. I thought it was specific to that DB. But I can't do a dump/import of any of my PW installations.
      MySQL: 5.6.27
      PHP version: 7.0.11
      phpMyAdmin: 4.5.5.1
      Anybody knows that problem? Or what to do?
      phpMyAdmin SQL Dump.sql
    • By vwatson
      Is it possible to add check boxes in order to select multiple backup files and delete them all at once, rather than having to click each one, then Delete?
      Also it would be helpful to make the Restore process more distinct from Deleting.  I must have inadvertently clicked the wrong button once and restored a backup unintentionally, wiping out a day's work. My mistake of course. I obviously wasn't paying close enough attention.  
    • By Fantomas
      Hi all,
      I'm still new to processwire and now I have to create the first hook.
      I need to modify the page-clone module, so there is a field in pages that has to be empty after cloning the page. How could I start this task?