Jump to content

CKEditor Confusion on Deleting Text


vwatson
 Share

Recommended Posts

Let's say I have an H2 element followed by a paragraph tag.

Heading

some paragraph text...

When I delete the heading text, the following paragraph takes on the heading style, as that h tag is not removed from the editor. 

I've tried deleting the heading first, and leaving the heading and backspacing over it from the paragraph, but no matter how I do it, the paragraph turns into an h tag. :(

This is for a township site. I want to make this as easy as possible for whoever will be editing this when I'm finished. The only way I can fix it now is to go into the source code and switch the h tag to a p tag - really not something I want to have them doing!

 

Link to comment
Share on other sites

20 minutes ago, vwatson said:

Oh, yeah, thanks. Why didn't I think of that? :) 

Seems like a bug in the editor. Surprising that it hasn't been corrected.

This sort of thing has been an issue for RTEs forever which is why whenever possible I separate headings into their own field and remove the option for users to style the text (except for bold, italics and inserting special characters and maybe sub and superscript for some sites). I know this isn't always possible, but it's always my preference.

Link to comment
Share on other sites

23 hours ago, adrian said:

I separate headings into their own field and remove the option for users to style the text 

This is a remake of an old site, and they have a lot of articles that have subheadings down throughout the content. I style the main headings in the code, but don't see an easy way to style sporadic additional headings the same way. 

And I was using Chrome. I'll try other browsers and see what happens.

Link to comment
Share on other sites

2 minutes ago, vwatson said:

This is a remake of an old site, and they have a lot of articles that have subheadings down throughout the content. I style the main headings in the code, but don't see an easy way to style sporadic additional headings the same way. 

And I was using Chrome. I'll try other browsers and see what happens.

Agreed it's not really always possible. RepeaterMatrix or even PageTable fields make it possible, but there is always some sort of trade-off :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By nabo
      Hello
      it would be nice if it could be possible to force a unique (or relative) imagefield for CKEditor.
      Example
      Using a repeater matrix (or repeater) with CKEditor field, the primary sources for images are imagefields in the page-repeater fieldset. Obviously I can change the page source, but I need to start from the root and this is not comfortable. In this specific situation the better solution is to have an imagefield in the parent page and force CKEditor to automatically go there... or if you want to have a "media library" go there first.
      Don't know which could be the best "setting system" but in my opinion this is an annoying problem.
    • By fruid
      inserting links i.e. <a>-elements, and only links, inside a CKEditor-summary field outputs the link-text and a weird " /> above the content-div (I'm using markup regions).
      I have no idea where this is coming from, all the other tags work perfectly, and the CKEditor-markup is fine too when adding links. It puts the <a>-element inside a <p> element but should be alright?
      Any hints?
    • By fruid
      I doubt nobody has seen this issue before…
      when I have an <h2> or <h3> or the likes in a CKEditor-body-field and I delete that header, the h-tag is applied to whatever comes next in line. I'm obviously talking about the WYSIWYG-view. Similar bugs occur when applying an h-tag, that tag sometimes encloses the next line as well. Could be that this happens when the next line is in the same "block"-element and not technically a new line but separated with a <br> but not always…
      When will a new version of CKEditor for PW be released or what's a competitive alternative at this point?
    • By Jennifer Stock
      Hi. Sometimes when I select text in a textarea field outfitted with CK Editor, it fails to register as a "Block Style" and therefore the custom styles I have specified for block-level elements are not displayed in the Styles drop-down menu. If I open the page in an incognito window and select the same elements, the Block Style styles appear as expected in the Styles menu.
      Is this a caching issue of some kind? I've played with turning on and off the HTML "quality assurance" options as well as putting my custom styles directly within the CKEditor folder in the /wire directory. Once the field stops registering the selection of block-level elements, it also seems to have simultaneously stripped the custom styles that had been successfully applied to these block-level elements previously.
      Not sure what to do next.
×
×
  • Create New...