Jump to content
FrancisChung

Don't use Resilio Sync. Other recommended tools?

Recommended Posts

Hi there,

I have an older Macbook Pro which I'm trying to use as a Desktop Machine for the occasional work-at-home machine.

I was using Resilio Sync to sync my projects between my main laptop and every time there's a problem with the sync, it seems to delete random files and folders. So anyone using Resilio Sync, think again.

I would have used rsync but if I recall correctly, I couldn't the get the command to work with my other laptop (rsync wouldn't accept my destination path).  I also have some files I sync between the main laptop and my Windows box, so that was another reason why I opted for Resilio Sync at the time.

So after spending a few hours recovering my files today, I've decided enough is enough (3rd time it's failed)  and am looking for a new way to sync files between 2 OSX Laptops and a Windows box.


Anyone have a foolproof, stress-free solution that they use?

Thanks!

Share this post


Link to post
Share on other sites

Hi @FrancisChung This is my favourite:

http://www.scootersoftware.com/features.php

Not just for source files, but: 

" SYNCHRONIZE FOLDERS ...You can efficiently update your laptop, backup your computer, or manage your website, and Beyond Compare will handle all the details. You can copy to and from disks, FTP servers, and zip files, all using the same interface. Anything you don't want affected can be easily filtered out, and all of the powerful comparison techniques are available, making the backup as fast or robust as you need. You can automate repetitive tasks using a flexible scripting language, and any script can be called from the command line, allowing you to schedule your syncs for when it's most convenient."

It is also fast via FTP, and it can handle 10 simultaneous connections if needed, turning it to be the fastest diff/merge tool ever :) but this is only one example. I rarely usef the synchronize folders feature, but that one works well too.

Edited by szabesz
typo
  • Like 1

Share this post


Link to post
Share on other sites

@szabesz  I trialed a few years ago and didn't really like the interface as compared to Winmerge on Windows. Didn't realise they have a OS X Client now.

@adrian  Thanks for the head's up.

I've discovered something called SyncThing so I'll probably look at this first. If I'm not happy with it, I'm definitely getting a commerical solution. 

Edited by FrancisChung
Spelling correction
  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By wbmnfktr
      I know from a trusted source that some of you use Laragon as their prefered Windows DEV solution.
      Due to a recent conversation I noticed that there might be a nice little feature some of you may not know about.
      Laragon offers the Quick app option with some tools already predefined. In order to have ProcessWire there as well you just have to add one (two with a comment) line to your Laragon configuration.
      # ProcessWire ProcessWire=composer create-project processwire/processwire %s
      Just in case you want to start your next project a little bit faster.
    • By kongondo
      I am trying out multi-instance support in a multi-site setup (option #1, multiple databases) on a Windows Machine (but using a LAMP stack). I am getting a Fatal error in ProcessWire.php #line 877, Failed opening required  '/F:/vhosts/sandpit.dev/wire/config.php' (include_path='.;C:\php\pear') in F:\vhosts\sandpit.dev\wire\core\ProcessWire.php on line 877
      I am using the following API
      $path = "F:/vhosts/sandpit.dev/site-mediamanager/"; // OR // $path = "F:\\vhosts\\sandpit.dev\\site-mediamanager\\"; $url = "http://mediamanager.sandpit.local/"; $site = new ProcessWire($path, $url); Here is Line #877
      require("$rootPath/$wireDir/config.php"); In my code, $path is an absolute path on the windows machine. In the above example, I want ProcessWire to find the /site-mediamanager/config.php, which is a multi-site running off one Wire powered through the main /site/.
      As you can see in the error, ProcessWire is adding an extra forward slash to the path, i.e. 
      '/F:/vhosts/sandpit.dev/wire/config.php' 
      instead of 
      'F:/vhosts/sandpit.dev/wire/config.php' 
      which obviously fails. I have traced the origin to line #784 in ProcessWire.php
      $rootPath = '/' . implode('/', $parts); // remove siteDir from rootPath The pre-pended / causes the error. Remove that and multi-instance works fine in my environment.
      Before I report this as a bug, has anyone ran into this issue? Alternatively, could someone on a Windows machine please test the multi-instance feature for me? Maybe even someone using an absolute path on any machine? Preferably test in a multi-site setup (option #1). If this is a bug, it would be nice if it gets fixed before the imminent master release.
      PW version 3.0.85 (but also tested on the latest dev version).
       
      Thanks.
    • By Konrad
      Hello folks, a slightly embarrassing entry on this forum with a failed setup on Xampp - perhaps someone can point me in the right direction?
      I downloaded and installed Xampp for OS X  and this seems to run fine - when I go to http://localhost the Xampp page loads nicely.
      I then went to the Bitnami Xampp page and downloaded the PW Module for OS X. I walk through the install and leave the path to the default /Applications/XAMPP,  enter my OS X admin pass, it then says it will restart the installer, enter admin pass again, leave the path as default and when I click on next it simply does nothing, I can still change the path or cancel the install and that's it.
      Any clues as to what I'm doing wrong? 
      Many thanks!
      Konrad
    • By FrancisChung
      Hi there,
      I was wondering if there's a module that allows me to copy certain pages or content from one instance of Processwire to another instance?
      Unfortunately, I can't copy a whole instance across as there needs to be some major cleanup job performed and it won't get done in time.
      Otherwise, if anyone has any code samples that would be much appreciated.
    • By steveooo
      Hello guys,
      I am using some nested PageTables and with every PageTable field the user clicks on, a modal window appears. Because every modal window's width & height are not 100%, every nesting step shrinks the window.

      Does someone have any solution for this problem?
      Best wishes,
      steveooo
×
×
  • Create New...