Jump to content

"Invalid file extension, please use one of:"


moose1
 Share

Recommended Posts

I just added a file upload field to my detail page template. In the field detail, valid file extensions are: pdf doc docx xls xlsx gif jpg jpeg png.

However, when I go to upload a file to a page - a pdf for example - I get this error:

"pdf is a invalid file extension, please use one of:"

Do I have to somehow whitelist these file-types somewhere in the backend? Or perhaps this is a permissions issue?

Thanks for any suggestions.

post-503-0-58792500-1341933579_thumb.png

Link to comment
Share on other sites

I think your files field may not be fully created yet. Go back to that field in Setup > Fields and hit save. Now try it again.

If you still get the error then go back to that field again, click on it's "details" tab and note the file extensions. Make sure that the file you are uploading is in the list of allowed extensions. Add more extensions as needed and save the field.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ridgedale
      I've been trying to work out how I can provide a frontend file upload (whatever file format the user chooses to upload - albeit not executables!) for registered users to be able to create pages/posts and upload any file they wish so they can create a link to the file so it can either be downloaded or displayed.
      Everything I've read so far appears to relate to just images and uploading and adding images is already covered using the images field.
      Any thoughts/guidance would be a appreciated.
       
    • By cosmicsafari
      Hi All,
      Just a quick question, if a form has an upload field should there be a working link in the subsequent email which allows you to view the uploaded file?
      As it stands only the name and size of the file appears in the email although viewing the source it appears wrapped in anchor tags, albeit without any href attribute.
      I'm not sure if this is the correct result or if I have somehow managed to cause this and there should be a working link to the uploaded file.
       
    • By hellomoto
      I can't find anything about this in the forums or anything, but I have a file field that accepts mp3 files. Trying to upload from an Android phone (I've tried from two) the files aren't accepted, it says they must be mp3 files, but they are, so it's not reading the file extensions I guess... The error names the file name without the extension saying it's missing the extension. Has anyone come across this? Thanks.
    • By sarah_hue
      Hi,
      wow, this is weird: I am running two sites with one ProcessWire installation. Both are using VersionControl module. I moved both sites to another webserver right after installing VersionControl.
      On site #1 ...sometimes (!) file upload is not possible (the pink status bar gets stuck at 100 %) already uploaded files (before moving to the new server) cannot be deleted file descriptions cannot be changed no error messages are given, not even in debug mode While on site #2 ...everything's fine: uploading, deleting, changing the description... I read Douglas' post on a glitch in dev 2.5.19, but I'm using the regular 2.5(.0).
      nghi's post on a similar problem describes pretty much what I'm experiencing here, but if there was something wrong in the suhosin.ini, site #2 would encounter the very same problem.
      If I use VersionControl to set the file field back to an earlier version where the file was not uploaded yet, the file disappears and is deleted from /assets/file/[page-id]/. Same vice-versa when setting to a version before a file was deleted: It is recreated on the page and in the filesystem.
      Permissions are -rw-rw-rw- for all files.
      Any ideas?
      Sarah
×
×
  • Create New...