Jump to content

Debug Filecomputer issue


hellomoto
 Share

Recommended Posts

There is no reason for this to have happened, I was not working on anything related to this:

Quote

Fatal error: Class 'PaymentModule' not found in /Applications/AMPPS/www/hc/site/assets/cache/FileCompiler/site/modules/PaymentInvoice-master/PaymentInvoice.module on line 3

Error: Class 'PaymentModule' not found (line 3 of /Applications/AMPPS/www/hc/site/modules/PaymentInvoice-master/PaymentInvoice.module)

I deleted the site cache and it's still happening. The whole site is broken. This is what happened last time and I had to rebuild. Now I'll have to again. I really need to use version control this time for sure. But nonetheless, I wasn't even working on these files.

Link to comment
Share on other sites

No. I deleted PaymentInvoice.module and it said I had an unclosed comment on the new module I was working on...... so I closed that comment and now the site loads. However if I put PaymentInvoice back in modules, it breaks again with the original error.

I refreshed the modules and put it back, now seems to work. Thanks =[

Link to comment
Share on other sites

  • 1 year later...

Have the same error here:

Quote

Fatal error: Class 'PaymentModule' not found in .../site/assets/cache/FileCompiler/site/modules/PaymentInvoice/PaymentInvoice.module on line 3

And when I deleted the folder FileCompiler/site/modules/PaymentInvoice, the error is:

Quote

Fatal error: Class 'PaymentModule' not found in .../site/modules/PaymentInvoice/PaymentInvoice.module on line 3

At least I was working on something related when it occured the first time: I had placed a copy of PaymentInvoice.module (named PaymentFree, to use with zero amount payments) in the modules directory.

Debug steps so far:

  • Removed PaymentFree.module from modules directory and cache
  • Removed PaymentInvoice.module from modules directory and cache
  • Refreshed modules, everything's fine again (except for not having PaymentInvoice)
  • Put PaymentInvoice.module back in place, above written error comes back.
  • Removed PaymentPaypal and PaymentModule, re-installed both
  • Cleared compiled files on module page: Error reappears, once PaymentInvoice.modules is in the modules directory
  • Installed PaymentInvoice.module from ZIP file: Error reappears

I have the strong feeling the error source is somewhere completely different, but I have no clue how to find it. Only error in logs is the mentioned one.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By luischacon
      Hello how are you, I need help on how I can solve this, update a module and now I don't know what to do

    • By Guy Incognito
      I seem to be running into a repeated fatal error in a fresh PW install version 3.0.148. I can't quite put my finger on the pattern but it seems to be around deleting image fields or removing images from certain image fields.
      This is the trace from the log generated by trying to save a page and delete an image from an image field:
      Fatal Error: Uncaught Error: Cannot access protected property Pageimage::$original in /wire/core/PageimageVariations.php:256 Stack trace: 1. /wire/core/Pageimage.php(1327): PageimageVariations->getInfo() 2. /wire/core/Wire.php(386): Pageimage->___isVariation() 3. /wire/core/WireHooks.php(823): Wire->_callMethod() 4. /wire/core/Wire.php(450): WireHooks->runHooks() 5. /wire/core/Pageimage.php(1369): Wire->__call() 6. /wire/core/Pageimage.php(399): Pageimage->getOriginal() 7. /wire/core/WireData.php(333): Pageimage->get() 8. /wire/core/PageimageVariations.php(256): Pro Line 256 of /wire/core/PageimageVariations.php Earlier in the day I was experimenting with custom fields for images for the first time and kept running into this error, thinking it was me using this feature wrong and not having time to read up I deleted the custom image fields template and went about my business. So now I don't know if I triggered an issue or whether it was never related to the custom image fields in the first place?
      Any ideas?
    • By abdulqayyum
      Hy Processwire community,
      There are some problem in fileCompiler cache.
      when i change under the directory \site\templates\ it must change under the directory /site/assets/cache/FileCompiler/site/templates/
      but it does not update and functionality working with /site/assets/cache/FileCompiler/site/templates/ directory.
       
      In this case please suggest me how i clear fileCompiler cache?
      what i have to clear it manually?
      Thanks AbdulQayyum.
    • By modifiedcontent
      I had upgraded my Apache configuration to include PHP7.2 and PHP7.3 for a Laravel-based script on the same server. Somehow it/I messed up a previously fine Processwire site, in a very confusing way.
      The site still looks fine, but editing template files has no effect whatsoever. It is stuck on some kind of cached version. I have already disabled PHP7's OPcache, cleared browser caches, etc, with no effect.
      The pages now apparently come from PW's assets/cache/FileCompiler folder, even though I never enabled template caching for this site.
      I have tried adding "namespace ProcessWire;" to the top of the homepage template file, but then I get this fatal error:
      My functions.php file pulls data in from another Processwire installation on the same VPS with the following line:
      $othersitedata = new ProcessWire('/home/myaccount/public_html/myothersite/site/', 'https://myothersite.com/'); That apparently still works fine; the site still displays data from the other installation, but via the "cached" template that I am now unable to change.
       
      I don't know where to start with this mess. Does any of this sound familiar to anyone? Any pointers in the right direction would be much appreciated. 
       
      Edit:
      Adding "$config->templateCompile = false;" to config.php results in the same fatal error as above. 
    • By cosmicsafari
      Hi all,
      Starting work for a new client, so pulled down a copy of their existing PW site.
      All looks normal in terms of the codebase structure, set it up as I would normally for any PW site yet I everytime I attempt to view a page I get:
      From what I can gather its running PW version 2.8.
      On the live environment where I copied it from and its working fine, they are apparently running PHP 7.1 whereas I am running PHP 7.3 locally, just incase that may be a cause for the issue.
      Any ideas as nothing seems obvious to me at this point.
       
       
×
×
  • Create New...