Jump to content

404 URL not found after installation.


Speed
 Share

Recommended Posts

Hi Everyone, New here but not new to CMS and Template developing :) . Early today, I've installed PW, it was successful, the result was flawless. But then, I realized I've encounter 404 error and was unable to go into admin. I've spend 4 hours going through troubleshooting guide following this link  http://processwire.com/docs/tutorials/troubleshooting-guide/page3  and I am not getting any luck, so I was hoping I could get some help from you so I can get started with PW :)

First, the PW is running on localhost using MAMP 3.3.2 (free version).  The PW files is located inside MAMP/htdocs as subfolder called pwNew. So obvious inside htaccess the  Rewrite Base command should be 

RewriteBase /pwNew

(of course hashtags has been removed) if I did it right, then it didn't work for me!  So next, I went inside  /apache/conf/httpd.conf and  then changed... 'none' to 'All' 

 

<Directory />
    Options FollowSymLinks ExecCGI
    AllowOverride All
    Order deny,allow
    Allow from all
</Directory>

Unfortunately, it didn't work for me.  I've confirmed twice... the mod_rewrite have been installed, up and running.

Confirmation # 1 running mod_rewrite_test.php with this code below, 

<?php
if(in_array('mod_rewrite', apache_get_modules())) {
  echo 'mod_rewrite is installed.';
} else {
  echo 'mod_rewrite isn't installed.';
}
?>

...and then run it from browser

brower_mod_rewrite.JPG

Confirmation # 2 from phpinfo

apache-mod_rewrite.JPG

I really need your help and hope there are solution for it.

 

Thanks in advance. 

Link to comment
Share on other sites

Hi Speed, welcome to the PW forums :)

I don't have a direct solution to your problem, more a general recommendation based on my experience. I find the development process and (especially) the rollout to a  production environment a lot easier if I develop using a virtual host. That way you're not having to worry about subfolders and localhost and all that; you can access your development site directly at http://my-project/

Here is an article about setting up virtual hosts in the free version of MAMP:
http://foundationphp.com/tutorials/vhosts_mamp.php

Link to comment
Share on other sites

@Speed: you did restart the webserver after changing http.conf, right? I don't know MAMP in particular, but check if there's an "AccessFileName" directive somewhere in the Apache config. It may be looking for htaccess or htaccess.txt instead of .htaccess on Windows since the latter can only be created in a CMD window (I've encountered some Apache bundles over the years that did so).

Link to comment
Share on other sites

Robin S, BitPoet, and Szabesz, thank you for responding.  Although Virtual host worked!  I've followed this clear and precise tutorial https://www.taniarascia.com/setting-up-virtual-hosts/ . Test confirmed when I added index.php alone and typed <?php "Hello World" ?>

 

However, new problem arises. After copy/paste PW files into local hoses... Typed "mylocal:8888" on address bar. I end up with "index of/" page. The PW did not initiate installation.  I've tried add "mylocal:8888 index.php" and "mylocal:8888 \index.php" I end up divert to google search.  I've restarted MAMP server nothing happens.  How can I get PW to initiate installation? 

Here's some information. 

processwire's  directory C:\MAMP\processwire

httpd.conf

<VirtualHost *:8888>
  ServerName mylocal
  DocumentRoot "C:/MAMP/processwire"
</VirtualHost>

host

127.0.0.1  mylocal

 

Link to comment
Share on other sites

Oh I feel stupid :(,

From httpd.config The processwire document root is set at C:\MAMP\processwire

 MAMP server Preference > (Tab) WebServer the document root is set  \MAMP\htdoc.  

I have changed it into C:\MAMP\processwire and it initiate install.php

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By daniel_puehringer
      Hi Community,

      Sadly I cannot intall ProcessWire on my webserver (Hosted at https://www.world4you.com/de/startseite.html, a small hosting provider in Austria)
      Here is the Problem: 
      1. I downloaded the current masterbranch as a .zip file (After a few tries I also downloaded the code via the git clone command, that led to the same error), unzipped it and transferred it to my server. Since there is already a wordpress site installed on the root directory, I transferred the processwire files into /relaunch and created a subdomain.
      2. I tried to install the language starter kit. As soon as I navigate to that folder Screenshot1 (see attached file 'processWireBug1') is shown. Everything looks nice, except the red text referring to the 'mod_rewrite' rule. The webserver provides the 'apache mod_rewrite' rule.
      3. As soon as I want to press 'Check again' or 'Continue to next step' an error Page with 500 error (see Screenshot 'processWireBug2') occurs.
      4. You can find my .htaccess file attached to this post..htaccess

      How could I solve this issue?

      Some additional information:
      1) the webserver provides the apache mod_rewrite (I checked that several times) and has php version 7.3. installed.
      2) since there is a wordpress site installed on the root directory, there is also a .htaccess file on the root directory. Could this .htaccess file have an impact on the .htaccess file for my processwire website?

      Thanks for your help and greetings from Austria,
      Daniel


    • By gswoodman
      Hello all,
      I have recently installed ProcessWire as I am learning to develop my own personal website.
      The installation process was completed, pressed 'Login to Admin' and I am receiving a 404 error.
      I am using a GoDaddy Shared Hosting Package with Plesk installed.
      Does anyone have any experience with using ProcessWire on a shared hoasting package?
      Many Thanks.
    • By rolspace.net
      Hi Everyone
      I have a problem here. I have built a site with Processwire on localhost and then transferred to my customer's server. a) it's a windows server (unfortunately) and b) there is a domain-mapping for this site, the domain points to a folder of another domain. Sorry, I can't explain it any better, I don't really understand the different types of servers (why do they have to be different anyway...).
      My problem is, that I see the main website but not the admin page. Do I have to add anything to my .htaccess file?
      I also tried to include web.config file. Not .htaccess nor web.config file have an impact when changing its content. I really have no clue what to do!!
      Links: mcconnellacademy.ch, mcconnellacademy.ch/admin
      Thanks for any pointing in the right direction!
    • By z0rk
      I've just installed the latest version of PW on debian 8 with apache2. The install went flawless; no errors. After the install completed I tried to access /processwire/ and failed with a 404 error. The home page of the site displays, but all links fail with 404 errors.
      Research suggests to edit .htaccess to make sure RewriteBase poinst to [path]/processwire/. I did that, but access to /processwire/ is still failing. I've also tried to enable AllowOverride All in the apache2 configuration file, but to no avail.
      Any suggestions?
      Thanks
    • By naruttam
      The Processwire version is ProcessWire 2.4.0 © 2015
      When attempting to save edits to the page, instead of getting the pw success message, I get the 404 page not found page.  
      This page in question cannot be deleted, moved, edited...nada.
      Page edit takes me to: http://www.mydomain....e/edit/?id=5772
      When I attempt to save the edits the address bar still says:
      http://www.mydomain....e/edit/?id=5772 but it displays the 404 Page Not Found page and changes are not saved.

      Also disabled Modsecurity on the server. Any ideas please
×
×
  • Create New...