Jump to content

AdminOnSteroids


tpr

Recommended Posts

  • 3 weeks later...

Hey @tpr - not sure what its purpose is, but:

html.aos {
    overflow: overlay;
}

does weird things to fixed position elements. For example, when Tracy is disabled, the icon that appears in place of the debug bar (to re-enable it) is positioned under the vertical scrollbar. If I remove this overflow rule, it is positioned as expected.

image.png.e71b3c8d00f12af1e15452edabdc171e.png

Thanks!

Link to comment
Share on other sites

Hi @tpr,

I found an irritating behaviour when using the submodule ListerTweaks. If I make a custom selection of the Users lister columns,

Screenshot1.png

it will not be reflected in the columns selection on the Users page:
There the default selection is displayed, and trying to change it has no effect.

Screenshot2.png

Link to comment
Share on other sites

  • 4 weeks later...

Hi, @tpr and thanks you for adding this useful module.
After switching on AdminOnSteroids I noticed a small problem appearing when opening and closing the repeater, but only in Mozilla Firefox and Admi Theme Uikit. After opening the single repeater, it remains in the open position.
I'm not fluent in JS and I do not know where the error is, but the console shows me information as below.

Error: Permission denied to access property "apply"

Admin-on-steroids.thumb.gif.043b81476e905d2468529feb4f4967ba.gif

SERVER DETAILS
ProcessWire: 3.0.126
PHP: 7.3.1
Webserver: Apache/2.4.35 (Win64) OpenSSL/1.1.1a
MySQL: 5.7.24

MODULE DETAILS
AdminOnSteroids: 2.0.13
ProcessTracyAdminer: 1.0.6
TracyDebugger: 4.17.22

Link to comment
Share on other sites

I'm not sure but perhaps it's a cross-domain issue, perhaps caused by a Firefox addon, I got the idea from here:

Quote

This only happens with Firefox addons that try to insert a <script> tag that points to an external cross-domain script.

 

  • Like 2
Link to comment
Share on other sites

What do you think about appending the field type to the Fields asmSelect list options? I often don't remember the type by the name so it would come handy. However, since it's a plain select HTML element it cannot be styled and in the rendered asmSelect the type appears twice (also at the end of the bars).

asmfieldtypes.gif

  • Like 4
Link to comment
Share on other sites

Actually having the field type appended to the name is quite handy when used together with the "add search box to asmSelect" feature because field types can also be searched.

So for example you can easily find CroppableImage3 image o CKEditor fields, etc, which is a huge help when there are a lot of fields.

image.png.6476b86c88f263cdfc408b4cf3af351f.png

  • Like 3
  • Thanks 1
Link to comment
Share on other sites

OK, due to the popular demand towards this feature it's been added to v2.0.14 🙂 

Some changes:

  • the new suffix contains the field type (eg. "Textarea"), and the inputfield class if it's different from it (eg. "CKEditor")
  • the optional inputfieldClass is not added if it's the language variant (to avoid situations like "excerpt - TextareaLanguage (Textarea)"
  • on the right side of the bars the original field type string is removed (before the percentage) not to display it twice

image.thumb.png.d05432f32b4e1fa2f5015653e464629e.png

  • Like 7
Link to comment
Share on other sites

Hello!

I'm brand new to ProcessWire (having been a Joomla! guy for many years and then adding Wordpress to my toolkit more recently). I've taken on a new client and their site uses ProcessWire. Last night I got the joy (lol) of moving their site to my large VPS and learning the ins and outs of PW. They were running PHP 7.0 and I bumped them to PHP 7.3. After fixing a bunch of front end issues with their theme, everything looks good except that in the admin, AdminOnSteroids is throwing some notices:

PHP Notice: Trying to get property 'template' of non-object in .../AdminOnSteroids/AdminOnSteroids.module:2970   
PHP Notice: Trying to get property 'name' of non-object in .../AdminOnSteroids/AdminOnSteroids.module:2970

Does anyone know how to fix this? I can hack my way around some PHP, but I'm not a programmer, so this one is a bit beyond my understanding. Any help would be appreciated.

Link to comment
Share on other sites

@Brian Peat Hello Brian,

Welcome to the forum & thank you for your first post. I hope @tpr - the author of this module - picks this up quickly for you (he's usually very responsive.) Although I'm reluctant to suggest a fix for that line in the module (I'm not wholly familiar with TPR's intention there and simply suppressing the notice might be hiding a larger issue) I do hope you end up enjoying working with ProcessWire and interacting here in the forums!

Best wishes,
Steve

Link to comment
Share on other sites

@Brian Peat welcome. One thought regarding the module: what version is the AOS module?  When going in admin under modules site adminonsteroids, there is a feature to directly check for newer versions. Maybe you are not running the latest version, where these issues are already fixed? At least there is no harm with updating AOS to the latest.  

 

Link to comment
Share on other sites

  • 2 weeks later...

Hey there. This morning I upgraded AOS for a project to latest version 2.0.15 and started noticing some issue viewing the hidden/unpublished pages in the admin. Tried to uninstall the module and grabbed a fresh copy, however the same issue appeared.

image.png.bde7d15019041782c808cedf7d7b3d1d.png

If I move my mouse over those that are not showing but only ID's are listed, they all appear fine:

image.png.483693e33aa5f9976094218a237677bb.png

Started disabling options of AOS in order to check which one would be causing the issue and it appeared that it is the PageList tweaks and more specifically: Show page IDs (SuperUser only) . I did not set any other options, however if I remove this one, the list shows properly. The issue seems to appear on both themes - default and uikit. Any ideas how could I keep the page ID's showing but keeping the hidden pages visible? Is this a feature/option I've missed or else?

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...