tpr

AdminOnSteroids

Recommended Posts

Hi @theo,

please try this and see if you can manage to make it work.

What would be handy here having an ajax button to check whether these assets exist.

AdminOnSteroids.module

Share this post


Link to post
Share on other sites
13 hours ago, tpr said:

Hi @theo,

please try this and see if you can manage to make it work.

What would be handy here having an ajax button to check whether these assets exist.

AdminOnSteroids.module

Thank you Roland.

But I can't make it work.

I show you what I did to test it. There are 6 "echos" marked like (0) ... (5). Code snippet is from about line 989 of the module.

        echo $root.' (0)<br>';
        echo $rootPath.' (1)<br>';

        // remove install subdirectory
        $rootPath = rtrim($rootPath, $root);
        echo $rootPath.' (2)<br>';

        $rootUrl = $this->config->urls->httpRoot;
        $rootUrl = rtrim($rootUrl, $root);

        $templatesUrlRelative = $this->config->urls->templates;
        
        echo $rootUrl.' (3) <br>';
        echo $templatesUrlRelative.' (4)<br>';

        // do not add JS to page on login page
        if ($this->page->id != 23) {

            // custom CKEaddons config js and css

            $ckeCSS = $this->getAssetPath('CKEStyle', 'admin/cke.css', $templatesUrlRelative, $configData, $root);
            $ckeJS = $this->getAssetPath('CKEScript', 'admin/cke.js', $templatesUrlRelative, $configData, $root);
            $ckeTemplates = $this->getAssetPath('CKEtemplates', 'admin/templates.js', $templatesUrlRelative,
                $configData, $root);
                
            echo $rootPath . $ckeJS.' (5)<br>';

This outputs:

/~theo/pw3061/ (0)
/home/theo/public_html/pw3061 (1)
/home/theo/public_html (2)
http://localhos (3)
/~theo/pw3061/site/templates/ (4)
/home/theo/public_html/~theo/pw3061/site/templates/admin/cke.js (5)

Where settings are:

Assets Root Path: /home/theo/public_html/pw3061/

CKEditor custom configuration script: /site/templates/admin/cke.js

 

Thank you.

Share this post


Link to post
Share on other sites

I'm thinking of removing the default paths and load only files that the user has written something into the inputs, and also remove the file_exists() limitation. So it would be entirely the user's responsibility to add an asset that is surely available (to avoid 404s).

Share this post


Link to post
Share on other sites
3 minutes ago, tpr said:

I'm thinking of removing the default paths and load only files that the user has written something into the inputs, and also remove the file_exists() limitation. So it would be entirely the user's responsibility to add an asset that is surely available (to avoid 404s).

I don't know PW well enough, but isn't there a setting anywhere to get or set (in my case:)

rootURL: http://localhost/~theo/pw3061/

rootPath: /home/theo/public_html/pw3061/

It think this would be handy in many situations. I'm usually setting such values in init.php, but it should probably go to config.php as a PW standard variable.

Or does sth. like this already exist?

 

Share this post


Link to post
Share on other sites

AFAIK you can overwrite some paths/urls but I wouldn't use it if not necessary (to avoid breaking things).

I'll implement the idea I wrote above, that would simplify things a lot (although autoloading assets will be gone).

Share this post


Link to post
Share on other sites
1 hour ago, tpr said:

I'll implement the idea I wrote above, that would simplify things a lot (although autoloading assets will be gone).

OK, thank you.

Share this post


Link to post
Share on other sites

Here are the updates. You can use absolute (fully qualified) or relative paths (relative to site root).

aos-assetpaths.gif.86282f210bcb85034d5dbbda9825827a.gif

 

aos-assetpaths.zip

  • Like 1

Share this post


Link to post
Share on other sites
On 14.5.2017 at 10:16 PM, tpr said:

Btw there are a few filterboxes: a "general" one for datatables, one for the Language Translator and one for File fields, are you covering them all?

Yes, i try to support all filterboxes. Sadly right now I am busy with some projects. Hope I find the time to finish this soon.

  • Like 1

Share this post


Link to post
Share on other sites

The last update made Notices appear at some of our websites (not on all):


Notice: Undefined index: CKEStyle in /Users/.../site/modules/AdminOnSteroids/AdminOnSteroids.module on line 1012

Notice: Undefined index: CKEScript in /Users/.../site/modules/AdminOnSteroids/AdminOnSteroids.module on line 1012

Notice: Undefined index: CKEtemplates in /Users/.../site/modules/AdminOnSteroids/AdminOnSteroids.module on line 1012

Notice: Undefined index: AdminStyle in /Users/.../site/modules/AdminOnSteroids/AdminOnSteroids.module on line 1012

Notice: Undefined index: AdminScript in /Users/.../site/modules/AdminOnSteroids/AdminOnSteroids.module on line 1012

Share this post


Link to post
Share on other sites

Thanks, please re-download (only .module file was changed).

  • Like 1

Share this post


Link to post
Share on other sites

A new pagelist action "Refresh" will be added in the next update. This refreshes the displayed page data in the page list + reloads children too. Can be useful if you renamed or deleted pages in another browser tab and would like to save a page reload :) 

aos-refresh-action.gif

  • Like 1

Share this post


Link to post
Share on other sites

hi @tpr

i just found a bug when using latest version of AOS (just did the update from 1.4.1 to 1.4.6). it also existed in the later version.

i have a repeater including an image field and an "editor" role with edit-access for the home-template (and all children). the problem is that the image in the repeater field gets uploaded and after reaching 100% disappears. i did some debugging and i found out the following:

  • aos uninstalled: works
  • aos installed: does not work (either enabled or disabled)
  • upload as superuser works at all setups
  • ajax error after fileupload: {"error":false,"message":"The requested process does not exist"}
  • when i try to edit the repeater item directly ( /admin/page/edit/?id=1024&InputfieldFileAjax=1 ) in the admin i get this error:
    59317c4d1da3b_2017-06-0216_54_51-ProgramManager.png.416cf1bd70f1a500fee7a57143be2282.png
 
i hope i was clear enough with my informations so that you can fix this as easy as possible :) if you need more information just let me know!
 
PS: regular image fields outside repeaters work as expected

Share this post


Link to post
Share on other sites

I have a site with similar editor role and could not reproduce the issue. You could try uncommenting things above these lines in init() and ready() functions and see where it fails:

if (!$this->enabled) {
	return;
}

Only lines above these will be run if you have disabled AOS in its settings page.

By any chance have you added new permission from these pre-defined ones? I had a site where "page-edit-created" caused similar issues if I remember right.

new-roles.thumb.png.b234308988efc9e5a206df516892f856.png

Share this post


Link to post
Share on other sites

thanks for your answer. i tried it on a fresh install on my local dev and had the same issue. i created a zip of the installation so you can try:

https://transfer.sh/eAZ7L/reptest.zip (8,5MB)

admin url /processwire

admin
admin!

test
tprtest1!

reptest.gif.f70de65905220ec95829c5ce3c34811b.gif

Share this post


Link to post
Share on other sites

Thanks! Could you try replacing the line 408 with this, and check if it fixes the issue and doesn't break other things? I clicked around in the admin and everything seems to be fine (in another PW).

Update: there was an issue with the previous fix, pls try this (lines 408-414):

        $editedPageId = $this->input->get->id ? $this->sanitizer->int($this->input->get->id) : false;

        if ($editedPageId && is_numeric($editedPageId) && $this->pages->find('id=' . $editedPageId . ',check_access=0')->count()) {
            $this->editedPage = $this->pages->find('id=' . $editedPageId . ',check_access=0')->first();
        } else {
            $this->editedPage = null;
        }

 

Share this post


Link to post
Share on other sites

Hi @tpr, I spotted an issue with the position of the InputfieldPageListSelect restore icon when the inputfield's width is not the last/only inputfield in a row:

2017-06-08_121232.png.61e391db43d0b800e7bc14c5aa272f7c.png

I fixed it with this:

html.aos .InputfieldPageListSelect { position:relative; }
.aos_pagelist_unselect.restore { right:0; transform:none; -webkit-transform:none; }

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, this part was always buggy but I think I've found a better way, namely floating clear btn and pagelist to the left, and setting pagelist width using calc(). It's OK here in Firefox and Chrome, even with long page titles, could you try?

unselect-placement.thumb.png.ac12031b3f4377807a29250df6877dcd.png

AdminOnSteroids.css

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, tpr said:

It's OK here in Firefox and Chrome, even with long page titles, could you try?

Works great, thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Hi,
I having a problem with image field inside a repeater field and with extra image fields and user profiles and the AdminOnSteroids.

With the superuser profile there is no problem, but the user has other profile then superuser the image in the repeater field does not show the image after upload and do not save the image and the extra image fields does not show correctly  (each language in a row) and the internal link selector does not work and does not show any error.

After a week trying to understand why the non superuser users where not able to upload the images and creating new fields to verify if the originals ones where with some kind of problem I come to the conclusion that the problem where not the fields on them selfs but with some module that was causing this behavior.

After trying to disable the module a tweak the AdminOnSteroids configurations the only thing that work for me was to uninstall the module and the users can upload the image the the extra image fields show correctly.

Its is a great module and I hope you can resolve this issue.

Thank you

Share this post


Link to post
Share on other sites
3 hours ago, vmo said:

having a problem with image field inside a repeater

It's the same issue as of @bernhard's, could you try the fix I posted on June 2?

  • Like 1

Share this post


Link to post
Share on other sites

sorry for my late reply! your fix didn't work for me. curious if it helps vmo...

Share this post


Link to post
Share on other sites

@tpr, I've been having a look at the images-in-repeater issue for non-superusers (I discovered this one a while back but forgot to report it here, sorry :().

-----

Edit: I did report it over in the Github repo.

Edit 2: looking at some PM history it looks like a solution (same intent but different implementation to that proposed below) was found but never merged into the repo?

-----

As you found, the $this->editedPage property is the source of the issue. Seeing as the things this property is used for within the module either don't work within repeaters (e.g. field edit links) or aren't needed for repeater pages (e.g. breadcrumb features) I think $this->editedPage should never be set to a repeater page. But it's much easier to exclude repeater pages in ready() because in init() it is not yet known which class a page is an instance of. So could $this->editedPage be set in ready() instead?

This is what I did in my testing and it seems to work okay:

public function init()
{
    // removed code that sets $this->edited page
    
    // populate self::$configData
    self::$configData = $this->modules->getModuleConfigData($this);
    
    // ...
    
    // a bit further down we need to change $configData[$subModule] to self::$configData[$subModule]
public function ready()
{
    // set $this->editedPage
    // excluded repeater pages, minor refactoring
    $this->editedPage = false;
    $editedPageId = $this->sanitizer->int($this->config->input->get->id);
    $editedPage = $this->pages->get($editedPageId);
    if( $editedPage->id && !($editedPage instanceof RepeaterPage) ) $this->editedPage = $editedPage;

    self::$configData = $this->modifyConfigData(
        $this->modules->getModuleConfigData($this),
        $this->editedPage
    );
    
    // ...

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Soma
      LogMaintenance
      A simple ProcessWire module to give some maintenance control over log files. I found myself often having lots of log files for different things that can grow more or less quickly to a size where they can be difficult to maintain. The built in Logger of PW does a good job of giving you the possibility to delete or prune logs. But it has to be done manually and sometimes a log grows into millions of lines, which makes it often impossible to even prune it as it's too large.
      LogMaintenance uses LazyCron to run the maintenance task and there's several settings you can setup on a global or per log basis.
      Archive: will create zip files for each log file in logs/archive/ folder and add the log each time the maintenance is run to a subfolder containing the datetime.
      Lines: keeps logs to a certain number of lines 
      Days: keeps the log to a certain number of days
      Bytes: keeps the log to a certain amount of bytes
      Each setting is checked from top down, the first setting to contain something is used. So if you check the "Archive" option, all other settings are ignored and logs are archived everytime the LazyCron is executed. If you want to keep your logs to a certain amount of bytes just leave all other settings to 0 or blank.
      Per Log Settings
      There's a textarea that you can use to setup a config for a specific log file one per line. All the logs you define here ignore the global settings above. The syntax for the settings is:
      logname:[archive]:[lines]:[days]:[bytes] 
      errors:1:0:0:0 // would archive the errors log messages:0:10000:0:0 // will prune the errors log to 10000 lines  
      The module can be found on github for you to check out. It's still fresh and I'm currently testing.
      https://github.com/somatonic/LogMaintenance
    • By teppo
      Fieldtype Page IDs is a third party Fieldtype that, simply put, stores Page references as integers (Page IDs).
      This fieldtype was built as a quick and dirty workaround for Page Reference fields' inability handle self-references due to circular reference issues. A project I've been working on for a while now includes a combination of RepeaterMatrix content blocks and tagging/categorization system that would've resulted in a lot of duplicate pages (and plenty of unnecessary manual work for content editors) had I used built-in Page Reference fields, and thus a new Fieldtype felt like the most sensible approach.
      Fieldtype Page IDs was designed to be loosely compatible with Page References in order to make conversions between the two feasible, but it is quite limited feature wise:
      largely due to the fact that stored values are actually just integers with no connection to Pages whatsoever some advanced selectors and related features are not supported, and page values can't be directly accessed configuration settings are limited to the bare essentials (selector string and Inputfield class) only a handful of Inputfields (AsmSelect, Checkboxes, Text) are (currently) supported Anyway, in case you need to store Page IDs (and Page IDs only) and are happy with the limitations mentioned above, feel free to give this Fieldtype a try. It has been working fine for me in one particular project, but hasn't been tested that much, so please tread carefully – and let me know if you run into any issues.
      GitHub repository: https://github.com/teppokoivula/FieldtypePageIDs
      Modules directory: https://modules.processwire.com/modules/fieldtype-page-ids/
    • By daniels
      This is a lightweight alternative to other newsletter & newsletter-subscription modules.
      You can find the Module in the Modules directory and on Github
      It can subscribe, update, unsubscribe & delete a user in a list in Mailchimp with MailChimp API 3.0. It does not provide any forms or validation, so you can feel free to use your own. To protect your users, it does not save any user data in logs or sends them to an admin.
      This module fits your needs if you...
      ...use Mailchimp as your newsletter / email-automation tool ...want to let users subscribe to your newsletter on your website ...want to use your own form, validation and messages (with or without the wire forms) ...don't want any personal user data saved in any way in your ProcessWire environment (cf. EU data regulation terms) ...like to subscribe, update, unsubscribe or delete users to/from different lists ...like the Mailchimp UI for creating / sending / reviewing email campaigns *I have only tested it with PHP 7.x so far, so use on owners risk
      EDIT:
      I've updated the module to 0.0.4. I removed the instructions from this forum, so I don't have to maintain it on multiple places. Just checkout the readme on github 🙂
      If you have questions or like to contribute, just post a reply or create an issue or pr on github. 
    • By bernhard
      WHY?
      This module was built to fill the gap between simple $pages->find() operations and complex SQL queries.
      The problem with $pages->find() is that it loads all pages into memory and that can be a problem when querying multiple thousands of pages. Even $pages->findMany() loads all pages into memory and therefore is a lot slower than regular SQL.
      The problem with SQL on the other hand is, that the queries are quite complex to build. All fields are separate tables, some repeatable fields use multiple rows for their content that belong to only one single page, you always need to check for the page status (which is not necessary on regular find() operations and therefore nobody is used to that).
      In short: It is far too much work to efficiently and easily get an array of data based on PW pages and fields and I need that a lot for my RockGrid module to build all kinds of tabular data.

      Basic Usage

       
      Docs & Download
      https://modules.processwire.com/modules/rock-finder/
      https://gitlab.com/baumrock/RockFinder/tree/master
       
      Changelog
      180528, v1.0.4 add custom select statement option 180516 change sql query method, bump version to 1.0.0 180515 multilang bugfix 180513 beta release <180513 preview/discussion took place here: https://processwire.com/talk/topic/18983-rocksqlfinder-highly-efficient-and-flexible-sql-finder-module/
    • By blynx
      Hej,
      A module which helps including Photoswipe and brings some modules for rendering gallery markup. Feedback highly appreciated
      (Also pull requests are appreciated 😉 - have a new Job now and don't work a lot with ProcessWire anymore, yet, feel free to contact me here or on GitHub, Im'm still "online"!)

      Modules directory: http://modules.processwire.com/modules/markup-processwire-photoswipe
      .zip download: https://github.com/blynx/MarkupProcesswirePhotoswipe/archive/master.zip
      You can add a photoswipe enabled thumbnail gallery / lightbox to your site like this. Just pass an image field to the renderGallery method:
      <?php $pwpswp = $modules->get('Pwpswp'); echo $pwpswp->renderGallery($page->nicePictures); Options are provided like so:
      <?php $galleryOptions = [ 'imageResizerOptions' => [ 'size' => '500x500' 'quality' => 70, 'upscaling' => false, 'cropping' => false ], 'loresResizerOptions' => [ 'size' => '500x500' 'quality' => 20, 'upscaling' => false, 'cropping' => false ], 'pswpOptions' => (object) [ 'shareEl' => false, 'indexIndicatorSep' => ' von ', 'closeOnScroll' => false ] ]; echo $pswp->renderGallery($page->images, $galleryOptions); More info about all that is in the readme: https://github.com/blynx/MarkupProcesswirePhotoswipe
      What do you think? Any ideas, bugs, critique, requests?
      cheers
      Steffen